Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9873 Discussions

Problems with Adafruit LCD

New Contributor I


I have an Adafruit ILI9341 and using it in 8bit parallel mode (trying to). I tried using the driver and sample code ( Display driver code and test program) from this page Edidoom : Intel Edison based video game console playing Doom.

I imported it into Eclipse and it didn't compile. I installed cygwin64 and MinGw, but it's still complaining that it cannot find g++.

Is the problem with tool chain? What should my ToolChain settings be? and the latest issue is during build i get "cc1plus.exe has stopped working"

Has anyone had similar experience?


3 Replies

Hello inteliot,

How did you set up Eclipse? If the problem is the toolchain, then you should be able to resolve the issue by following section three of Native Applications Guide for Boards and Kits.

Anyhow, I'd personally suggest you to compile the project on the Edison itself mainly because eclipse projects are stored temporarly on the Edison and will be erased on the next boot.


New Contributor I

Hello Peter,

thanks for the link - i'm looking through that and will report back here.

New Contributor I

I followed documentation, but that did not help compile, however it did clear up some other strange things that were happening...

but i found the solution to the original problem in this thread: /thread/61564?start=0&tstart=0

and used File -> New -> Other... -> Intel(R) IoT Developper Kit -> Intel (R) IoT C/C++ project.

to create a new project . after that I was just getting "nullptr not defined"

I don't know why it is not recognizing nullptr. After I defined it, it works (compiles, builds and runs) - this is probably not the best practice to define again, but works for now.


On another note, I noticed that the Edison IOT dev kit installation (w_iot_2015.0.031.exe, that includes the drivers, IOT dev kit, Eclipse) does not install Eclipse properly unless you have winzip on your system. The error I get is something along the lines of corrupted archive (only for eclipse)...but after installing winzip and running installation again, it worked just fine. the downside is that if you do a standalone installation of Eclipse, you have to start it using the batch file, instead of Eclipse icon (at least that's how it was for me).

Anyone know if this is expected behavior? If so, maybe it should be added to instructions.