Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMate3
Novice
1,424 Views

RTC problem

Hi.

I plugged the rechargeable Battery to V_VBAT_BKUP pin Digi-Key: 728-1057-ND.

RTC work fine when I use edison image (kernel version 3.10.17). But when I use edison image (kerrnel version 3.10.98) RTC stop (save last time).

What could be the reason?

7 Replies
idata
Community Manager
31 Views

Hi mat03,

 

 

Thank you for contacting us.

 

As far as I'm aware, there's no issue with the RTC on the Edison's latest image. I checked the release notes and there isn't any mention of any RTC issues either. Would you please share more information on how you're testing the RTC on the latest image? If you include pictures of your configuration, the commands you're using and how you're testing the RTC it'd be of great help.

 

 

Also, make sure that the rechargeable battery connected to V_VBAT_BKUP is providing enough power according to the specifications of the hardware guide http://www.intel.com/content/www/us/en/support/boards-and-kits/000005808.html http://www.intel.com/content/www/us/en/support/boards-and-kits/000005808.html .

 

 

We'll be waiting for your response.

 

 

-Sergio

 

MMate3
Novice
31 Views

Hi.

I connected battery to Mini Edison Breakout. Battery go to J18 pin 5 (v_vbat_bkup) and battery go to J19 pin (gnd).

I connected edison to internet "configure_edison --wifi". I waited when time is set "timedatectl".

To disconnected from internet I wrote "cp /etc/wpa_supplicant/wpa_supplicant.conf.original /etc/wpa_supplicant/wpa_supplicant.conf", next

"systemctl stop wpa_supplicant", next "systemctl disable wpa_supplicant".

When edison was offline (I tried ping 192.168.1.1 a few times) I unplugged all micro USB cable. I waited 20 minutes and pluged micro USB cable to edison. Next I check time "timedatectl"

I charged battery to full and I measured voltage in battery all the time.

Best mat03

idata
Community Manager
31 Views

Hi mat03,

 

 

Thank you for providing a detailed description of your test. The method you used should work. What's the voltage ratings of the battery you're using?

 

 

To configure the date try to use the commands

 

date 120213302016 (MMDDhhmmYYYY) hwclock –systohc

 

 

Let us know if this works for you.

 

 

-Sergio

 

idata
Community Manager
31 Views

Do you still need assistance with this case? What were the results of trying our latest suggestion?

 

 

-Sergio

 

MMate3
Novice
31 Views

Hi,

I checked commands and everything it's the same. Edison loses time.

Best mat03

idata
Community Manager
31 Views

Hi mat03,

 

 

We'll investigate further on your issue. We'll come back once we have more information. Thank you for your patience.

 

 

-Sergio

 

idata
Community Manager
31 Views

Hi mat03,

 

 

We have tested the RTC on Edison with image versions 25.5 and release 3.5. and cannot reproduce the described behavior, both versions keep the set RTC. The only difference to your setup is the coin battery that is being used, we used a CR2032 rated at 3.0V with a 210mAh capacity.

 

 

Also, please note that the hardware guide states "This backup subsystem allows for interruption of the main supply for a short period of time, such as changing a main system battery", which is what you may be experiencing after ~20 minutes.

 

 

-Sergio