Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RKasu
New Contributor I
1,862 Views

Regarding Intel studio set-up

Hai Everyone,

I'm using Intel breakout board with yocto image.I have downloaded the Intel studio setup for linux (64 bit) from https://software.intel.com/en-us/iot/software/ide https://software.intel.com/en-us/iot/software/ide.I have the following questions,please do needful.

1)I'm trying to get the output of led mraa program which was imported.The error I'm getting is libmraa object file missing and there is no output on my breakout board.I'm following the same procedure given in the links.

2)when I'm opening the Iot Sensor support in order to see the sensors configured,I'm getting the blank space there,I'm not getting any sensors there,How can I get the sensor names there.

3)I'm little bit confused of the software,so Can I have detailed description of the documents providing the following details

  • dependencies of the software.
  • after building where can I see the binary files.
  • integration of new sensors and adding the files.
  • why I'm getting the errors of mraa library.
  • why I'm getting error if I build the program again.
  • Is it valid for both Intel arduino board and breakout board.

Please do needful,Thanks in advance.

Thanks and Regards,

Radhika

0 Kudos
5 Replies
idata
Community Manager
38 Views

Hi Radhika.k,

 

  1. Which image are you using? Also, could you please provide the link to the tutorial you're following to get the output of the LED, I would like to see the instructions that you're following. A picture of the error you're getting would also be of help. Also, make sure to update your existing version of mraa and upm, this might be causing the issue.
  2. Regarding the sensors issue, make sure that the sensors you're using are supported in the UPM library, https://github.com/intel-iot-devkit/upm/ https://github.com/intel-iot-devkit/upm/. Check this guide in case you haven't seen it before, https://software.intel.com/en-us/working-with-sensors-in-intel-system-studio-iot-edition https://software.intel.com/en-us/working-with-sensors-in-intel-system-studio-iot-edition.
  3. I'm not sure I understood your last request, do you want documentation on those subjects? Or do you have some documentation already and want us to help you with it?

Regards,

 

-Pablo

RKasu
New Contributor I
38 Views

Hi Pablo,

Thanks for giving reply,I'm using the image from http://git.yoctoproject.org/cgit/cgit.cgi/meta-intel-edison/about/ meta-intel-edison - Layer for the Intel Edison Development Platform on Intel edison arduino expansion board and I have updated the libraries of upm and mraa too.I followed the steps of the link https://software.intel.com/en-us/blinking-an-led-using-c-with-intel-system-studio-iot-edition IoT - Blinking an LED using C/C++ | Intel® Software ,I'm using normal c/cpp not gateway ,but the output is that the target image is not updated and libmraa.so.1 cannot open shared object file ,then I created the custom repository following the link https://software.intel.com/en-us/updating-upm-and-mraa IoT - Updating and selecting update options for the UPM and MRAA libraries | Intel® Software

but there is no output ,the errors I have got are there in the screenshots and I thought to update mraa and upm libraries following from the steps

echo "src mraa-upm http://iotdk.intel.com/repos/3.0/intelgalactic/opkg/i586 http://iotdk.intel.com/repos/3.0/intelgalactic/opkg/i586" > /etc/opkg/mraa-upm.conf 

opkg update

 

opkg install mraa

 

opkg install upm

 

but even then the same errors and there is no output on led .and Regarding the sensors also I didn't see any sensor names and the sensor related screenshots also pinned below.

Please refer the tar file of screenshots pinned below.Please do needful.Any and every help is appreciated.Thanks in advance.

Thanks and Regards,

Radhika.

RKasu
New Contributor I
38 Views

Hai Pablo,

Please consider the above reply too and I thought if there is problem of python but there is no output and the same error ie,libmraa.so.1 cannot find the object file.

In /etc/opkg/ base-feeds.conf initially there are no links and I added the links below on base-feeds.conf

src/gz all http://repo.opkg.net/edison/repo/all http://repo.opkg.net/edison/repo/all

src/gz edison http://repo.opkg.net/edison/repo/edison http://repo.opkg.net/edison/repo/edison

src/gz core2-32 http://repo.opkg.net/edison/repo/core2-32 http://repo.opkg.net/edison/repo/core2-32

and in iotkit-conf also I added the link in iotkit-conf

src iotkit http://iotdk.intel.com/repos/2.0/intelgalactic http://iotdk.intel.com/repos/3.0/intelgalactic

and there is the output shown in the screenshots and the links which are added are active when I use ping on another tab.

The zip folder of the screenshots is pinned below

 

Hope the opkg is updated and Inte iot studio works without errors,Any and everyhelp is appreciated,Thanks in advance.

Thanks and Regards,

Radhika

idata
Community Manager
38 Views

Hi Radhika,

 

 

Thank you for the images. I'm still unsure about what image you're using, the number that you're providing is related to the kernel but no the image directly.

 

Could you please download this image? http://iotdk.intel.com/src/3.0/edison/iot-devkit-yp-poky-edison-20160315.zip http://iotdk.intel.com/src/3.0/edison/iot-devkit-yp-poky-edison-20160315.zip. I would like you to try what you've been trying previously, I just want to see if you get the same errors, I'm wondering why you're unable to update mraa and upm, and I would like to handle that first.

 

 

Regards,

 

-Pablo
idata
Community Manager
38 Views

Hi Radhika,

 

 

Any updates on this case?

 

 

Regards,

 

-Pablo
Reply