Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9881 Discussions

Regression in BIOS v0026 - V0029 fixes

New Contributor I

In the new v0026 BIOS for the STK1AW32SC, the ability to sync a Bluetooth keyboard to the BIOS (enabling use of a Bluetooth keyboard in the BIOS) no longer works:

In "Bluetooth Configuration", selecting (with USB keyboard or mouse) "Scan Device" does nothing. It doesn't even attempt the scan.

This used to work in BIOS v0024, and indeed going back to v0024 fixes the problem.

The Release Notes for v0026 say "Fixed a Bluetooth keyboard sync issue."

Oh, really?

Edit: The scan will occur in v0026 if there is already a configured Bluetooth device. However, if that device is deleted, then there appears to be no way to start a scan for new devices, other than going back to v0024.

Also, in going back and forth between v0024 and v0026, I have lost the ability to display the BIOS function key menu (eg, F2, F7, F8, F10), even after a "restore factory defaults".. Those keys still work when rebooting; it's just the menu that doesn't appear. The "3-second power-button" procedure does display its menu. I even tried going back to v0019 and restoring factory defaults, but still no boot menu.

Of course, booting works fine, and the BIOS screens are all fully functional (except for the v0026 Bluetooth device scan).

Message was edited by: Dean Gibson

0 Kudos
5 Replies
Community Manager

Hello DeanGibson,

I would recommend updating the BIOS using the recovery method, downgrade the current version to 024 and then with a BIOS recovery jump to 026. If by any chance there was a corrupted file, the BIOS recovery should address this. See here for the instructions BIOS Recovery Instructions for Intel® Compute Stick.



New Contributor I

OK, I downloaded the BIOS recovery files SC0024.BIO and SC0026.BIO, and used the BIOS Recovery process on both files, in succession:

  1. Immediately after applying the BIOS Recovery process, I noted that the BIOS function key menu (eg, F2, F7, F8, F10) appeared, but after I applied my usual BIOS settings, it disappeared. To make a long story short, once I enabled "Secure Boot", the BIOS function key menu disappeared (but the function keys continued to work). I found that, in the "Secure Boot Configuration" section, I had previously selected "Install Intel Platform Key". Once I selected "Force Secure Boot Defaults", the BIOS function key menu appeared on subsequent restarts. The question is, why does installing the "Intel Platform Key" disable the BIOS function key menu (but not the function keys!)
  2. The problem with "Scan Device" in "Bluetooth Configuration" remains: "Scan Device" in v0026 does nothing if there is not already a Bluetooth device listed. However, in using the "Power On menu", I found that the newer BIOSes (probably starting with v0019) will allow Bluetooth keyboard pairing as part of that "Power On" menu, and that is sufficient to get access to (and navigate within) the BIOS screens. So, this is an effective workaround (at least for me) for a real bug introduced in v0026.

Anything you can point me to, to find out about the "Intel Platform Key" mechanism (and whether I should use it), is welcome. I believe in hardening access to all my computers, using Secure Boot and whatever other security mechanisms are available. I use BitLocker encryption on all my Windows 10 systems except the STK1AW32SC (which does not have a TPM).


Hey Dean, thanks for the good information.

I'll see if I can reproduce your issues here and let you know.

in the meantime, we've posted BIOS 0029: Download BIOS Update [SCCHTAX5.86A] can you give that a try and let us know?

For the TPM info, you can start here: Intel® Trusted Platform Module User Guide

New Contributor I

From the v0029 :

New Fixes/Features:

 Security enhancements.

 Added android option.

 Update TCG to TCG10.

 Added item for PTT enable/disable.

 Added BT scan device solution.

Note the last item. This fixes the Bluetooth "Device Scan" I reported in this thread.

Note the penultimate item: Enabling PTT ( Trusted Platform Module Information ) and then booting Windows 10 reveals a TPM !!!

I've upgraded the STK1AW32SC to Windows 10 x64 Professional and enabled BitLocker (using the "TPM") on the SSD !!!

However, I would still like an answer to "Anything you can point me to, to find out about the "Intel Platform Key" mechanism (and whether I should use it), is welcome." The "Intel Platform Key" is not the same as the TPM (which I have some familiarity with). I read the document you referenced, and did not find a reference to the "Intel Platform Key".


Good to know 0029 fixed the Bluetooth issue, thank you for the feedback.

Here's more about PTT: Intel® Platform Trust Enabler | Product Guide