Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,734 Views

Running a .jar file on galileo gen 2

I've been trying to run a .jar file on my galileo gen 2. I followed instructions from https://docs.oracle.com/javame/8.3/get-started-galileo/installing-java-me-embedded-software-intel-ga... MEEGG-GUID-2A673D59-05EE-48B1-9C6E-D37A35CF1B34 Installing the Java ME Embedded Software on the Intel Galileo Gen2 Board for installing Java ME Embedded. I'm getting the error-

detect_fb_type: unknown device type

on running usertest.sh. How can that be fixed and are there any alternatives to running a .jar file on the galileo?

0 Kudos
5 Replies
FTinetti
Honored Contributor I
40 Views

Hi mehak,

Remember that Java ME is not a full Java, so maybe your .jar requires more than java ME to work. I'd suggest you check the source/project from which you got the .jar in order to see whether your .jar requires "more than" java ME. Or maybe I did not understand your post, and you are asking about a problem installing the Java ME itself... you let me know.

HTH,

Fernando.

idata
Community Manager
40 Views

Hello mehak,

 

 

I was wondering if you could check the comments made by FGT.

 

 

If you have any update or question, don't hesitate to contact us.

 

 

Regards,

 

Andres V.
idata
Community Manager
40 Views

Thanks for the reply FGT

 

Yes, you were right. The .jar file specifically requires jdk-8 to run. Although the error (detect_fb_type: unknown device type) was during installation of java ME.
FTinetti
Honored Contributor I
40 Views

I see, it seems to be that it is possible to install jdk8 in Intel Galileo, or at least it is what I understand from , even when I've never tried it, though.

HTH,

Fernando.

idata
Community Manager
40 Views

Hello mehak,

 

 

I was wondering if you could check the last suggestion provided by FGT.

 

 

If you have any update or question, don't hesitate to contact us.

 

 

Regards,

 

Andres V.
Reply