Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,568 Views

SSH Handshake Timeout

I'm trying to get started with the Edison and have had a lot more trouble than I feel like I should be having. The first issue was that the latest Yocto image was a bigger file size than the Edison had memory, but after manually flashing the older image was able to set up wifi using XDK. However, when I try to connect to the Edison in XDK as an IoT device, I get an error saying timeout while waiting for SSH handshake. I then tried using Arduino to get something working, but got a similar timeout error when trying to upload a sketch. Could the issue be with not using the latest image? Any other suggestions?

Probably the most frustrated I've ever been trying to get started with a new board :/.

9 Replies
Highlighted
Employee
23 Views

Hello MattMuell,

In fact the latest image is bigger than Edison's drive storage, but it can be flashed using Flash Tool Lite. You can find this tool and a guide on how to use it in http://software.intel.com/en-us/iot/hardware/edison/downloads Intel® Edison Downloads.

SSH needs a password to work correctly, have you set a password on your Edison? In case you haven't, I'd suggest you to access your Edison's terminal as shown in https://software.intel.com/en-us/get-started-edison-windows-step3 Set up a serial terminal and set it up by entering the command configure_edison --setup and following the on-screen steps. Once the password is set try again.

If you have already set a password, are you able to access your Edison through SSH using PuTTY? Or, do you get the same behavior?

When you tried to use the Arduino IDE, which version of the Arduino IDE were you using? Could you show us a screenshot of the issue you are getting and of your PC's device manager?

Peter.

0 Kudos
Highlighted
Employee
23 Views

Hi MattMuell,

Have you been able to flash and use your board? Did you try with Peter's suggestions?

Let us know which Arduino IDE version you are using.

Regards,

Charlie

0 Kudos
Highlighted
Novice
23 Views

Hello,

Sorry for the delay on this. I'm getting "Flash failed" when I try using Phone Flash Tool Lite (is that the right one?). I would see it connect for a split second and then say disconnected, but it was still showing up in my devices in Finder (I'm on a Mac). I erased the image (previous version of Yocto) that was currently on the Edison before using Flash Tool Lite, is that right?

 

I set up a password for my edison and have no problem logging into root login with serial terminal, and typed it in when trying to connect with SSH in XDK. I'm installing xcode now and will follow up later this afternoon about whether I can SSH in that way.

 

I'm using Arduino version 1.5.3-Intel.1.0.4. This is what I get when I try to upload a sketch (I have to force quit each time):

 

Binary sketch size: 76,099 bytes (of a 10,000,000 byte maximum) - 0% used

starting download script

# !/bin/sh

#

echo "starting download script"

Args to shell: /Users/MatthewMueller/Downloads/Arduino Edison.app/Contents/Resources/Java/hardware/tools/x86/bin /var/folders/8v/9x86tdbn2r1cqdrghx0ck4nm0000gn/T/build4436598569593246658.tmp/Blink.cpp.elf /dev/tty.usbserial-DN00QA9R

echo "Args to shell:" $*

Serial Port PORT (note: should be /dev/cu.xxxxxx for OSX)

#

Using tty Port /dev/tty.usbserial-DN00QA9R

# ARG 1: Path to lsz executable.

Sending Command String to move to download if not already in download mode

# ARG 2: Elf File to download

# ARG 3: TTY port to use.

#

# path may contain \ need to change all to /

path_to_exe=$1

fixed_path=${path_to_exe//\\/\/}

#

tty_port_id=$3

echo "Serial Port PORT" $com_port_id "(note: should be /dev/cu.xxxxxx for OSX)"

echo "Using tty Port" $tty_port_id

#

echo "Sending Command String to move to download if not already in download mode"

echo "~sketch download" > $tty_port_id

 

Here's a picture of the intel with the old firmware re-flashed on it:

Any other suggestions?

Thanks for your quick responses!

Best,

Matt

0 Kudos
Highlighted
Novice
23 Views

Hello,

Sorry for the delay on this. I'm getting "Flash failed" when I try using Phone Flash Tool Lite (is that the right one?). I would see it connect for a split second and then say disconnected, but it was still showing up in my devices in Finder (I'm on a Mac). I erased the image (previous version of Yocto) that was currently on the Edison before using Flash Tool Lite, is that right?

 

I set up a password for my edison and have no problem logging into root login with serial terminal, and typed it in when trying to connect with SSH in XDK. I'm installing xcode now and will follow up later this afternoon about whether I can SSH in that way.

 

I'm using Arduino version 1.5.3-Intel.1.0.4. This is what I get when I try to upload a sketch (I have to force quit each time):

 

Binary sketch size: 76,099 bytes (of a 10,000,000 byte maximum) - 0% used

starting download script

# !/bin/sh

#

echo "starting download script"

Args to shell: /Users/MatthewMueller/Downloads/Arduino Edison.app/Contents/Resources/Java/hardware/tools/x86/bin /var/folders/8v/9x86tdbn2r1cqdrghx0ck4nm0000gn/T/build4436598569593246658.tmp/Blink.cpp.elf /dev/tty.usbserial-DN00QA9R

echo "Args to shell:" $*

Serial Port PORT (note: should be /dev/cu.xxxxxx for OSX)

#

Using tty Port /dev/tty.usbserial-DN00QA9R

# ARG 1: Path to lsz executable.

Sending Command String to move to download if not already in download mode

# ARG 2: Elf File to download

# ARG 3: TTY port to use.

#

# path may contain \ need to change all to /

path_to_exe=$1

fixed_path=${path_to_exe//\\/\/}

#

tty_port_id=$3

echo "Serial Port PORT" $com_port_id "(note: should be /dev/cu.xxxxxx for OSX)"

echo "Using tty Port" $tty_port_id

#

echo "Sending Command String to move to download if not already in download mode"

echo "~sketch download" > $tty_port_id

<p sty...
0 Kudos
Highlighted
Employee
23 Views

Yes, you are correct, you should be using Phone Flash Tool Lite, however if it fails as you described, it is recommended to use the instead.

Were you able to SSH into your Edison? In case you didn't, did it make a difference to update the image?

Regarding the Arduino IDE, you are using a very old version, I'd suggest you to either use https://downloadcenter.intel.com/download/24355/Intel-Arduino-IDE-1-6-0 Intel® Arduino IDE 1.6.0 or https://www.arduino.cc/en/Main/Software the latest Arduino IDE but if you choose the latter you will have to manually add Edison to the IDE unlike on version 1.6.0. Also, which board and port did you select when you grabbed that log?

Peter.

0 Kudos
Highlighted
Novice
23 Views

Hi Peter,

I'm getting this when I try the alternate flashing method but nothing appears in the Edison disc when it appears again in my finder:

wr-130-64-194-68:edison-iotdk-image-280915 Matthew$ ./flashall.sh

Using U-Boot target: edison-blankcdc

Now waiting for dfu device 8087:0a99

Please plug and reboot the board

dfu-util: Device has DFU interface, but has no DFU functional descriptor

Flashing IFWI

dfu-util: Device has DFU interface, but has no DFU functional descriptor

Download [=========================] 100% 4194304 bytes

Flashing U-Boot

Download [=========================] 100% 237568 bytes

Flashing U-Boot Environment

Download [=========================] 100% 65536 bytes

Flashing U-Boot Environment Backup

Download [=========================] 100% 65536 bytes

Rebooting to apply partition changes

Now waiting for dfu device 8087:0a99

dfu-util: Device has DFU interface, but has no DFU functional descriptor

Flashing boot partition (kernel)

Flashing rootfs, (it can take up to 5 minutes... Please be patient)

Rebooting

U-boot & Kernel System Flash Success...

Your board needs to reboot to complete the flashing procedure, please do not unplug it for 2 minutes.

wr-130-64-194-68:edison-iotdk-image-280915 Matthew$

I re-copied the old image onto the edison, following http://www.intel.com/content/www/us/en/support/boards-and-kits/000005801.html these instructions, then tried the new version of Arduino with the same response appearing in the log (connecting to Intel Edison board in a cu.usbserial-xxx port).

 

After setting up the wifi again with XDK I was able to SSH into the Edison by realizing that XDK was recognizing the Edison on the wrong server. I am able to connect in the SSH Terminal, but am getting "Error: (SSH) Channel open failure: Connection refused" when I try to connect to it as an IoT device.

Any other suggestions?

 

Thank you,

Matt

 

0 Kudos
Highlighted
Employee
23 Views

Which image are you using? You can find this out with the command configure_edison --version. Also, I would like to check your Edison's IP address and your PC's IP address. You can get the Edison's IP address with the command ifconfig wlan0, your computer's IP address should also appear if you enter the command ifconfig on its terminal.

Peter.

0 Kudos
Highlighted
Novice
23 Views

Looks like image 159 and IP address 130.64.194.101. It shows up with the different IP under IoT Devices, but doesn't connect either when I add it manually with the correct IP address.

My IP address is 130.64.194.68

Thanks!

0 Kudos
Highlighted
Employee
23 Views

It is not normal to find an extra IP address (that appears to belong to nothing) in the XDK. In that case I'd assume that something might have gone wrong during the XDK's installation and I would try to install it again. I also noticed that you are using version 159, this is not the latest version, the latest version is 159.devkit, you can get this image in http://software.intel.com/en-us/iot/hardware/edison/downloads IoT - Intel® Edison Board Download | Intel® Developer Zone, flashing this image might also help you.

Peter.

0 Kudos