Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,222 Views

STCK1A32WFC Won't work anymore

Hi, I have a STCK1A32WFC that was working fine with Windows 10 for almost a year. Suddenly today, the start screen won't load anymore. Every time I press the power button the blue led is on, but it won't show anything on the screen. I tried:

- Changing Power Wall Outlet

- Changing USB Cable

- Changing HDMI input on TV (TV has 4 HDMI it doesn't work on any of them)

- Plugging it to an external PC monitor

Nothing works, the stick only shows a blue led, and nothing happens. What can it be? Do I need to ask for a replacement?

Thanks!

0 Kudos
6 Replies
Highlighted
Novice
9 Views

This seems to be an issue of the windows update. In my Family someone (with a Lenovo Notebook) have the same issue. Ask Microsoft support how to solve!

0 Kudos
Highlighted
New Contributor I
9 Views

Have you tried pressing and holding F2 (with a USB keyboard attached) after power on, in order to get into the BIOS?

0 Kudos
Highlighted
Beginner
9 Views

When I connect it to my TV, I get a "No Video Signal" message.

I'm not even able to see the start screen with the Intel Logo, tried pressing the "Power-ON/OFF" button for 3 seconds like it says on the Bios Update tutorial, no luck.

Tried pressing F2 as soon as I turned it ON, nothing. Blue led always on, nothing else... not even the fan seems to work.

Don't know what the problem is yet.

0 Kudos
Highlighted
New Contributor I
9 Views

You are using the original power supply and not a USB cable to a hub or different power supply, correct? I had problems using anything but the Intel power supply.

0 Kudos
Highlighted
Beginner
9 Views

Dean Gibson wrote:

You are using the original power supply and not a USB cable to a hub or different power supply, correct? I had problems using anything but the Intel power supply.

Yes, I'm using the power supply that came in the box. Using original USB cable also.

0 Kudos
Highlighted
Community Manager
9 Views

Hello Arielcan,

 

 

At this point, it is possible that your Intel® Compute Stick is defective. I suggest you to get a replacement for the unit, you can submit a warranty replacement for the unit at the following link:

 

https://customercare.intel.com/?lang=en-US https://customercare.intel.com/?lang=en-US

 

 

Regards,

 

 

Ivan

 

0 Kudos