Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
834 Views

Sample application ExGroveStarterKit on latest build of Eclipse gets undefined symbol...

https://software.intel.com/en-us/user/1115428 Aaron N. Mon, 03/30/2015 - 14:41

The sample application ExGroveStarterKit on latest build of Eclipse gets undefined symbol during download. Do I need to link a library for this? If so, where is the library and how do I reference it?

Build works fine, but this is the output I get at launch.

mailto:root@three root@three:~# echo $PWD'>'

 

/home/root>

 

mailto:root@three root@three:~#

 

mailto:root@three root@three:~# chmod 755 /tmp/ExGroveStarterKit;/tmp/ExGroveStarterKit ;exit

 

/tmp/ExGroveStarterKit: symbol lookup error: /tmp/ExGroveStarterKit: undefined symbol: _ZN3upm11GroveButtonC1Ej

Thanks, Aaron

0 Kudos
3 Replies
Highlighted
New Contributor I
2 Views

Re: Sample application ExGroveStarterKit on latest build of Eclipse gets undefined symbol...

Aaron N. Mon, 03/30/2015 - 14:45

Please see attachment for selecting this project using File/New/Intel IoT C++ Project....

0 Kudos
Highlighted
2 Views

Re: Sample application ExGroveStarterKit on latest build of Eclipse gets undefined symbol...

https://software.intel.com/en-us/user/1007941 Raghu Kona (Intel) Mon, 03/30/2015 - 15:12

Can you please check the version of your mraa library on the Intel Edison board (connecting via SSH or Serial)

Current version is

mailto:root@edison root@edison:/tmp# opkg info libmraa0

 

Package: libmraa0

 

Version: 0.6.1

mailto:root@edison root@edison:/tmp# opkg info upm

 

Package: upm

 

Version: 0.1.9

If you are not using the latest, upgrade by using these commands

opkg updateopkg upgrade

0 Kudos
Highlighted
New Contributor I
2 Views

Re: Sample application ExGroveStarterKit on latest build of Eclipse gets undefined symbol...

https://software.intel.com/en-us/user/1115428 Aaron N. Mon, 03/30/2015 - 16:19

Raghu,

That did the trick, and the application now loads and runs fine. Thanks!

-Aaron

0 Kudos