Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NZ1
Novice
2,758 Views

Starting Eclipse from the .bat

So I've followed the instructions on how to set up an IDE for the Edison however whenever I try to start it from the .bat file I get

I've installed the latest version of Java but is there something else that I specifically need to do in order for it to find the proper version? Any help would be appreciated.

20 Replies
Sergio_A_Intel
Employee
397 Views

Hi,

Do you have a 32 or a 64 bit machine? Are you following this guide https://software.intel.com/en-us/installing-the-eclipse-ide IoT - Installing the Eclipse* IDE | Intel® Developer Zone ? What version of the Windows OS are you using?

Have you tried to install Eclipse with the Unified Installer https://software.intel.com/en-us/iot/hardware/edison/downloads IoT - Intel® Edison Board Download | Intel® Developer Zone

Sergio

NZ1
Novice
397 Views

I am running windows 10 64 bit and I was following https://software.intel.com/en-us/iot/library/edison-getting-started IoT - Intel® Edison Board Get Started Guide | Intel® Developer Zone which included downloading the unified installer and later going through the guide for installing Eclipse, though I did not download eclipse from the installer. I also went back and installed it through the Unified Installer but I get the same error when I start eclipse.

MGilm
New Contributor I
397 Views

I'm having the same (or similar) problem and started a thread last week. No answer yet that solves anything.

I too downloaded the "Integrated Installer" but it seems to NOT provide anything WRT Eclipse (so I don't know we are told to use the Integrated Installer for an improvement). That IDE needs to be downloaded separately and apparently independently, one must also install java (JDK)

None of the "suggestions" provided in that error window actually help.

Sergio_A_Intel
Employee
397 Views

What is the result of double clicking in C:\Intel\iotdk-ide-win\devkit-launcher.bat? Do you have the .bat file in the same directory?

Sergio

NZ1
Novice
397 Views

I've tried running it from there too but I still run into the same issue.

MGilm
New Contributor I
397 Views

I've not been able to get rid of the "java error".

Since I am trying to use the C/C++ path, I've been able to ignore it.

Sergio_A_Intel
Employee
397 Views

Did you install the latest Java from http://www.oracle.com/technetwork/java/javase/downloads/index.html Java SE - Downloads | Oracle Technology Network | Oracle ?

The error message also says "ensure Java is in PATH". Are you sure you set Java in the correct PATH?

Sergio

NZ1
Novice
397 Views

I do have the latest version and I have tried adding a PATH environment variable that leads to where Java is but none of that seems to have worked.

Sergio_A_Intel
Employee
397 Views

I had no issues installing or running the eclipse IDE by clicking the bat or running it from cmd.

I have java SE Development Kit 8 update 65 (64-bit)

Windows 10 64 bit.

Make sure to have the right JDK, and take a screenshot of the installed programs window with the JDK highlighted.

Sergio

NZ1
Novice
397 Views

The versions of java I have are

So I do have the 64 bit jdk also the PATH variable i created is

Could I have done that wrong?

Sergio_A_Intel
Employee
397 Views

I installed the Eclipse on a second Windows 10 system and I am still not able to reproduce your issue.

How are you installing Eclipse, have you uninstall and re-install it using the installer? http://downloadmirror.intel.com/25384/eng/w_iot_2015.0.028.exe http://downloadmirror.intel.com/25384/eng/w_iot_2015.0.028.exe

Where are you installing the program? Try installing it on a path without spaces, such as: C:\Intel-Dev\iotdk-ide-win

Sergio

JPeep
Novice
397 Views

Hi Sergio,

 

I am having the same trouble except with Windows 7 64 bit. Could you please provide a little more detail with what the path should be etc? This is where I am at now:

My path to the program is: C:\Intel\iotdk-ide-win (no spaces)

I created a path to Java as the user above did.

This is the version of Java I downloaded online. Is this the error?

Any help would be appreciated.

 

Very respectfully,

Jordan

MGilm
New Contributor I
397 Views

Jordan1850 wrote: "please provide a little more detail with what the path should be"

I agree. It's not really satisfying to read "ensure java is in Path". (as it says in the command shell)

What is "java" - a specific file, or perhaps a folder that holds that specific file, or perhaps that folder's folder?

For example, is the PATH entry:

C:\Program Files\java ?

or C:\Program Files\java\jdk1.8.0_66 ?

or C:\Program Files\java\jdk1.8.0_66\bin ?

or C:\Program Files\java\jre1.8.0_66 ?

-Mike

Sergio_A_Intel
Employee
397 Views

Try doing something like this: Go to Control Panel > System > Advanced system settings > Advanced > Environment Variables then add a New System Variable called JDK_HOME.

It will look something like this:

In the variable value you have to set the address where you installed the jdk.In my case it is C:\Program Files\Java\jdk1.8.0_65

Let me know your results

Sergio

JPeep
Novice
397 Views

That is exactly what I had in place from copy and pasting the path:

I noticed this, "super important note for windows users" regarding this process:https://learn.sparkfun.com/tutorials/programming-the-intel-edison-beyond-the-arduino-ide/toolchain-e... Programming the Intel® Edison: Beyond the Arduino IDE - learn.sparkfun.com

I couldn't figure out how to carry out the instructions that followed. I'll email the author of that article.

Thanks,

Jordan

JPeep
Novice
397 Views

Hi Sergio,

I have had no luck with this. Does this indicate any action that I could take that you're aware of?

Thank you,

Jordan

Sergio_A_Intel
Employee
397 Views

I can see you still have the variable name PATH. Use the variable name JDK_HOME instead of PATH with the same variable value. I also found a document with several Eclipse common errors and solutions. Take a look at https://software.intel.com/en-us/eclipse-for-iot-troubleshooting-and-faq# I_cant_open_Eclipse IoT - Eclipse* for Intel® IoT Platforms Troubleshooting and FAQ | Intel® Developer Zone . Your window error message is one of the sections. Make sure you've completed all the suggestions.

Sergio

JPeep
Novice
397 Views

Hi Sergio,

 

I can not open eclipse by double clicking its icon, but it then tells me to close it and proceed to open it with the batch file. The link you provided didn't help me.

Here is my java version (I corrected my path). My java version wouldn't even show up in the command prompt window until I changed the PATH to the following:

Do you think I need to modify the batch file?

Thanks,

Jordan

Sergio_A_Intel
Employee
397 Views

Try with the following suggestions:

-remove all JDK and JRE and install only the latest JDK and JRE. Make sure only one is installed.

-add the installation path of the JDK to the end of the PATH variable (see attached images)

-open eclipse and add the JDK path in: Windows -> Preferences -> Java (see screenshot)

Sergio

JPeep
Novice
162 Views

Hi Sergio,

Thank you very much for bearing with me. Uninstalling all of my versions of Java, reinstalling the specified ones, and specifying the path did most of the work. After all that when I double clicked the devkit-launcher the window opened and disappeared without launching eclipse. I tried launching it from the command prompt, but it said that 'find' was not recognized etc. I then opened the batch file and removed this line:

java -version 2>&1 | find "64-Bit" >nul:

I replaced it with the following line:

java -version 2>&1 | C:\Windows\System32\find "64-Bit" >nul:

After that when I double clicked the batch file it said that it could not find the eclipse.exe file in this path.

The eclipse.exe file was actually stored in a subfolder so I edited the START line of the batchfile to have the correct path:

"C:\Intel\iotdk-ide-win\eclipse-win\eclipse.exe"

Now it works perfectly!

Thanks again and merry Christmas/Happy holidays,

Jordan

Reply