Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MTubb
Beginner
7,301 Views

The BSS Type Is Not Valid

Hello everyone!

Just received my ICS M3 with Windows 10. So far everything has been going quite well, until I tried to connect its integrated wireless to an adhoc network.

Here is what I've done so far:

I went into Network Sharing and setup a connection to a wireless network manually.

 

From CMD, I type in netsh wlan show networks interface = "Wireless Network Connection" and I can see the SSID of the adhoc network I would like to connect to.

 

The command I need to execute next is netsh wlan set profileparameter connectiontype=ibss connectionmode=manual where is being replaced by the SSID I named the new network created within the Network Sharing window.

 

When I attempt to run the above command, I get the error: Failed to modify the profile. Error 0X8000D. The BSS type is not valid.

I am at a loss at this point, since windows 10 does not allow simple connections to adhoc wi-fi networks, I need to configure it manually this way. I know that this method works, as I've completed these same steps in my HP laptop, also running Windows 10.

I have the most recent wireless drivers installed for the ICS - Intel Dual band Wireless-AC 8260 Version 10.40.0.9.

Any help or guidance would be hugely appreciated.

-Mitchell

0 Kudos
4 Replies
HLind2
Beginner
1,761 Views

Hi!

I ran in to the same issue trying to connect to a IBSS network on Windows 10 using Intel Dual band Wireless-AC 8260 Driver 18.40.0.9.

Checking

netsh wlan show wirelesscapabilities

WDI Version (Windows) : 0.1.0.1

WDI Version (IHV) : 0.1.0.1

Soft AP : Not supported

IBSS : Not Supported

Rolling back to 18.33.0.1 (Windows 8.1) driver enables what's needed to connect:

WDI Version (Windows) : 0.0.0.0

WDI Version (IHV) : 0.0.0.0

Soft AP : Supported

IBSS : Supported

To rollback:

  1. Install the 8260 driver for Windows 8.1 on your Windows 10 https://downloadcenter.intel.com/download/25799/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo... Download Intel® PROSet/Wireless Software and Drivers for Windows 8.1*.
  2. Device Manager,
  3. right-click on your Wireless Network Adapter,
  4. Update driver software,
    1. Browse My Computer for driver software,
    2. Let me pick from a list of device drivers on my computer,
    3. Choose your older driver,
    4. Next,
    5. Close
  5. Verify using netsh:
    1. netsh wlan show wirelesscapabilities
    2. netsh wlan show driver

My guess is that Intel removed SoftAP, Hosted Network support from their latest driver as IBSS (https://msdn.microsoft.com/en-us/library/windows/hardware/ff560650(v=vs.85).aspx Native 802.11 Miniport Drivers (Windows Drivers) ) is deprecated by Microsoft and might stop working by upgrading Windows in a unknown future.

MTubb
Beginner
1,761 Views

Thanks for the info, Hugo.

I've removed all traces of the original driver and installed the 18.33.0.1 driver and my settings now match what you show they should. I was also able to set the IBSS parameter as well.

It's important to not that the ProSet wireless software does not allow this. Anyone who wants to fix the same problem I had needs to install ONLY the driver.

I'll test the connection to the ad hoc network later today when it is recreated. If it works as expected, I'll mark your answer as correct. If not, I'll be back with more information!

Again, thanks a bunch!

-Mitchell

idata
Community Manager
1,761 Views

Hello, All:

Thank you for your feedback, this is really helpful.

Regards,

Amy.

DWolf2
Beginner
1,761 Views

You sir deserve a medal of some kind. Thank you so very much! I was ripping out my hair at this point.

Now I am able to connect to Adhoc networks with my Dual Band Wireless-AC 3165 without any problems.

Reply