Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9882 Discussions

Transfer incomplete Intel Galileo Gen 2 with SD Card


Hi everyone!

Well I just got an Intel Galileo and want to use it with a bigger Linux image and controle it by console. I saw a lot of tutorials like this one: but it is giving me a "Transfer incomplete" when I try to upload an sketch to configure Ethernet port in Galileo.

I want to use PuTTY for connection and for this I'm trying to connect by Ethernet. What I have done this far:

  1. Downloaded Linux image (from here: /docs/DOC-22226
  2. Insert SD Card on Galileo
  3. Turn on the Galileo
  4. Wait a while and then connect USB cable on client port
  5. Connect Ethernet between computer and Galileo
  6. Check that port appeared in "Device Manager" (it appears at COM4)
  7. Opened Arduino 1.6 (Menu>Tools>Board>Intel° Galileo Gen 2 | Menu>Tools>Port>COM4)
  8. Made this sketch :

void setup() {

// Start the Telnet Server on Galileo

system("telnetd -l /bin/sh");

//Give Galileo eth0 an IP Address

system("ifconfig eth0 netmask up");


void loop() {

// put your main code here, to run repeatedly:


But I'm having this log:

Sketch uses 80,322 bytes (0%) of program storage space. Maximum is 10,000,000 bytes.

# !/bin/sh

# clupload script to invoke lsz

starting download script

# Copyright (C) 2014 Intel Corporation

# ... Here goes all the license, but I didn't want to insert it

echo "starting download script"

echo "Args to shell:" $*

# ARG 1: Path to lsz executable.

# ARG 2: Elf File to download

# ARG 3: COM port to use.

# path contains \ need to change all to /



Deleting existing sketch on target

# COM ports are not always setup to be addressed via COM for redirect.

# /dev/ttySx are present. Howwever, COMy -> /dev/ttySx where x = y - 1



echo "COM PORT" $com_port_id


echo "Converted COM Port" $com_port_arg "to tty port" $tty_port_id

echo "Sending Command String to move to download if not already in download mode"

echo "~sketch downloadGalileo" > $tty_port_id

# Move the existing sketch on target.

echo "Deleting existing sketch on target"

"$fixed_path/lsz.exe" --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" <> $tty_port_id 1>&0

^XB00000000123273^XB00000000123273Retry 0: Got TIMEOUT

^XB00000000000000^XB00000000000000Retry 0: Got TIMEOUT

Transfer incomplete

# Execute the target download command

# Download the file.


"$fixed_path/lsz.exe" --escape --binary --overwrite $host_file_name <> $tty_port_id 1>&0

^XB00000000000000^XB00000000000000Retry 0: Got TIMEOUT

^XB00000000000000^XB00000000000000Retry 0: Got TIMEOUT

Transfer incomplete

# mv the downloaded file to /sketch/sketch...

0 Kudos
2 Replies

Hello Yamil_elias,

You can access the console through the serial port. You only need a FTDI cable. Please check the following document for additional details about the serial port and the FTDI cable: Intel® Galileo Boards and Kits — Console Serial Cables

On the other hand, I would say, according to your description, that the board is not booting correctly from the SD Yocto image. Could you please take a screenshot of the content of the SD Card? Sometimes, after decompressing the files, some of them are decompressed incorrectly causing the board not booting properly.




Well I solved my issue in other way. I don't own an FTDI cable, that's why I tried to do it by telnet. Anyways, I solve it by connecting a micr USB cable (my phone's charger) to the Intel Galileo and (with the drivers already installed in my computer) it detect it as a Port:

But that was only for connection. About my issue with the Incomplete Transfer it wasn't detecting the Yocto Image. The issue was in the grub.conf file (Located in /boot/grub/). How I solve it was changing only one word in the code to Mass Storage:

default 1

timeout 1

color white/blue white/cyan

title Clanton SVP kernel-MassStorage initrd-SPI IMR-On IO-APIC/HPET NoEMU

kernel --spi root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 reboot=efi,warm apic=debug rw

initrd --spi

title Clanton SVP kernel-MassStorage initrd-MassStorage image-full IMR-On IO-APIC/HPET NoEMU debug

root (hd0,0)

kernel /bzImage root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 reboot=efi,warm apic=debug rw LABEL=boot debugshell=5 rootimage=image-full-galileo-clanton.ext3

initrd /core-image-minimal-initramfs-clanton.cpio.gz

And that's all I hope it helps another one in the same trouble as me.