Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

UART Pin 0, Pin 1 RX TX configuration

HPhan7
Novice
1,392 Views

Hi all,

I want to use Pin 0,1 as UART to communicate with GPS sensor. I read some sharing and figure out it Serial1 in Arduino sketch then I try to configure those pin follow Sergey block

http://www.malinov.com/Home/sergey-s-blog/intelgalileo-configuringtheserialportinlinux Intel Galileo - Configuring the Serial Port in Linux - Malinov Family Web Presence.

But when I go to puty and type first command the result is " echo: write error: Device or resource busy. Anyone know how to solve the problem?

In the other hands, can I use Serial1 and Serial independently in sketch after configuration?

Finally, is there a method to boot those command line from sketch?

Regards

Frank

1 Solution
FTinetti
Honored Contributor I
167 Views

Hi Frank,

Take a look at , where I think it is described the relationship among serial, serial1, TX-RX, and the Serial Monitor you need to take into account.

Finally, is there a method to boot those command line from sketch?

If you need to execute commands from a sketch, you can use the function "system()"... but I don't know if this is what you are asking for.

HTH,

Fernando.

View solution in original post

2 Replies
FTinetti
Honored Contributor I
168 Views

Hi Frank,

Take a look at , where I think it is described the relationship among serial, serial1, TX-RX, and the Serial Monitor you need to take into account.

Finally, is there a method to boot those command line from sketch?

If you need to execute commands from a sketch, you can use the function "system()"... but I don't know if this is what you are asking for.

HTH,

Fernando.

HPhan7
Novice
167 Views

Hi Leonado,

Thanks for your help, I read and tested my board by loop pin 0 and 1. they worked normally. So the thing get problem here is my sensor.

Regards

Frank

Reply