Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9874 Discussions

UART on edison arduino board

SMeel1
Beginner
995 Views

Hi,

I have a sensor that works on two modes (I2C,UART),I am converting the i2c to uart and similarly from uart to i2c. after changing the mode from uart to i2c i am unable to detect the address.I have connected the sensor tx,rx pins to A4,A5 and same to rx and tx(PIN 0, PIN 1).After I change the mode from uart to i2c using nodejs the voltage across the pin 0, pin 1 is 3V. But when the remove the jumper wires from the pin 0 and pin 1 i am able to detect the address,when i put the wires back i am not able to detect the address.

I tried to get the address after rebooting but no luck, but i am able to get the address after i shutdown the device and on.

How can i make voltage on the uart pins to zero after i change the mode from uart to i2c in order to detect the address of the sensor.

Thanks'

Srujani.

0 Kudos
2 Replies
AlHill
Super User
119 Views

Please stay with your other thread:

Doc

idata
Community Manager
119 Views

Hello Srujani,

 

 

Thanks for reaching out!

 

 

As Al Hill mentioned, this thread is a duplicate of https://communities.intel.com/thread/111746 https://communities.intel.com/thread/111746, we have replied to you there. We will continue the support in that thread.

 

 

Pedro M.
Reply