Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BRETT_B_Intel
Employee
1,839 Views

Ubuntu 14.04 LTS - Screen (screen /dev/ttyUSB0) comm problems

Hi all,

I am having trouble maintaining communications through the "screen" proxy (screen /dev/ttyUSB0 115200), I can successfully log into both of my edisons ; Yocto, on one and Ubi on the other, but generally after a small amount of time and often right after communications begin I loose all ability to communicate through "screen". Sometimes it will display only half the text of its current process, I can log out of it properly with ctrl -a shft k. Any suggestions? - Thanks

- Using Sparkfun Base block.

4 Replies
Pedro_M_Intel
Employee
70 Views

Hello mistaBIZ,

This sounds really weird, I have never experienced this issue while using Ubuntu. My guesses are that you either have a bad USB cable or you accidentally blocked screen.

Can you test your Edison with a different USB cable? Does it make a difference?

Check http://stackoverflow.com/questions/4367669/the-gnu-screen-is-unresponsive-seems-blocked http://stackoverflow.com/questions/4367669/the-gnu-screen-is-unresponsive-seems-blocked, do you think something like that could be happening to you?

Peter.

BRETT_B_Intel
Employee
70 Views

Peter, Thanks for the solid link. I will give this a go when I get home.

Carlos_M_Intel
Employee
70 Views

Hi mistaBIZ,

Have you been able to try with Peter's suggestion?

Regards,

Charlie

BRETT_B_Intel
Employee
70 Views

Not specifically, I updated some dependencies from another site I found highlighting a similar problem. This seemed to work, but I have the site Peter mentioned on standby if I find otherwise.

-Thanks

Reply