Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NTane
Beginner
3,115 Views

Unable to Connect Intel Galileo Gen2 to IoT Cloud

Jump to solution

Hi everyone,

I have being trying to connect my board to IoT Analytics dashboard. I have being following the instructions from "https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics Intel® IoT Platforms: Getting Started: Cloud Analytics | Intel® Developer Zone" .

The iotkit-agent was already installed but while testing the network using proxy server, i typed the command "iotkit-admin proxy 172.16.1.1 8080", but an error comes that says "set Proxy data".

I tested the command "iotkit-admin test" on my home network too without proxy server, bu an error comes that says

"error: Data Submission Error code=ESRCH errno=ESRCH,syscall=getaddrinfo

error: Connection failed to dashboard.us.enableiot.com"

Does anyone could help me with this issue?

Thanks in anticipation

Nicy

1 Solution
mheo1
Beginner
678 Views

Thank for your help. I find that my school's router block my request, so I bring that board home and everything's ok now. Thank you )

View solution in original post

7 Replies
idata
Community Manager
678 Views

Hi,

 

 

First, make sure that you have a connection to the cloud, run the command iotkit-admin test. Check what version you have installed with iotkit-admin –V and notice in https://github.com/enableiot/iotkit-agent https://github.com/enableiot/iotkit-agent that there are several new features related to proxies for different versions. Upgrade if needed following the steps of section 3. Once you've upgraded, try to reset the proxy in case there's a misconfiguration issue with iotkit-admin reset-proxy. Then, try to configure the proxy once again.

 

 

Let us know your results.

 

 

Sergio

 

idata
Community Manager
678 Views

Do you still need help with this thread, were you able to connect to the IoT cloud?

 

 

Sergio

 

NTane
Beginner
678 Views

My agent version was 1.7.0 before updating and after updating (using command: npm update -g iotkit-agent), it is same. Do I need to run this command:

iotkit-admin set-data-directory ?

And if yes then how to find the data directory?

 

I tried to connect my board with my home network, still the error is there.

 

In my work network I am trying to connect behind proxy server using commands:

1. iotkit-admin proxy http://172.16.80.90 http://172.16.80.90 8080

2. iotkit-admin http_proxy=http://172.16.80.90:8080 http://172.16.80.90:8080

 

3. iotkit-admin http_proxy=http://username:abcdef1234@172.16.80.90:8080 http://username:abcdef1234@172.16.80.90:8080

 

Please let me know the correct command for connecting behind the proxy.....

 

Thanks in anticipation

 

idata
Community Manager
678 Views

According to https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=0ahUKEwiDxbeMnLLMAhUM3WMKHUJGCIk... https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=0ahUKEwiDxbeMnLLMAhUM3WMKHUJGCIk...

 

If you are attempting the connection from behind a firewall with a proxy server, add the proxy

 

server to the iotkit-admin configuration:

 

 

iotkit-admin.js proxy http://proxy.company.com http://proxy.company.com 8080

 

 

Sergio

 

mheo1
Beginner
678 Views

I have the same problem!!

2016-04-20T16:31:59.922Z - info: Trying to connect to host ...

2016-04-20T16:32:22.821Z - error: Data Submission Error code=ESRCH, errno=ESRCH, syscall=getaddrinfo

2016-04-20T16:32:22.885Z - error: Connection failed to dashboard.us.enableiot.com

I type iotkit-admin –V then it shown that my version was 1.7.0

I though this problem was about my internet connection because I did this on my school lab. But I can't figure it out because I still connected to internet and can run the Web client on Example sketch.

But I found that my computer cannot ping Google.com while still connected to internet.

idata
Community Manager
678 Views

If you're not able to ping google from your computer you might have a firewall blocking your requests. Make sure you're not being blocked by a firewall and that you have all proxy settings set correctly, as explained in the post above.

 

 

Sergio

 

mheo1
Beginner
679 Views

Thank for your help. I find that my school's router block my request, so I bring that board home and everything's ok now. Thank you )

View solution in original post

Reply