Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
854 Views

Unable to SSH over WiFi when disconnected from PC

Hi.

I'm having some really basic issues.

Setup: Edison + Arduino board

Firmware version installed: 201606061707.

1.- I can SSH to the board @ 192.168.2.15 (Intel Edison USB RNDIS Device) and after configuring WiFi I get IP 192.168.2.21 and I'm able to SSH over WiFi IP no issues.

Issue: When I disconnect the board from the PC and power it from a 2amp USB port it boots, it connects to my network and gets the 192.168.2.21 IP, but I'm unable to SSH, or even ping the WiFi IP.

2.- All the guides I've followed tell you to verify configuration by accessing the IP over http/browser.

Issue: I don't get any html page return with either ..2.15 or ..2.21 ever.

3.- when I run configure_edison --version

Issue: The cmd return "Could not determine firmware version information. Quitting."

How do I resolve the above issues?

Thanks.

Btw I'm a Linux noob.

0 Kudos
8 Replies
Highlighted
Community Manager
14 Views

Hello Гѧѱ,

 

 

I understand what you're mentioning, I'll try to help you.

 

The behavior you describe is a known issue where Edison's web server is not working correctly. This behavior has been previously reported and we are currently working on it, however, there's no ETA for when a fix might arrive.

 

 

The only workaround right now would be to use an older version of Edison's image. If you are interested in trying this, I'd suggest you to use the version 146 ( https://downloadmirror.intel.com/24910/eng/edison-image-ww18-15.zip) which did not have this issue.

 

 

I hope this helps you.

 

-Peter.
0 Kudos
Highlighted
Community Manager
14 Views

Thanks Peter.

Downgrading the firmware resolved issues 2 & 3, but the most important one, 1 is still troubling me. Why is it I can only connect to the Edison when it's connected to a PC?

When it's powered from the USB power adaptor it get's a WiFi IP but I'm unable to access it. It's like it enables a firewall when not connected to a PC with the correct drivers.

Is there a list of firmware changes?

Thanks

0 Kudos
Highlighted
Community Manager
14 Views

I understand, could you please try the following on the same scenario (with your board powered from a 2A USB port):

 

 

1. Connect your board with a serial connection (PuTTY, to keep track of what might be happening).

 

2. Unplug your board from your PC.

 

3. Check the board's IP address with ifconfig, does it still have one?

 

4. If so, try pinging google.com, what happens? Could you please post a screenshot?

 

5. In case the board has issues reaching google.com, please enter the following commands:

 

 

ifconfig wlan0 down

 

systemctl restart wpa_supplicant.service

 

ifconfig wlan0 up

 

 

6. Try pinging google.com again, do you notice any difference?

 

 

Also, do you have access to an external power supply (with the barrel jack connection)? If so, could you please try the same scenario again but with this power supply and let us know if the issue persists?

The list of changes on the image is in the Release Notes, which can be found in https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads

 

 

Let me know how it goes.

 

-Peter.
0 Kudos
Highlighted
Community Manager
14 Views

Hi Peter.

Thanks for your response.

I think you have experience with this board when it first came out. Since then Intel as usual has seriously messed up the drivers.

  1. I can't connect over Serial I've tried with 3 SSH programs (Tera, Putty & SecureCRT v8)... nothing happens, just times out.
  2. The ONLY way to connect to this waste of time is through RNDIS. Which essentially creates a closed network with the host PC. This is the ONLY way I've been able to connect: https://software.intel.com/en-us/connecting-to-intel-edison-board-using-ethernet-over-usb IoT - Connecting to your Intel® Edison board using Ethernet over USB | Intel® Software
  3. If I don't set a static IP address for the RNDIS adapter as per the above instructions, there's NO WAY to communicate with the board.

==========================================================

  1. How am I supposed to serial in to the Edison when I disconnect from it? Your Steps 1-2.
  2. Pings to ..2.15 and ..2.21 from other non connect PCs fail.
  3. While the Edison is powered by 9v Plug or USB A, as soon as I disconnect the USB cable from the PC the Edison loses all network connectivity.

     

    The Edison can't ping any outside addresses, or even addresses on the same network.
  4. router gives "edison" ip after wifi setup.
  5. Serial Connection NEVER works, from day 1.
  6. Using FTDI, I get a COM port, but I still can't SSH on to the board. Btw I used FTDI com ports daily with my Arduino projects no issues.

     

So how do I connect to Edison without a PC? Is it possible? Has anyone done it?

I've spent ~20hrs trying to get the board to connect to WiFi independent of a host PC and failed.

Thanks.

0 Kudos
Highlighted
Novice
14 Views

Hi Гѧѱ,

my current version is 159 and it works well. So you should try the version 159

regards,

Khoa

0 Kudos
Highlighted
Community Manager
14 Views

I setup a new PC with Win10 Anniversary, this resolved the com port issue, but it only works if I use the same usb ports as when I run "intel_edison_setup_win_v2016.2.007.exe"

I have also flashed "edison-iotdk-image-280915.zip" (version 159) below is the terminal print from boot.

I am still unable to connect to the edison when the board isn't connected to a PC with all the drivers.

The board gets an IP, but doesn't respond to pings and I can't see anything on http:80 unless it's connected to a PC.

I can't ping anything from the board, and it can't access anything on the network.

No other device on my network has issues.

I can't even ping the router which is giving it the IP address:

root@edison:~# ping 192.168.2.1

PING 192.168.2.1 (192.168.2.1): 56 data bytes

^C

--- 192.168.2.1 ping statistics ---

5 packets transmitted, 0 packets received, 100% packet loss

Below is the terminal output when connected over FTDI and powered by 9v.

******************************

PSH KERNEL VERSION: b0182b2b

WR: 20104000

******************************

SCU IPC: 0x800000d0 0xfffce92c

PSH miaHOB version: TNG.B0.VVBD.0000000c

microkernel built 11:24:08 Feb 5 2015

******* PSH loader *******

PCM page cache size = 192 KB

Cache Constraint = 0 Pages

Arming IPC driver ..

Adding page store pool ..

PagestoreAddr(IMR Start Address) = 0x04899000

pageStoreSize(IMR Size) = 0x00080000

*** Ready to receive application ***

U-Boot 2014.04 (Jun 19 2015 - 12:05:55)

Watchdog enabled

DRAM: 980.6 MiB

MMC: tangier_sdhci: 0

In: serial

Out: serial

Err: serial

Hit any key to stop autoboot: 0

Target:blank

Partitioning already done...

Flashing already done...

GADGET DRIVER: usb_dnl_dfu

reading vmlinuz

5434848 bytes read in 134 ms (38.7 MiB/s)

Valid Boot Flag

Setup Size = 0x00003c00

Magic signature found

Using boot protocol version 2.0c

Linux kernel version 3.10.17-poky-edison+ (sys_dswci@tlsndgbuild004) # 1 SMP PREEMPT Fri Jun 19 12:06:40 CEST 2015

Building boot_params at 0x00090000

Loading bzImage at address 00100000 (5419488 bytes)

Magic signature found

Kernel command line: "rootwait root=PARTUUID=012b3303-34ac-284d-99b4-34e03a2335f4 rootfstype=ext4 console=ttyMFD2 earlyprintk=ttyMFD2,keep loglevel=4 g_multi.ethernet_config=rndis systemd.unit=multi-user.target hardware_id=00 g_multi.iSerialNumber=c0fb66ba05f5e9587f6813992ee05ec2 g_multi.dev_addr=02:00:86:e0:5e:c2 platform_mrfld_audio.audio_codec=dummy"

Starting kernel ...

[ 1.632138] snd_soc_sst_platform: Enter:sst_soc_probe

[ 2.036346] pmic_ccsm pmic_ccsm: Error reading battery profile from battid frmwrk

[ 2.054537] pmic_ccsm pmic_ccsm: Battery Over heat exception

[ 2.054605] pmic_ccsm pmic_ccsm: Battery0 temperature inside boundary

Welcome to Linux!

Expecting device dev-ttyMFD2.device...

[ OK ] Reached target Remote File Systems.

Expecting device dev-disk-by\x2dpartlabel-factory.device...

Expecting device sys-subsystem-net-devices-usb0.device...

[ OK ] Reached target Paths.

[ OK ] Reached target Swap.

[ OK ] Set up automount boot.automount.

[ OK ] Created slice Root Slice.

[ OK ] Created slice User and Session Slice.

[ OK ] Listening on Delayed Shutdown Socket.

[ OK ] Listening on /dev/initctl Compatibility Named Pipe.

[ OK ] Listening on udev Control Socket.

[ OK ] Listening on udev Kernel Socket.

[ OK ] Listening on Journal Socket.

[ OK ] Created slice System Slice.

Mounting Temporary Directory...

[ OK ] Created slice system-serial\x2dgetty.slice.

[ OK ] Created slice system-getty.slice.

Starting Load Kernel Modules...

Starting Create list of required static device nodes...rrent kernel...

Starting udev Coldplug all Devices...

Mounting Debug File System...

Mounting POSIX Message Queue File System...

Starting Apply Kernel Variables...

Starting Journal Service...

[ OK ] Started Journal Service.

[ OK ] Reached target Slices.

Starting Remount Root and Kernel File Systems...

[ OK ] Set up automount home.automount.

[ OK ] Mounted POSIX Message Queue File System.

[ OK ] Mounted Debug File System.

[ OK ] Mounted Temporary Directory.

[ OK ] Started Create list of required static device nodes ...current kernel.

[ OK ] Started Apply Kernel Variables.

[ OK ] Started Remount Root and Kernel File Systems.

[ OK ] Started Load Kernel Modules.

[ OK ] Started udev Coldplug all Devices.

Mounting Configuration File System...

Mounting FUSE Control File System...

Starting Load/Save Random Seed...

Starting Create Static Device Nodes in /dev...

[ OK ] Mounted FUSE Control File System.

[ OK ] Mounted Configuration File System.

[ OK ] Started Load/Save Random Seed.

[ OK ] Started Create Static Device Nodes in /dev.

Starting udev Kernel Device Manager...

[ OK ] Reached target Local File Systems (Pre).

Mounting /var/volatile...

[ OK ] Mounted /var/volatile.

[ OK ] Started udev Kernel Device Manager.

[ OK ] Reached target Local File Systems.

Starting Trigger Flushing of Journal to Persistent Storage...

Starting Create Volatile Files and Directories...

[ OK ] Started Create Volatile Files and Directories.

[ OK ] Started Trigger Flushing of Journal to Persistent Storage.

[ OK ] Found device /dev/ttyMFD2.

[ OK ] Found device /sys/subsystem/net/devices/usb0.

[ OK ] Found device /dev/disk/by-partlabel/factory.

Mounting Mount for factory...

[ OK ] Created slice system-systemd\x2drfkill.slice.

Starting Load/Save RF Kill Switch Status of rfkill1...

Starting Load/Save RF Kill Switch Status of rfkill2...

Starting Load/Save RF Kill Switch Status of rfkill0...

Starting Network Time Synchronization...

Starting Update UTMP about System Boot/Shutdown...

[ OK ] Mounted Mount for facto...

0 Kudos
Highlighted
New Contributor I
14 Views

It is not good that the wlan0 and the usb0 connections belong to the same sub-network. Try to modify your lan address to something different from 192.168.2.0 - say 192.168.90.0.

If it is not possible, change the Edison usb0 default address. At present the only way I know is to edit (as root):

/systemd/network/usb0.network

Address=192.168.2.15/24

change the address to 192.168.90.15 and reboot.

0 Kudos
Highlighted
Community Manager
14 Views

Hi Гѧѱ,

 

 

Could you please try if's suggestion and let us know how it goes?

 

If the issue persists, I'd like you to perform the following test:

 

 

1. Open Edison's serial COM port on PuTTY.

 

2. Flash your board using the flashall.sh method (as explained in https://communities.intel.com/docs/DOC-25154 https://communities.intel.com/docs/DOC-25154)

 

3. When the board starts flashing do you have any output on the COM port?

 

 

Let me know how it goes.

 

-Peter.
0 Kudos