Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,430 Views

Unable to set up wifi in Intel Edison

I used Window10. I tried Intel configuration tool and it kept saying my password was wrong.

So I tried to use Putty. It kept saying "Password must be either 5 or 13 characters."

Then I found a way on the Internet (https://software.intel.com/en-us/blogs/2014/11/18/intel-edison-troubleshooting-and-faq Troubleshooting Intel® Edison and Intel® Galileo | Intel® Software ) to change the configure_edison file for it to accept my password which is 26 characters long. However, it still didn't work. It kept saying "Password must be either 5 or 13 characters."

What should I do?

Tags (1)
12 Replies
Highlighted
Community Manager
24 Views

Hi,

 

In the latest image, where cat /etc/version is 201606061707, the password length option is between 8 and 63 characters. Look at the image below

 

 

Flash to the latest image found in https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads with the flash tool lite https://software.intel.com/en-us/articles/flash-tool-lite-user-manual https://software.intel.com/en-us/articles/flash-tool-lite-user-manual .

Let us know your results.

-Sergio

 

0 Kudos
Highlighted
Novice
24 Views

I've already flash to the latest image, Since my Wifi is WEP, not WPA. It asked me to provide either 5 or 13 characters.

If it is WPA, like your example, then it's length is between 8 and 63 characters.

0 Kudos
Highlighted
Community Manager
24 Views

You can try changing the configure_edison file. Go to /usr/bin/configure_edison and look for the file that requires the password length.

 

Some of the functions you may find useful are configureHiddenNetwork, configureNetwork, and configureNetworkAP.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
24 Views

Thanks for your answer but I already tried to change it to accept 26 characters. It still didn't work. It still asked me to provide 5 or 13 characters. I don't know if I change the right file. Since I'm using Windows, the configure_edison is located in C:\Users\XX\AppData\Local\Temp\{3944ff12-847b-445a-877e-816220cffdaf}\config\ProductConfig/configure_edison. Is it the right file? I only got this one in my computer searching.

0 Kudos
Highlighted
Community Manager
24 Views

No, that's not the correct file. Even if you're using Windows in your computer, when you enter the terminal of the Edison, as shown in my first reply, you're using the Linux image on the Edison, that's where you need to make the changes.

 

 

The correct file is in /usr/bin/configure_edison. In the Linux console of your Edison, type cat /usr/bin/configure_edison, there you should see the code that shows how the configure_edison script works. Look for the functions posted above, you'll notice those functions manage the password length that is to be entered by the user.

 

To edit the file so that it receives the password length required, type vi /usr/bin/configure_edison in the Linux console.

 

 

Once you've made the necessary changes within vi, type "Esc", then ":wq!" and "Enter"

 

 

-Sergio

 

0 Kudos
Highlighted
Community Manager
24 Views

Do you still need help with this thread? Were you able to edit the configure_edison file?

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
24 Views

Thanks for the solution. Sorry for the late reply.

I have successfully edited the file and changed my password of the wifi, however, I am still encountering wifi connection problem. I have tried so many times these days but still don't know what went wrong.

I tried the originally way(left) but also the alternate way provided by your Intel website(right).

Like this:

0 Kudos
Highlighted
Community Manager
24 Views

Which changes have you made to the configure_edison file, can you add the content of the functions that were changed? Were you ever able to connect to Wi-Fi, is there a chance you can try and test your connection to a WPA configured network with this image and with a fresh install?

 

 

Now, there's also this message:" Password must be either 26 or 13 characters". Usually, the password length is a range from which you can choose, not an exact value, did you start to receive this message after the changes in the configure_edison file? Have you changed anything in the Wifi configuration that's not password related?

 

 

-Sergio

 

0 Kudos
Highlighted
Community Manager
24 Views

Do you still need assistance with this case, were you able to set up WiFi?

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
24 Views

Thanks for your reply!

I didn't quite understand this means: "test your connection to a WPA configured network with this image and with a fresh install?" I think my wifi is using WEP, instead of WPA. Is that the reason that causes this problem?

Besides, I only changed the configureHiddenNetwork, configureNetwork, and configureNetworkAP part in the configure_edison file. Since my password is 26 characters, I think it may be more convenient to change the password part to be exactly 26 characters. Is that OK?

0 Kudos
Highlighted
Community Manager
24 Views

Hi,

 

 

What I meant was that if it's possible to test your Edison's Wi-Fi connection in another network, one with WEP, not WPA. If possible, can you change the router settings to use WEP instead of WPA? If there are other devices connected to that router and you change the security mode, those devices might disconnect, so do this in a test environment to make sure the network's connectivity won't be lost.

 

 

There's an interesting discussion about it here /message/317848# 317848 https://communities.intel.com/message/317848# 317848 .

 

 

The password length changes you did in the "configure_edison" script can be exactly 26 characters. Just be careful on how you change the code in the configure_edison script.

 

 

-Sergio

 

0 Kudos
Highlighted
Community Manager
24 Views

Hi Neuroastronaut,

 

 

Do you still need help with this thread, were you able to set up Wi-Fi?

 

 

-Sergio

 

0 Kudos