Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9868 Discussions

WIFI drops every 1800s - DHCP lease

MMich22
New Contributor II
3,371 Views

I found out that my edison is dropping the wifi connection every 1800 seconds showing the following message:

[ 7266.660167] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_DEAUTH_IND

[ 7266.660247] link down if wlan0 may call cfg80211_disconnected. event : 6, reason=2 from 20:bb:c0:e6:b3:5b

[ 7266.663005] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_DEAUTH

[ 7266.663075] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK

[ 7266.670129] cfg80211: Calling CRDA for country: CH

[ 7266.670824] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

[ 7271.008023] CFG80211-ERROR) wl_cfg80211_connect : Connectting with20:bb:c0:e6:b3:5b channel (36) ssid "WIFI", len (13)

[ 7271.008023]

[ 7271.102221] wl_bss_connect_done succeeded with 20:bb:c0:e6:b3:5b

[ 7271.109224] wl_bss_connect_done succeeded with 20:bb:c0:e6:b3:5b

[ 9080.729661] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_DEAUTH_IND

[ 9080.729749] link down if wlan0 may call cfg80211_disconnected. event : 6, reason=2 from 20:bb:c0:e6:b3:5b

[ 9080.731957] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK

[ 9080.735254] cfg80211: Calling CRDA to update world regulatory domain

[ 9080.746675] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

[ 9085.088546] CFG80211-ERROR) wl_cfg80211_connect : Connectting with20:bb:c0:e6:b3:5b channel (36) ssid "WIFI", len (13)

[ 9085.088546]

[ 9085.182892] wl_bss_connect_done succeeded with 20:bb:c0:e6:b3:5b

[ 9085.220861] wl_bss_connect_done succeeded with 20:bb:c0:e6:b3:5b

9080s - 7266s = 1814s which seems to be exactly the dhcp lease time. It is independent if I use Yocto or Ubilinux?

Why does my edison disconnect every 30 minutes? Could someone help me?

0 Kudos
8 Replies
Carlos_M_Intel
Employee
587 Views

Hi rosenrot

Is this log obtained when you are on Yocto?

I suggest you to first, be sure that the issue it's not in the network that you are using.

After configuring password and wifi with configure_edison. Verify the DNS number of your network in /etc/resolv.conf if it's not correct, change the number with the correct one.

Regards;

Carlos

MMich22
New Contributor II
587 Views

Yes, this is Yocto output put it is also almost the same for ubilinux.

I changed the nameserver now to be the same as for my laptop, same result. There is a disconnect every 30 seconds.

Richard_A_Intel2
Employee
587 Views

Is there a possibility someone is trying to hack into your Wifi? http://www.securityweek.com/researchers-outline-how-crack-wpa2-security Researchers Outline How to Crack WPA2 Security | SecurityWeek.Com

MMich22
New Contributor II
587 Views

I don't think so because this is a university wifi and it happens since two weeks.

I do only see the disconnects with the edison board.

Carlos_M_Intel
Employee
587 Views

Hi rosenrot

It's strange that you are having the same error with Ubilinux and Yocto. There a /docs/DOC-23242 new Yocto's image try with it and let us know if the error continues.

Is there a way to test the WiFi connection with another network, in order to definitely discard network-issues.

Regards;

CMata

MMich22
New Contributor II
587 Views

I found the issue, I contacted the wifi administrator and told him about the 1800s problem. He found an session option which was set to 1800s. After removing it, the edison stays connected. The error was not so easy to find because windows does not show the reauth process. I had to use another linux notebook to see that also there it disconnects every 1800s.

Unfortunately, I thought that the edison is doing something wrong because I did not think about a configuration mistake of the wifi itself. My bad! Thanks to anyone trying to help, maybe this post will help someone in future.

hston
New Contributor II
587 Views

Dear Rosenrot,

Where can I find the 1800s session option, I also need fix the wifi drop problem. Thanks

Carlos_M_Intel
Employee
587 Views

Hi hopstone,

It will depend on the router you are using, I suggest you to search in the Internet the model of your model and to check if it is available to change/set a session or timeout. If the model you are using has a GUI there shouldn't be problems while changing these settings but if you have problems, contact the support group of your network and router.

Regards,

-Charlie

Reply