Community
cancel
Showing results for 
Search instead for 
Did you mean: 
VBu
Beginner
1,932 Views

WOL on Compute Stick STK2mv64CC ?

Hello guys. Sorry for my english.

I have Stick STK2mv64CC with Winfows 10 Pro x64, install latest bios and wlan drivers. I read that stick have WLAN WOL, but i cant confugure it for good result.

After sleep, hybernate or soft power off wi-fi router lost stick's ip. I try send multicast magic packet with mac but no effect. In power managment of wifi adapter power off device for economy is unchecked. What is the problem? Maybe some manuals for property configuration. Thanks to all.

0 Kudos
4 Replies
idata
Community Manager
131 Views

Hello niil85,

 

 

I understand that you are currently trying to setup your WiFi so that it does not turn off or that it loses the IP.

 

 

Regarding this, what I can recommend you to do first is to check under the adapter settings and make sure that the IP address is set as static instead of dynamic. Also, for more information about the technical specifications refer to the link below:

 

 

https://www.intel.com/content/dam/support/us/en/documents/boardsandkits/computestick/STK2m3W64CC_STK... https://www.intel.com/content/dam/support/us/en/documents/boardsandkits/computestick/STK2m3W64CC_STK...

 

 

I hope this helps.

 

 

 

Regards,

 

David V
VBu
Beginner
131 Views

There only two notes about WOL in manual pdf:

Wireless LAN (only on STK2MV64CC) from SS: S3, S4, S5 (Notes 1, 2) remark "S5 WOL after G3" supported; monitor to remain in sleep state

and

Monitor will remain in "sleep" state 2. remark "S5 WoL after G3" only supported w/Deep Sleep disabled

STK2MV64CC supported Wlan WOL as its wtiten

I dont understand why its needed setup as static IP for WOL? No special option in BIOS.

Who can setup it succesfully

n_scott_pearson
Super User Retired Employee
131 Views

In order to wake up a system, you have to send it a magic packet. In order to send it a magic packet, depending upon the tool that you use to do so, you need to know either its IP address or its MAC address. If your tool requires you to know its IP address, then there is a problem: with DHCP enabled, the IP address of the system can change over time, making the determination of the necessary IP address problematic. It is thus recommended that you use a static IP address for those PCs that need to be awoken via WOL.

To enable WOL, from within Windows, browse to the properties for the Wireless Adapter (Intel Dual Band Wireless-AC 8260). In the Power Management tab, check (enable) Allow this device to wake the computer. I also checked Only allow a magic packet to wake this computer, so that other events on the LAN (resets, etc.) do not cause the ICS to spuriously wake up.

Because I also set the ICS to disable HDCP and use a static IP address, I next did a Windows restart. Along the way, I used F2 to enter BIOS Setup and found that I did not need to make any changes in the BIOS Configuration. I exited BIOS Setup and booted back into Windows. I then manually put the ICS to sleep. Using my magic packet tool (NirSoft's WakeMeOnLAN, just because I had it on hand), I sent the ICS a magic packet. Voila! the ICS woke up.

Hope this helps,

...S

SZhou15
Beginner
131 Views

At first it did not work on me neither. It took me 5 days to realise the WiFi is in hidden mode. And no document even mentions that WOL does not work on hidden WiFi. It took me 5 days to figure it out...

Reply