Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SDijk
New Contributor I
1,030 Views

Wi-Fi and Bluetooth disappeared, can't upload firmware

Today after rebooting my Edison, I can't access the Wi-Fi and Bluetooth interfaces anymore, and my attempts to reinstall the firmware also fail. Earlier today I have tried to make an external Bluetooth dongle work on my Edison over the OTG port using a custom-compiled btusb kernel module. Possibly something broke during that attempt, hopefully only software-wise.

Symptoms:

  • ifconfig doesn't show wlan0 or usb0, while it previously did.
  • After `rfkill unblock bluetooth`, hciconfig doesn't show any devices, while it previously did.
  • When connecting to my PC using the https://learn.sparkfun.com/tutorials/edison-getting-started-guide# updating-the-firmware-image SparkFun guide, no filesystem comes up and the Intel installer also doesn't recognize the board. I have tried both OS X El Capitan and Windows 10. I'm not sure whether it worked previously on these versions, maybe it is also an issue with the OS versions being too new.

How can I get my Edison board back to factory settings, or proceed in finding out what's wrong?

2 Replies
SDijk
New Contributor I
93 Views

I just noticed that /dev/root (mounted on /) was 100% full, with no blocks available. This may have caused some problems. I removed some files from /opt and now only 68% is used. Still the issues from my first post persist. Any ideas?

SDijk
New Contributor I
93 Views

Fixed, found it that no kernel modules were loaded anymore and I had to run depmod.

Reply