Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ODobr1
Beginner
1,167 Views

WiFi access - refused to connect

Jump to solution

Hi! I wonder if you can help me with WiFi issue on Intel Edison.

I'm using Arduino IDE and sketch from Example -> WiFI (Edison) -> SimpleWebServerWiFi. Just updated with password and network name. I can update post with example code but here is nothing special. It seems that connection works fine:

Attempting to connect to Network named: L&N

SSID: L&N

IP Address: 192.168.1.102

signal strength (RSSI):-39 dBm

To see this page in action, open a browser to http://192.168.1.102

But when I try to access by http://192.168.1.102/ http://192.168.1.102/ in browser result always is the same (no matter which is wifi network):

This site can't be reached

192.168.1.102 refused to connect.

Could you help me or suggest any way how to solve this issue?

0 Kudos
1 Solution
idata
Community Manager
76 Views

Hello lamrak,

 

 

Thank you for interest in the Intel® Edison Breakout Board.

 

 

I found a couple of threads that mention issues similar to the one you are experiencing, so please check that troubleshooting first:

 

 

Intel Edison Arduino board with SimpleWebServerWifi sketch

 

https://communities.intel.com/message/331731# 331731 https://communities.intel.com/message/331731# 331731

 

Community member c151515135 solved his issue by flashing the latest image (Flash Tool Lite User Manual https://software.intel.com/en-us/articles/flash-tool-lite-user-manual & How to Run the Flashall Script https://communities.intel.com/docs/DOC-25154 https://communities.intel.com/docs/DOC-25154).

 

 

Communication with Edison over WiFi

 

https://communities.intel.com/message/275569# 275569 https://communities.intel.com/message/275569# 275569

 

Community member Apivovarov got the SimpleWebServerWiFi to work following this suggestion:

 

 

SimpleWebServerWiFi in the IDE, and change the line: WiFiServer server(80); with WiFiServer server(81); Also you will need to put your ssid and password in the sketch.  In order to know which is the IP address of your board, run ifconfig in the Serial Console, the IP address is in wlan0 -- inet addr   After running the sketch, types the address in your web browser.  For example, if your IP address is 123.234.23.12. You will need to add the :81 at the end: 123.234.23.12:81

 

 

Please let me know if you find the previous information useful.

 

 

If you need further assistance, don't hesitate to contact us.

 

 

Regards,

 

Andres V.

View solution in original post

3 Replies
idata
Community Manager
77 Views

Hello lamrak,

 

 

Thank you for interest in the Intel® Edison Breakout Board.

 

 

I found a couple of threads that mention issues similar to the one you are experiencing, so please check that troubleshooting first:

 

 

Intel Edison Arduino board with SimpleWebServerWifi sketch

 

https://communities.intel.com/message/331731# 331731 https://communities.intel.com/message/331731# 331731

 

Community member c151515135 solved his issue by flashing the latest image (Flash Tool Lite User Manual https://software.intel.com/en-us/articles/flash-tool-lite-user-manual & How to Run the Flashall Script https://communities.intel.com/docs/DOC-25154 https://communities.intel.com/docs/DOC-25154).

 

 

Communication with Edison over WiFi

 

https://communities.intel.com/message/275569# 275569 https://communities.intel.com/message/275569# 275569

 

Community member Apivovarov got the SimpleWebServerWiFi to work following this suggestion:

 

 

SimpleWebServerWiFi in the IDE, and change the line: WiFiServer server(80); with WiFiServer server(81); Also you will need to put your ssid and password in the sketch.  In order to know which is the IP address of your board, run ifconfig in the Serial Console, the IP address is in wlan0 -- inet addr   After running the sketch, types the address in your web browser.  For example, if your IP address is 123.234.23.12. You will need to add the :81 at the end: 123.234.23.12:81

 

 

Please let me know if you find the previous information useful.

 

 

If you need further assistance, don't hesitate to contact us.

 

 

Regards,

 

Andres V.

View solution in original post

ODobr1
Beginner
76 Views

Hi Andres,

thank you very much for your help, the reason was in port. I changed port number to 81 as you suggested and as url address http://193.168.1.112:81 and it works.

idata
Community Manager
76 Views

Hello lamrak,

 

 

I'm glad to hear that you could solve the issue.

 

 

Thank you for sharing your experience with the community, we really appreciate it.

 

 

Have a nice day.

 

 

Regards,

 

Andres V.
Reply