Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,753 Views

WiFi cannot be activated on Intel Edison (Arduino expansion board)

I tried several to start the WiFi, but all the methodes failed.

The methodes are:

1. Intel Setup Tool

2. configure_edison command

3. wpa_supplicant command

Nothing works. I added the last overview of commands

Best Regards,

Piet

0 Kudos
15 Replies
Highlighted
Community Manager
41 Views

Hi ExperTronics,

 

 

Which image are you currently using? Make sure to use the latest image available in the Download center for Edison.

 

Also, have you tried to flash the Edison module? The issue could be related to a corrupt image, so flashing the module might solve the issue. Here you can find the instructions, /docs/DOC-98643 https://communities.intel.com/docs/DOC-98643. There you'll find two possible methods to flash the Edison in case the first doesn't work.

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

I tried both options and WiFi is still not working

  1. I tried with the standard option as given on the internet with "iot_web_win_master_3022" and following all the steps
  2. I found on the web the alternative way with the flash tool "flash.all (iot-devkit-prof-dev-image-edison-20160525

     

    and dfu-util)

So what to do! {I replaced the Edison with another one (new), but still no WiFi connection}

Best Regards,

Piet

0 Kudos
Highlighted
Community Manager
41 Views

Hi ExperTronics,

To which network are you trying to connect? Is there more than one connection available when trying to configure the Edison's WiFi? You should be connected to the same network that your computer is connected to (the computer to which you have your Edison connected).

 

Also, are you working behind a proxy? If so, disconnect from it and try to configure the Edison's WiFi now.

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

It is still not working. My setup is now an other router/access point and only my working Laptop is wireless connected. I think that the Edison software cannot handle the wireless stuf. my settings are:

- Security Type: WPA/WPA2-PSK

- WPA Encryption Algorithm: TKIP+AES

What to do!

Best Regards,

Piet

0 Kudos
Highlighted
Community Manager
41 Views

Hi ExperTronics,

Could you please share pictures of your process? I would like to see the message that you're getting, in case you're getting one. Hopefully, I'll be able to reproduce the issue and get some better results. Also, please try with this method:

Systemctl start connman

 

Connmanctl //this will enable the connman commands

 

Enable wifi

 

Scan wifi //wait some time for it to scan the networks and you'll see a list of networks available with a long number in front starting with "wifi_"

 

Services

 

Agent on //you'll get a message

 

Connect wifi_ // add the number after the underscore.

 

//You'll then be asked for the network password

 

Quit // to exit the connman commands.

Let us know if that works.

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

I tried your proposal but nothiong happend. For the output by Putty see attachment

0 Kudos
Highlighted
Community Manager
41 Views

Hi ExperTronics,

 

 

Sorry for the confusion, I should had specify it. You should enter the commands with lower case letters, so instead of "Systemctl start connman" you should enter "systemctl start connman", the Linux console is case sensitive so it won't recognize the command if it's written with capital letters. Same apply for the other commands.

 

 

Sorry again for my mistake.

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

I did it again with no capitals and something happend. (for the output see attachment)

I can ping now http://www.google.com/ www.google.com and my router (192.168.2.254) but nothing else. If I try if from my wifi connected LapTop or from my cable connected DeskTop is gives "not at home".

What are the next steps, because something is working!

Best Regards,

Piet

0 Kudos
Highlighted
Community Manager
41 Views

Hi Piet,

 

 

Do you have your Edison board connected to this LapTop that you're mentioning? Is this your host computer? Also, have you tried connecting to your Edison board? Just copy the Edison IP address and paste it in your computer browser. What do you get?

 

Remember that you must be connected to the same network.

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

All the qeustion I can answer with Yes. The output from my browser is attached

Best Regards,

Piet

0 Kudos
Highlighted
Community Manager
41 Views

Hi Piet,

 

 

This seems more related to your network configuration, or maybe your computer settings. If you're able to ping web pages and even your router, it would be a good idea to consider some other factors. Are you aware of any specific configuration in your network or computer? I would even suggest that it's something to do with the connection itself, because at first you were unable to connect your Edison to WiFi using the "standard" way. In addition to that, there's this message in one of your pictures:

 

The remote computer isn't responding to connections on port 80, possibly due to firewall or security policy settings or because it might be temporarily unavailable.

 

Have you tried to use your board with a different network or in a different place? Do you get the same behavior?

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Community Manager
41 Views

Hi Piet,

 

 

Do you have updates on this case?

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

After almost one day work, I have some positive results.

What happened:

  1. New clean install of windows 10 pro on my LapTop-PV2
  2. Adding a second router/access-point (old 3Com 3CRWE554G72T) to my existing router/access-point (3Com WAN port wired to LAN port of ZTE/368N with IP range 192.168.1.xxx)
  3. Using Intel Edison Board Configuration Tool (Windows). IP address of Edison 192.168.1.205
  4. Ping was OK in command mode box, but nothing worked in a browser (http://192.168.1.205/ http://192.168.1.205 or http://Edison-ET.local/ http://Edison-ET.local)
  5. Using PuTTy in SSH mode and it worked via WiFi (IP address 192.168.1.205 port 22), but when I used Edison-ET on port 22 the message was 'Host does not exist'
  6. Now I can do some testing with BLE. I used the TI SensorTag CC2650 (examples from the web)
  7. I follow the page http://www.opensourcerers.org/iot-smart-gateway-intel-edison-ti-sensortag-part-1/ http://www.opensourcerers.org/iot-smart-gateway-intel-edison-ti-sensortag-part-1/ and get one error (see attachedment)
  8. I could connect on BLE with the Sensortag and I get some results

So far it worked,

 

but still some errors!

Best Regards,

Piet

0 Kudos
Highlighted
Community Manager
41 Views

Hi Piet,

 

 

This is an update error with the latest image, it should be solved soon. In the meantime, make the following change:

 

Go to /etc/opkg/ on your Edison, once there open iotkit.conf and edit the line "src iotkit http://iotdk.intel.com/repos/3.5/intelgalactic/opkg/i586/ http://iotdk.intel.com/repos/3.5/intelgalactic/opkg/i586/".

 

Original line: src iotkit http://iotdk.intel.com/repos/3.5/intelgalactic/opkg/i586/ http://iotdk.intel.com/repos/3.5/intelgalactic/opkg/i586/

 

Edited line: src iotkit http://iotdk.intel.com/repos/3.0/intelgalactic/opkg/i586/ http://iotdk.intel.com/repos/3.0/intelgalactic/opkg/i586/

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
Novice
41 Views

Dear Pablo,

Thanks this solved the problem! I tried some other suggestions to solve the problem to get access to the edison by using a browser. See attachedment for more details.

Best Regards,

Piet

0 Kudos