Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PMuld2
New Contributor II
1,802 Views

Wifi connection times out

Jump to solution

Hi,

I have an Edison with the latest image:

root@edison:~# configure_edison --version

159.devkit

Now, I have setup Wifi with configure_edison --wifi and get:

root@edison:~# wpa_cli status

Selected interface 'wlan0'

bssid=40:4d:8e:95:5f:f0

ssid=WLAN-5FF089

id=3

mode=station

pairwise_cipher=CCMP

group_cipher=CCMP

key_mgmt=WPA2-PSK

wpa_state=COMPLETED

ip_address=192.168.2.101

p2p_device_address=fe:c2:de:2f:56:70

address=fc:c2:de:2f:56:70

However, the connection times out on 192.168.2.101.

Also, the route command times out:

root@edison:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

Netstat -rn gives:

root@edison:~# netstat -rn

Kernel IP routing table

Destination Gateway Genmask Flags MSS Window irtt Iface

0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 usb0

192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0

192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

But trying to close usb0, delete the usb0 route, etc. to possibly resolve an interface conflict does not work.

What could I try?

Thanks!

1 Solution
Sergio_A_Intel
Employee
118 Views

Hi,

I checked with my Edison and the output of route and netstat –rn is almost the same as yours. As you said, this issue is because of an IP conflict between usb0 and wlan0.

In my case I have 192.168.2.0 for usb0 and 192.168.10.0 for wlan0. For both interfaces I have the same Gateway and Genmask as yours.

The easiest way to solve this would be to go to your router and specify the DHCP settings. Set up the router so that it leases IPs from a different IP range.

Try this and let us know your results.

Sergio

View solution in original post

3 Replies
Sergio_A_Intel
Employee
119 Views

Hi,

I checked with my Edison and the output of route and netstat –rn is almost the same as yours. As you said, this issue is because of an IP conflict between usb0 and wlan0.

In my case I have 192.168.2.0 for usb0 and 192.168.10.0 for wlan0. For both interfaces I have the same Gateway and Genmask as yours.

The easiest way to solve this would be to go to your router and specify the DHCP settings. Set up the router so that it leases IPs from a different IP range.

Try this and let us know your results.

Sergio

View solution in original post

PMuld2
New Contributor II
118 Views

Indeed, now it works with a different subnet 192.162.3.0:

wlan0 Link encap:Ethernet HWaddr fc:c2:de:2f:81:72

inet addr:192.168.3.100 Bcast:192.168.3.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:157 errors:0 dropped:0 overruns:0 frame:0

TX packets:188 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:36744 (35.8 KiB) TX bytes:34554 (33.7 KiB)

root@edison:~# ping google.com

PING google.com (173.194.113.105): 56 data bytes

64 bytes from 173.194.113.105: seq=0 ttl=57 time=25.008 ms

64 bytes from 173.194.113.105: seq=1 ttl=57 time=25.337 ms

64 bytes from 173.194.113.105: seq=2 ttl=57 time=43.837 ms

^C

--- google.com ping statistics ---

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 25.008/31.394/43.837 ms

root@edison:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default speedport.ip 0.0.0.0 UG 0 0 0 wlan0

192.168.2.0 * 255.255.255.0 U 0 0 0 usb0

192.168.3.0 * 255.255.255.0 U 0 0 0 wlan0

But to understand better, would there be another way to create different subnets for usb0 and wlan0 ?

Also, a bit confusing is that this Edison worked before in my home office router.

Thanks in any case!

Sergio_A_Intel
Employee
118 Views

If you are using any interface and you wish it to have a different IP range you can change the interface's settings with ifconfig. Depending on the options you use with ifconfig you can either view or edit your interface's settings. Take a look at http://www.tecmint.com/ifconfig-command-examples/ 15 Useful "ifconfig" Commands to Configure Network Interface in Linux .

Now, if you want to have a single interface to be connected to devices that belong to different networks and have it route properly you'd have to create VLANs. A VLAN is a virtual LAN interface. Each VLAN you create will have a different ID and will behave as a different subnetwork. You can see more information on VLANs here https://wiki.archlinux.org/index.php/VLAN https://wiki.archlinux.org/index.php/VLAN .

Your Edison might have been working properly on your home office router because of the router's configuration. Your home office router might be configured to lease a different range of IP addresses through DHCP. When you scanned for networks and connected, it received an IP from a different range that didn't conflict with any other interface.

Sergio

Reply