Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PZett
Beginner
1,326 Views

X11 forwarding request failed

I'm trying to do X11 forwarding from my Galileo (gen2) to my Ubuntu x64 computer. I've

enabled X11 forwarding on my Galileo by editing /etc/ssh/sshd_config:

X11Forwarding yes

X11UseLocalhost no

I still get

$ ssh -X root@192.168.0.121

X11 forwarding request failed on channel 0

root@galileo:~#

Help!

2 Replies
Sergio_A_Intel
Employee
36 Views

Hi,

Was editing /etc/ssh/sshd_config the only change you made to enable X11? When you reboot the board do you see the changes you made saved? When enabling X11 forwarding you need to restart the SSH server with /etc/init.d/sshd restart. Make sure the lines you edit are uncommented.

What openssh version do you have? Are you using the uclibc image, eglibc image or a custom image?

You can see more information of X11 forwarding here https://wiki.archlinux.org/index.php/Secure_Shell https://wiki.archlinux.org/index.php/Secure_Shell

Sergio

Carlos_M_Intel
Employee
36 Views

Hi Pibben,

Have you been able to enable X11? Please let us know if you have updates on this.

Regards,

Charlie