Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GGreg3
Beginner
1,211 Views

bitbake edison-image fail: gcc-cross, qemu

I'm following the instructions in the Edison Board Support Package User Guide rev 006. I'm running Ubuntu 14.04 in a Parallels virtual machine under Mac OS X 10.9.5.

Command:

gar@ubuntu:~/edison/edison-src/out/linux64/build$ bitbake edison-image

Result:

ERROR: Task 2137 (virtual:native:/home/gar/edison/edison-src/out/linux64/poky/meta/recipes-devtools/qemu/qemu_2.1.0.bb, do_compile) failed with exit code '1'

NOTE: Tasks Summary: Attempted 771 tasks of which 764 didn't need to be rerun and 2 failed.

Waiting for 0 running tasks to finish:

Summary: 2 tasks failed:

/home/gar/edison/edison-src/out/linux64/poky/meta/recipes-devtools/gcc/gcc-cross_4.9.bb, do_compile

virtual:native:/home/gar/edison/edison-src/out/linux64/poky/meta/recipes-devtools/qemu/qemu_2.1.0.bb, do_compile

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Advice?

Thanks,

 

Gregg
0 Kudos
2 Replies
GGreg3
Beginner
74 Views

Problem solved. The Parallels virtual machine had 1 GiB ram and 2 processors. I bumped that to 8 GiB RAM (on a mac with 16GB) and 4 processors, and it ran to completion in a little over an hour (with a 2.6 GHz Core i7; it's a mac mini).

I did get some warnings though; does anybody know if these can safely be ignored?

WARNING: QA Issue: bluez5: configure was passed unrecognised options: --with-systemdunitdir [unknown-configure-option]

WARNING: busybox: alternative target (/etc/syslog.conf or /etc/syslog.conf.busybox) does not exist, skipping...

WARNING: busybox: NOT adding alternative provide /etc/syslog.conf: /etc/syslog.conf.busybox does not exist

WARNING: alt_link == alt_target: /etc/syslog.conf == /etc/syslog.conf

WARNING: QA Issue: battery-voltage rdepends on libsystemd, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: iotkit-agent requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]

WARNING: QA Issue: xdk-daemon requires libdns_sd.so, but no providers in its RDEPENDS [file-rdeps]

WARNING: QA Issue: pulseaudio-module-console-kit rdepends on consolekit, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: systemd-kernel-install requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]

WARNING: QA Issue: post-install requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]

WARNING: QA Issue: wpa-supplicant-passphrase rdepends on libcrypto, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: wpa-supplicant rdepends on libcrypto, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: wpa-supplicant rdepends on libssl, but it isn't a build dependency? [build-deps]

Thanks,

Gregg

Carlos_M_Intel
Employee
74 Views

Hi Gregg,

Which source files are you using?

After building an image is normal to receive some warnings but shouldn't have a big impact on the image.

Are you doing changes in the image?

Which source files are you using?

After booting the board with the custom image, are you getting problems?

I suggest you to always clean your build folder or to start from scratch when trying to build again.

Regards,

Charlie

Reply