Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,287 Views

can't see intel edison drive on pc

Hello,

I have got 2 new intel edison with arduino breakout board . Followed edison getting started procedure from intel site but couldnt make my pc to see edison drive nor its showing any usb connected.

I have installed all drivers as well tried different cables. I am giving power supply through 7V , 1.5A adapter. In one board i can see ds1 is continuously on and ds3 led blinking continuously and in other only ds1 is glowing.

Thanks in advance.

Tags (1)
7 Replies
Highlighted
Novice
12 Views

sorry its arduino expansion board

0 Kudos
Highlighted
Employee
12 Views

Hi anu1216,

From your description, I understand that none of the Edison modules are recognized regardless of the Arduino Expansion Board used, right?

I recommend you to use the Standalone Driver available here: https://software.intel.com/en-us/iot/hardware/edison/downloads IoT - Intel® Edison Board Download | Intel® Developer Zone. It might fix the issue.

On the other hand, did you check if you have access to the Edison's console? Follow this guide to set up a serial terminal using PuTTY: https://software.intel.com/en-us/get-started-edison-windows-32-step5 IoT - Step 5: Set up a serial terminal | Intel® Developer Zone. You need to install the FTDI Drivers before setting up the terminal. The following guide details the process to install the USB drivers (Standalone Driver) and the FTDI drivers: https://software.intel.com/en-us/get-started-edison-windows-32-step2 IoT - Step 2: Install drivers | Intel® Developer Zone

Let me know if there is any difference after installing those drivers. If there isn't, post a screenshot of your Device Manager while the board is powered with the DC power supply and both USB cables are connected to the PC.

Regards,

Diego

Highlighted
Novice
12 Views

I followed Step 2 to install both the drivers. But there is no change in Device Manager, I will post screenshot tomorrow.

I tried to set up terminal using PuTTY after installing FTDI driver but couldnt not do anything as no serial port is detected.

0 Kudos
Highlighted
Novice
12 Views

I have powered up board with 7V DC (1.5A) and connected both USB and took screenshot of device manager. As well i tried to use flash lite,standalone driver and intel installer too but same.

0 Kudos
Highlighted
New Contributor I
12 Views

Hi I noticed from your Device manager you have an x99 chip set. I had a similar problem to you. I have an x99 too, an ASUS Rampage extreme 5.

In my situation I had to ensure I was using USB2 ports, which was a pain since I needed to use an internal header and an old part to bring the connections to the outside of the case. Once I was on old school USB2 everything worked fine.

Worth a try..

0 Kudos
Highlighted
Employee
12 Views

Hi anu1216,

If you are using USB 3.0 ports, as Irakandjii mentioned, I recommend you to use USB 2.0 ports instead. There are issues reported when using USB 3.0 ports with Edison. The following thread might be of your interest: . It's the thread Irakandjii opened when it faced the issue with the USB 3.0 ports.

Regards,

Diego

0 Kudos
Highlighted
Novice
12 Views

Sorry for late reply.

ya its working now. Thank you very much.

0 Kudos