Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GChow
Beginner
1,568 Views

edison bricked

I only opened my edison today and found that I can't update the firmware. yes, I have tried manual mode, it does not work because I can't see the drive.

I can contact it through putty . BUT that is about it.

I try typing in "reboot ota" and I get

ash: reboot: not found

HERE is the boot log. can anyone help?

******************************

PSH KERNEL VERSION: b0182b2b

WR: 20104000

******************************

SCU IPC: 0x800000d0 0xfffce92c

PSH miaHOB version: TNG.B0.VVBD.0000000c

microkernel built 11:24:08 Feb 5 2015

******* PSH loader *******

PCM page cache size = 192 KB

Cache Constraint = 0 Pages

Arming IPC driver ..

Adding page store pool ..

PagestoreAddr(IMR Start Address) = 0x04899000

pageStoreSize(IMR Size) = 0x00080000

*** Ready to receive application ***

U-Boot 2014.04 (Jun 19 2015 - 12:05:55)

Watchdog enabled

DRAM: 980.6 MiB

MMC: tangier_sdhci: 0

In: serial

Out: serial

Err: serial

Hit any key to stop autoboot: 0

Target:blank

Partitioning already done...

Flashing already done...

GADGET DRIVER: usb_dnl_dfu

reading vmlinuz

5124192 bytes read in 127 ms (38.5 MiB/s)

Valid Boot Flag

Setup Size = 0x00003c00

Magic signature found

Using boot protocol version 2.0c

Linux kernel version 3.10.17-poky-edison+ (sys_dswci@ncsndgbuild04) # 1 SMP PREEMPT Wed Aug 20 16:09:18 CEST 2014

Building boot_params at 0x00090000

Loading bzImage at address 00100000 (5108832 bytes)

Magic signature found

Kernel command line: "rootwait root=PARTUUID=012b3303-34ac-284d-99b4-34e03a2335f4 rootfstype=ext4 console=ttyMFD2 earlyprintk=ttyMFD2,keep loglevel=4 g_multi.ethernet_config=rndis systemd.unit=multi-user.target hardware_id=00 g_multi.iSerialNumber=f0e51eda3cd14b7b2c0602565fc6632f g_multi.dev_addr=02:00:86:c6:63:2f platform_mrfld_audio.audio_codec=dummy"

Starting kernel ...

[ 0.768596] pca953x 1-0020: failed reading register

[ 0.772771] pca953x 1-0021: failed reading register

[ 0.778584] pca953x 1-0022: failed reading register

[ 0.783707] pca953x 1-0023: failed reading register

[ 1.677144] pmic_ccsm pmic_ccsm: Error reading battery profile from battid frmwrk

[ 1.686450] pmic_ccsm pmic_ccsm: Battery Over heat exception

Welcome to Linux!

[ OK ] Reached target Remote File Systems.

Expecting device dev-ttyMFD2.device...

Expecting device dev-mmcblk1p1.device...

[ OK ] Reached target Paths.

[ OK ] Set up automount Arbitrary Executable File Formats F...utomount Point.

[ OK ] Reached target Swap.

[ OK ] Set up automount boot.automount.

[ OK ] Set up automount home.automount.

[ OK ] Created slice Root Slice.

[ OK ] Listening on Delayed Shutdown Socket.

[ OK ] Listening on /dev/initctl Compatibility Named Pipe.

[ OK ] Listening on Syslog Socket.

[ OK ] Listening on udev Kernel Socket.

[ OK ] Listening on udev Control Socket.

[ OK ] Created slice User and Session Slice.

[ OK ] Listening on Journal Socket.

[ OK ] Created slice System Slice.

Starting Remount Root and Kernel File Systems...

Starting Load Kernel Modules...

Starting udev Coldplug all Devices...

Starting Create list of required static device nodes...rrent kernel...

Mounting Debug File System...

Starting Apply Kernel Variables...

Mounting POSIX Message Queue File System...

[ OK ] Created slice system-getty.slice.

[ OK ] Created slice system-serial\x2dgetty.slice.

Starting Journal Service...

[ OK ] Started Journal Service.

[ OK ] Reached target Slices.

Mounting Temporary Directory...

[ OK ] Set up automount factory.automount.

[ 4.341419] g_multi: Unknown parameter `ethernet_config'

[ OK ] Mounted POSIX Message Queue File System.

[ OK ] Mounted Debug File System.

[ OK ] Mounted Temporary Directory.

[ OK ] Started Remount Root and Kernel File Systems.

[FAILED] Failed to start Load Kernel Modules.

See 'systemctl status systemd-modules-load.service' for details.

[ OK ] Started Create list of required static device nodes ...current kernel.

[ OK ] Started Apply Kernel Variables.

[ OK ] Started udev Coldplug all Devices.

Starting Create Static Device Nodes in /dev...

Mounting FUSE Control File System...

Mounting Configuration File System...

Starting Load/Save Random Seed...

[ OK ] Mounted Configuration File System.

[ OK ] Mounted FUSE Control File System.

[ OK ] Started Create Static Device Nodes in /dev.

[ OK ] Started Load/Save Random Seed.

Starting udev Kernel Device Manager...

[ OK ] Reached target Local File Systems (Pre).

Mounting /var/volatile...

[ OK ] Started udev Kernel Device Manager.

[ OK ] Mounted /var/volatile.

[ OK ] Reached target Local File Systems.

Starting Trigger Flushing of Journal to Persistent Storage...

Starting Create Volatile Files and Directories...

[ OK ] Started Create Volatile Files and Directories.

[ OK ] Found device /dev/ttyMFD2.

[ OK ] Started Trigger Flushing of Journal to Persistent Storage.

Starting Network Time Synchronization...

Starting Update UTMP about System Boot/Shutdown...

[ OK ] Created slice system-systemd\x2drfkill.slice.

Starting Load/Save RF Kill Switch Status of rfkill2...

Starting Load/Save RF Kill Switch Status of rfkill0...

Starting Load/Save RF Kill Switch Status of rfkill1...

[ OK ] Started Network Time Synchronization.

[ OK ] Started Load/Save RF Kill Switch Status of rfkill2.

[ OK ] Started Load/Save RF Kill Switch Status of rfkill0.

[ OK ] Started Load/Save RF Kill Switch Status of rfkill1.

[ OK ] Started Update UTMP about System Boot/Shutdown.

[ OK ] Reached target Sound Card.

[ OK ] Reached target System Initialization.

[ OK ] Reached target Timers.

[ OK ] Listening on D-Bus System Message Bus Socket.

[ OK ] Listening on sshd.socket.

[ OK ] Reached target Sockets.

[ OK ] Reached target Basic System.

Starting Watchdog sample daemon...

[ OK ] Started Watchdog sample daemon.

Starting USB Ethernet gadget...

Starting Crashlog service...

[ OK ] Started Crashlog service.

Starting Edison RM button handler...

[ OK ] Started Edison RM button handler.

Starting Kernel Logging Service...

[ OK ...

2 Replies
Pablo_M_Intel
Employee
81 Views

Hi graham_chow,

Have you tried using the Flash Tool Lite? I would suggest you to first try with that as it is the preferred method of flashing your board's firmware, you can check the instructions in here: https://software.intel.com/en-us/flashing-firmware-with-flash-tool-lite https://software.intel.com/en-us/flashing-firmware-with-flash-tool-lite.

If this doesn't work, you can try with the flashall script. Below you can see the instructions.

  1. Download the Edison Yocto Complete image. You can get it from here https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads.
  2. Next, you'll need to download dfu-utils:
    1. If using Windows, download it from vjou's message /message/257947# 257947 https://communities.intel.com/message/257947# 257947. Then save the file in the same folder you extracted the Edison image.
    2. For Mac, open a terminal window and type brew install dfu-util coreutils gnu-getopt.
    3. In Ubuntu, open a terminal window and type sudo apt-get install dfu-util.
  3. Run flashall.sh (Linux and Mac) or flashall.bat (Windows). Open a terminal window, get into the Edison image folder and enter ./flashall.sh or flashall.bat.

Regards,

PabloM_Intel

GChow
Beginner
81 Views

Before I read this (pablom reply), I googled and followed the instructions here...

http://www.instructables.com/id/Fix-an-Intel-Edison-with-a-Corrupted-Linux-Image/ Fix an Intel Edison with a Corrupted Linux Image

I know it is probably not the recommended way, but it sure worked. Now I get... when I boot. My drive is back as well

Poky (Yocto Project Reference Distro) 1.7.2 edison ttyMFD2

Reply