Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

/etc/init.d/networking: No such file or directory problem.

MAham
Novice
4,572 Views

Hello,

I am trying to set up wifi connection in Galileo Gen2. I have installed iot-devkit-201510010757-mmcblkp0-galileo.direct on the board.

Recently I bought intel centrino 2230 ( http://www.amazon.in/ThinPc-Centrino-300mbps-Bluetooth-Antenna/dp/B01BBS1774/ref=sr_1_2?ie=UTF8&qid=... Amazon.in: Buy ThinPc Intel Centrino Mini PCI E Wi-Fi Card 300mbps Speed + Bluetooth 4.0 + Dual Antenna Online at Low Pr… ) and connected to the board. I confirmed its compatible firmware in /lib/firmwire/ (iwlwifi-2030-6.ucode).

I did the followings:

root@galileo:# lspci -k | grep -A 3 -i "network"

01:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)

Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN

Kernel driver in use: iwlwifi

Kernel modules: iwlwifi

root@galileo:/etc/network# cat interfaces

cat: interfaces: No such file or directory

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:C6:FB

inet6 addr: fe80::9a4f:eeff:fe01:c6fb/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1147 errors:0 dropped:0 overruns:0 frame:0

TX packets:1910 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:181289 (177.0 KiB) TX bytes:697143 (680.8 KiB)

Interrupt:51

enp0s20f6:avahi Link encap:Ethernet HWaddr 98:4F:EE:01:C6:FB

inet addr:169.254.11.46 Bcast:169.254.255.255 Mask:255.255.0.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

Interrupt:51

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:81436 errors:0 dropped:0 overruns:0 frame:0

TX packets:81436 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:5868876 (5.5 MiB) TX bytes:5868876 (5.5 MiB)

wlp1s0 Link encap:Ethernet HWaddr 68:17:29:69:73:9B

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:156 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:42239 (41.2 KiB)

(wlan0 does not show up!)

root@galileo:~# cd /etc/network/

root@galileo:/etc/network# ls

if-down.d if-post-down.d if-pre-up.d

(if-up.d is also not present)

root@galileo:/etc/network# /etc/init.d/networking restart

-sh: /etc/init.d/networking: No such file or directory

Can you guys help on this?? I am really stuck in this.

0 Kudos
4 Replies
FTinetti
Honored Contributor I
3,166 Views

Hi syedahamad10,

Take a look at https://software.intel.com/en-us/blogs/2014/03/13/configuring-wifi-for-the-intel-galileo-board Configuring WiFi for the Intel Galileo Board | Intel® Software

Some other threads that may help:

HTH,

Fernando.

idata
Community Manager
3,166 Views

Hello syedahamad10,

 

 

In the eglibc image (which is the one you are using) wlan0 is not present, the wireless interface in shown as wlp1s0. Follow the next guide in order to enable Wi-Fi and configure it:

 

 

https://software.intel.com/en-us/node/519955

 

 

Let me know if it helps you.

 

Peter.
MAham
Novice
3,166 Views

Thank you sir. It worked. Can you elaborate me for proxy setting?

idata
Community Manager
3,166 Views

Hi syedahamad10,

 

 

I haven't had the need to work behind a proxy before, but I think to configure it on your Galileo you'll need to enter the following export http=:. After that you should be able to have normal access. Similar to this thread: /thread/50712 https://communities.intel.com/thread/50712, take a look at the last post.

 

 

Regards,

 

Pablo
Reply