Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,006 Views

eth0 device not found with LSB image

I am running LSB image, when i try to configure eth0 with ifconfig, i get

eth0: error fetching interface information: Device not found

i tried ifup eth0

eth0: ERROR while getting interface flags: No such device

ifconfig only shows settings for lo, nothing else.

0 Kudos
8 Replies
Highlighted
Novice
18 Views

looking at dmesg, it seems stmmaceth is not loaded at all, no sign of it or eth0 being loaded. could i have forgotten something when building the LSB image?

0 Kudos
Highlighted
New Contributor II
18 Views

Let's try some basic steps:

- Is one of the LEDs on the ethernet port on after powering the Galileo?

- Did you wait at least 30sec after turning off before a new start?

- Did you attached the ethernet cable to a network before you turned it on?

I use the LSB image too, and the only - regular - problem for me is, the Galileo does not recognize a connection, if I connect the cable *after* start up.

0 Kudos
Highlighted
Novice
18 Views

yes the orange light is on, after i plug in the ethernet cable a yellow light comes on.

yes waited 30 secs.

yes tried that too.

the eth0 port works perfectly fine without the LSB image, i compared the dmesg from both images, the difference is eth0 and its driver stmmac is not loaded for the LSB image at start up, i have attached the two outputs.

reading this documents on stmmac, https://www.kernel.org/doc/Documentation/networking/stmmac.txt https://www.kernel.org/doc/Documentation/networking/stmmac.txt, seems stmmac should be enabled in kernel configurations ( see under 1. ). seeing that it does not load at start up, maybe i should have enabled it before building the image? i used bsp version 0.9.

quick edit: seems my assumption about stmmac is wrong, it is loaded correctly into kernel, i dont understand why it isnt loading. excuse my random assumptions, i am learning this as on the go.

lsmod shows stmmac is used by 0.

0 Kudos
Highlighted
New Contributor II
18 Views

I'm not that linux/network guru and unfortunatly, your linux wizard is sick at home. And I also should mention, I'm still on a 0.7.5 based LSB image. And to make it worst: I broke my Wlan card yesterday. But let's try some other ideas:

I forgot one important question: How do you currently access the Galileo? Via Wlan?

The stmmac module on my Galileo is also used by 0 - although I'm currently connected to it via eth0.

Some other ideas to check:

- What shows lspci? I get this:

...

00:14.6 Ethernet controller: Intel Corporation Device 0937 (rev 10)

00:14.7 Ethernet controller: Intel Corporation Device 0937 (rev 10)

...

- Check your kernel configuration. You can do this on your host computer. In your ./yocto_build directory call:

bitbake virtual/kernel -c menuconfig

You get a GUI to configure the kernel. The following stuff should be enabled:

* Bus options (PCI etc) -> [*] PCI support

* Device Drivers -> Network device support -> [*] Ethernet driver support -> ...

On my kernel the following ethernet drivers are enabled:

[*] Cadence devices

[*] Intel devices ->

Intel(R) PRO/100 Gigabit Ethernet support

[*] STMicroelectronics devices ->

STMicroelectronics 10/100/1000 Ethernet driver

[*] STMMAC PCI bus support

[*] STMMAC DMA arbitration scheme

0 Kudos
Highlighted
Novice
18 Views

ntel(R) PRO/100 Gigabit Ethernet support was not selected... not sure how that happend. do i run bit bake again after config?

Edit: ran bitbake, much faster this time, almost began at the end. let see if it fixes the problem. thanks a mil for helping me out!

0 Kudos
Highlighted
Novice
18 Views

seems that isn't the problem, i will try to run 0.7.5 bsp and see if that helps. on the upside, i got the wifi working, able to connect through wifi.

0 Kudos
Highlighted
Novice
18 Views

I ran the board on 0.7.5 based LSB image, the ethernet works just fine now, i wonder if this was a bug on 0.9 ?

0 Kudos
Highlighted
Novice
18 Views

Solution to this problem is in post 6 of this thread

0 Kudos