Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
4,597 Views

ethernet connection on galileo

Hi I have galileo gen2 board, i am using

Linux galileo 3.8.7-yocto-standard # 2 Wed May 25 00:22:16 PDT 2016 i586 GNU/Linux

I want to connect internet via ethernet cable to my galileo, for this i want to share my laptop wireless net connection to galileo.

I tried some tutorials say http://www.google.co.in/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwjY6fH_6bn... http://www.google.co.in/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwjY6fH_6bn... Intel® Galileo : Share Laptop/PC WiFi to Galileo over LAN but no luck, every time when i ping,

root@galileo:~# ping www.google.con

ping: bad address 'www.google.con'

root@galileo:~#

pls help me connecting internet on galileo, its urgent

pls reply soon

thanks in advance

thanks

Tags (1)
0 Kudos
11 Replies
Highlighted
Honored Contributor I
1,461 Views

Hi megalileo,

The problem is that the yocto linux used in this card does not have DNS set. Take a look at

HTH,

Fernando.

0 Kudos
Highlighted
Community Manager
1,461 Views

Hi megalileo,

Could you run cat /etc/version and show us the output? Or are you using a custom image? I would like to test this under your environment settings.

In order to use a bridge between the Galileo Board and the PC, you will need to do the following.

 

Go to "Open Network and Sharing Center" > "Change adapter settings". In there, right click on your Wireless Network Connection and then to Properties > Sharing, in there enable the first option. This would be the same steps (1-4) from the tutorial: http://www.instructables.com/id/Intel-Galileo-Share-LaptopPC-WiFi-to-Galileo-over-/%3FALLSTEPS http://www.instructables.com/id/Intel-Galileo-Share-LaptopPC-WiFi-to-Galileo-over-/?ALLSTEPS

If you get the message "Internet connection sharing has been disabled by the network administrator" in the sharing tab, try with the following: https://technet.microsoft.com/en-us/library/cc770930%28v%3Dws.10%29.aspx https://technet.microsoft.com/en-us/library/cc770930(v=ws.10).aspx

I think the problem you have is that you are not setting correctly the IP address on the enp0s20f6 interface. Open a Putty session in your PC, and run ifconfig, you should see the lo and enp0s20f6 interfaces. Run ifconfig enp0s20f6 down

 

Open a console prompt in your PC, and run the command ipconfig. You should see something like:

 

If the IPv4 Address on your computer is 192.168.10.30 you can to set the enp0s20f6 interface with 192.168.10.31, never use the same IP the computer has. On Putty you need to run the commands ifconfig enp0s20f6 down and then ifconfig enp0s20f6 192.168.10.31, or the IP address you have chosen.

Please let me know if you have been setting the IP address correctly, provide some screenshots so we could see your steps.

 

Have you tried changing the DNS address?

 

Also, check the status of the bridge on your computer.

Regards,

 

Charlie

 

0 Kudos
Highlighted
New Contributor I
1,461 Views

Hi very great thanks for your reply, this time I am in my college, don't have laptop here and try sharing my laptop connection at night in home......

but in mean time I want to connect my college net connection to galileo, but no luck again

I am using:

galileo login: root

root@galileo:~# uname -a

Linux galileo 3.8.7-yocto-standard # 2 Wed May 25 00:22:16 PDT 2016 i586 GNU/Linux

root@galileo:~# cat /etc/version

201606062125

root@galileo:~#

as you asked.

for connecting my college net to PCs in the lab we do the following settings,

Highlighted
New Contributor I
1,461 Views

Hi very great thanks for your reply, this time I am in my college, don't have laptop here and try sharing my laptop connection at night in home......

but in mean time I want to connect my college net connection to galileo, but no luck again

I am using:

galileo login: root

root@galileo:~# uname -a

Linux galileo 3.8.7-yocto-standard # 2 Wed May 25 00:22:16 PDT 2016 i586 GNU/Linux

root@galileo:~# cat /etc/version

201606062125

root@galileo:~#

as you asked.

for connecting my college net to PCs in the lab we do the following settings

and then plug an ethernet cable to my galileo then,

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet6 addr: fe80::9a4f:eeff:fe01:8070/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2148 errors:0 dropped:0 overruns:0 frame:0

TX packets:61 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:164176 (160.3 KiB) TX bytes:15628 (15.2 KiB)

Interrupt:51 Base address:0x4000

enp0s20f6:avahi Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet addr:169.254.7.95 Bcast:169.254.255.255 Mask:255.255.0.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

Interrupt:51 Base address:0x4000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:960 errors:0 dropped:0 overruns:0 frame:0

TX packets:960 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:72160 (70.4 KiB) TX bytes:72160 (70.4 KiB)

root@galileo:~# ifconfig enp0s20f6:avahi 192.168.1.27 netmask 255.255.252.0 up

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet6 addr: fe80::9a4f:eeff:fe01:8070/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2615 errors:0 dropped:0 overruns:0 frame:0

TX packets:110 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:203567 (198.7 KiB) TX bytes:32507 (31.7 KiB)

Interrupt:51 Base address:0x4000

enp0s20f6:avahi Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet addr:192.168.1.27 Bcast:192.168.3.255 Mask:255.255.252.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

Interrupt:51 Base address:0x4000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:1760 errors:0 dropped:0 overruns:0 frame:0

TX packets:1760 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:129760 (126.7 KiB) TX bytes:129760 (126.7 KiB)

root@galileo:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

192.168.0.0 * 255.255.252.0 U 0 0 0 enp0s20f6

root@galileo:~# route add default gw 192.168.1.1 netmask 255.255.252.0

root@galileo:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default localhost.local 255.255.252.0 UG 0 0 0 enp0s20f6

192.168.0.0 * 255.255.252.0 U 0 0 0 enp0s20f6

root@galileo:~# connmanctl

connmanctl> services

*AR Wired ethernet_984fee018070_cable

connmanctl> config ethernet_984fee018070_cable --ipv4 manual 192.168.1.27 255.255.252.0 192.168.1.1

connmanctl> exit

root@galileo:~# ping 192.168.1.27

PING 192.168.1.27 (192.168.1.27): 56 data bytes

64 bytes from 192.168.1.27: seq=0 ttl=64 time=0.531 ms

64 bytes from 192.168.1.27: seq=1 ttl=64 time=0.420 ms

64 bytes from 192.168.1.27: seq=2 ttl=64 time=0.420 ms

64 bytes from 192.168.1.27: seq=3 ttl=64 time=0.409 ms

64 bytes from 192.168.1.27: seq=4 ttl=64 time=0.479 ms

64 bytes from 192.168.1.27: seq=5 ttl=64 time=0.406 ms

64 bytes from 192.168.1.27: seq=6 ttl=64 time=0.406 ms

64 bytes from 192.168.1.27: seq=7 ttl=64 time=0.406 ms

64 bytes from 192.168.1.27: seq=8 ttl=64 time=0.421 ms

64 bytes from 192.168.1.27: seq=9 ttl=64 time=0.422 ms

64 bytes from 192.168.1.27: seq=10 ttl=64 time=0.408 ms

^C

--- 192.168.1.27 ping statistics ---

11 packets transmitted, 11 packets received, 0% packet loss

round-trip min/avg/max = 0.406/0.429/0.531 ms

root@galileo:~# connmanctl ethernet_984fee018070_cable --nameservers 8.8.8.8 8.8.4.4

root@galileo:~# ping google.com

ping: bad address 'google.com'

root@galileo:~#

I am very upset now

pls help me connecting internet on galileo

pls reply soon, waiting...........

thanks in advance

thanks

Highlighted
New Contributor I
1,461 Views

Hi thanks for reply, i tried as u said, but still no luck

connected ethernet cable from pc to galileo

power on galileo

started putty

started wifi hotspot and connected to pc

while galileo booting, setup my pc

now on galileo

galileo login: root

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet addr:192.168.1.27 Bcast:192.168.3.255 Mask:255.255.252.0

inet6 addr: fe80::9a4f:eeff:fe01:8070/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:187 errors:0 dropped:0 overruns:0 frame:0

TX packets:768 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:19018 (18.5 KiB) TX bytes:46018 (44.9 KiB)

Interrupt:51 Base address:0xc000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:844 errors:0 dropped:0 overruns:0 frame:0

TX packets:844 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:72088 (70.3 KiB) TX bytes:72088 (70.3 KiB)

root@galileo:~# ifconfig enp0s20f6 down

root@galileo:~# [ 667.139286] IPv6: ADDRCONF(NETDEV_UP): enp0s20f6: link is not ready

root@galileo:~# ifconfig enp0s20f6 169.254.36.103 netmask 255.255.0.0

[ 1057.590759] enp0s20f6: device MAC address 98:4f:ee:01:80:70

[ 1057.632396] IPv6: ADDRCONF(NETDEV_UP): enp0s20f6: link is not ready

root@galileo:~# [ 1059.600225] libphy: stmmac-1:01 - Link is Up - 100/Full

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet addr:169.254.36.103 Bcast:169.254.255.255 Mask:255.255.0.0

inet6 addr: fe80::9a4f:eeff:fe01:8070/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:189 errors:0 dropped:0 overruns:0 frame:0

TX packets:934 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:19190 (18.7 KiB) TX bytes:62094 (60.6 KiB)

Interrupt:51 Base address:0xc000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:2951 errors:0 dropped:0 overruns:0 frame:0

TX packets:2951 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:225184 (219.9 KiB) TX bytes:225184 (219.9 KiB)

root@galileo:~# ping google.com

ping: bad address 'google.com'

root@galileo:~# connmanctl services

*AR Wired ethernet_984fee018070_cable

8.8 8.8.4.4o:~# connmanctl config ethernet_984fee018070_cable --nameservers 8.8.8

root@galileo:~# ping google.com

ping: bad address 'google.com'

root@galileo:~#

one thing more whenever i write a long commandline the cursor comes to left, as you see above (in nameservers 8.8.8.8 8.8.4.4) is there any way to write long commands in putty

I am very upset now

pls help me connecting internet on galileo, sharing laptop net and college ethernet, how to set my proxy port

pls reply soon, waiting...........

thanks in advance

thanks

0 Kudos
Highlighted
Community Manager
1,461 Views

Hi megalileo,

How are you setting the bridge between the WiFi and Ethernet interfaces on your PC? You should select both of them, then right click on one of them and select Bridge Connections, just like:

 

This should enable the bridge, try this with the galileo unplugged to the Ethernet cable.

 

Are you behind a proxy? Are you setting it as it should?

 

Also, be sure that the Network is not blocking the new IP address and/or if there is another device with the same IP connected to the Network.

 

Have you tried to enable the bridge and connect another device to the laptop? With this we could see if the problem is the configuration on the PC or in the board.

Regards

 

Charlie
Highlighted
New Contributor I
1,461 Views

Hi thanks for reply,

Actually I am Doing two things : want to connect my college direct wired connection to galileo, here I am at a proxy with proxy ip 192.168.1.1 and proxy port 3128, ip 192.168.0.1 and mask 255.255.252.0

as I showed in the screen shots in post 4 pls see it

but I could not find the way to config these settings, pls tell me the procedure to set these settings

AND

secondly I want to share my laptop net to galileo so that I can use net on galileo in my home also, I will try bridge as u said

Highlighted
Honored Contributor I
1,461 Views

megalileo wrote:

Hi thanks for reply,

Actually I am Doing two things

...

I suggest you solve one of them at a time. First, because it's easier, of course. And second, because you will have to use different configurations in the different environments, i.e. I think there is no single network configuration for networking in your two scenarios.

For your home scenario, if your home wifi router has LAN Ethernet cable option I suggest you use the Ethernet cable first so that your Intel Galileo will be directly connected to the internet. I've seen that most of the home routers have one, like mine:

(sorry for the dirt...) but I think it would depend on too many local/country details so I don't know what your case would be. If this is also your case, then your Intel Galileo would receive it's IP from the router DHCP, will be one more device connected to the LAN (like your computers) and will have access to the Internet. You are able to assign a fixed IP, but take into account not to collide with other computers that receive their IP via DHCP. If you want to have DNS, then use the information in the thread above.

Another possibility for the home scenario is the one you asked for and explained above by Charlie, I've not tried it so if you try please let me know your results.

The scenario of the college is different, since you have to set the proxy. I've been trying to find something in this forum, but everything seems to be related to http traffic...

Fernando.

0 Kudos
Highlighted
New Contributor I
1,461 Views

Thanks for reply,

OK I got your point, now i first focus on direct wired connection, I don't have direct LAN port on my wifi router (actually i use my phone to make wifi hotspot)

any way now i am going to spent a week or two in my college hostel for my embedded workshop, so i am trying direct wired connection

as I wrote we do the following settings to connect LAN to our pc in my college net lab,

now I tried this on my galileo

root@galileo:~# ifconfig enp0s20f6 down

root@galileo:~# [ 105.759797] IPv6: ADDRCONF(NETDEV_UP): enp0s20f6: link is not ready

root@galileo:~# ifconfig enp0s20f6 192.168.0.12 netmask 255.255.252.0

[ 153.357997] enp0s20f6: device MAC address 98:4f:ee:01:80:70

[ 153.392397] IPv6: ADDRCONF(NETDEV_UP): enp0s20f6: link is not ready

root@galileo:~# [ 155.360233] libphy: stmmac-1:01 - Link is Up - 100/Full

[ 155.365540] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s20f6: link becomes ready

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:80:70

inet addr:192.168.0.12 Bcast:192.168.3.255 Mask:255.255.252.0

inet6 addr: fe80::9a4f:eeff:fe01:8070/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:325 errors:0 dropped:0 overruns:0 frame:0

TX packets:118 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:25712 (25.1 KiB) TX bytes:13952 (13.6 KiB)

Interrupt:51

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:496 errors:0 dropped:0 overruns:0 frame:0

TX packets:496 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:38752 (37.8 KiB) TX bytes:38752 (37.8 KiB)

root@galileo:~# route add default gw 192.168.1.1 netmask 255.255.252.0

root@galileo:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default localhost.local 255.255.252.0 UG 0 0 0 enp0s20f6

default localhost.local 0.0.0.0 UG 0 0 0 enp0s20f6

8.8.4.4 localhost.local 255.255.255.255 UGH 0 0 0 enp0s20f6

8.8.8.8 localhost.local 255.255.255.255 UGH 0 0 0 enp0s20f6

192.168.0.0 * 255.255.252.0 U 0 0 0 enp0s20f6

192.168.1.1 * 255.255.255.255 UH 0 0 0 enp0s20f6

root@galileo:~# connmanctl

connmanctl> services

*AR Wired ethernet_984fee018070_cable

connmanctl> config ethernet_984fee018070_cable --ipv4 manual 192.168.0.12 255.255.252.0 192.168.1.1

connmanctl> config ethernet_984fee018070_cable --nameservers 8.8.8.8 8.8.4.4

for the proxy problem I got this https://wiki.yoctoproject.org/wiki/Working_Behind_a_Network_Proxy https://wiki.yoctoproject.org/wiki/Working_Behind_a_Network_Proxy

root@galileo:~# export http_proxy=' http://192.168.1.1:3128/'

root@galileo:~# export https_proxy=' http://192.168.1.1:3128/'

root@galileo:~# export ftp_proxy=' http://192.168.1.1:3128/'

root@galileo:~# export no_proxy='.example.com'

root@galileo:~# ping google.com

ping: bad address 'google.com'

root@galileo:~#

even then no luck

pls help me,

egerly waiting your reply pls reply soon

thanks in advance

thanks

Highlighted
Honored Contributor I
1,461 Views

I see...

I'm not able to help on the proxy details because I think you have right settings (so I don't know what the problem is...) but maybe you can try something in the meantime. If you set

ifconfig enp0s20f6 192.168.0.12 netmask 255.255.252.0

while your pc is on, then you will have a problem, since there are two devices with the same IP in the same LAN... try to set another IP to your PC or the Galileo. You can ask your network/systems admin for non used IPs or just use the "usual" trial-error method with IPs "similar" the one your PC has (e.g. 192.168.0.50).

HTH,

Fernando.

0 Kudos
Highlighted
Community Manager
1,461 Views

Hi megalileo,

 

 

Did you tried with Fernando's suggestions? Let us know if you have updates on this.

 

 

Regards,

 

Charlie
0 Kudos