Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PMuld2
New Contributor II
1,508 Views

flashall script gives no response

Hi,

I am trying to run the flashall script to upgrade the Intel Edison firmware (via MacOS).

I see this:

pm:edison-image-ww05-15 pmu$ ./flashall.sh

Using U-Boot target: edison-blankcdc

Now waiting for dfu device 8087:0a99

Please plug and reboot the board

dfu-util: Device has DFU interface, but has no DFU functional descriptor

Flashing IFWI

Flashing U-Boot

Flashing U-Boot Environment

Flashing U-Boot Environment Backup

Rebooting to apply partition changes

Now waiting for dfu device 8087:0a99

But then it seems that the script hangs.

Any options to debug this?

Thanks!

5 Replies
PMuld2
New Contributor II
97 Views

Especially, it might be nice to learn more about the command:

# reboot ota

and when in bootloader mode:

microkernel built 23:15:13 Apr 24 2014

******* PSH loader *******

PCM page cache size = 192 KB

Cache Constraint = 0 Pages

Arming IPC driver ..

Adding page store pool ..

PagestoreAddr(IMR Start Address) = 0x04899000

pageStoreSize(IMR Size) = 0x00080000

*** Ready to receive application ***

U-Boot 2014.04 (Aug 20 2014 - 16:08:32)

Watchdog enabled

DRAM: 980.6 MiB

MMC: tangier_sdhci: 0

In: serial

Out: serial

Err: serial

Hit any key to stop autoboot: 0

boot >

how to do some basic checks if any update has been applied already?

Or possibly control to upgrade from here?

PMuld2
New Contributor II
97 Views

Possibly, there is an approach to do the upgrade via:

boot > run do_ota

reading ota_update.scr

** Unable to read file ota_update.scr **

Saving Environment to MMC...

Writing to MMC(0)... done

resetting ...

PMuld2
New Contributor II
97 Views

also with the phone flash tool lite, I get no response:

12/27/15 22:16:18.741 INFO : [Port 1/3] osimage -- /Users/pmu/Downloads/edison-iotdk-image-280915/u-boot-edison.img

12/27/15 22:16:18.741 INFO : [Port 1/3] gpflags -- 0x80000007

12/27/15 22:16:18.741 INFO : [Port 1/3] softfuse --

12/27/15 22:16:18.748 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 0

12/27/15 22:16:19.749 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 1

12/27/15 22:16:20.750 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 2

12/27/15 22:16:21.751 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 3

12/27/15 22:16:22.753 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 4

12/27/15 22:16:23.754 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 5

12/27/15 22:16:24.756 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 6

12/27/15 22:16:25.758 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 7

12/27/15 22:16:26.760 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 8

12/27/15 22:16:27.761 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 9

12/27/15 22:16:28.763 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 10

12/27/15 22:16:29.764 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 11

12/27/15 22:16:30.766 INFO : [Port 1/3] XFSTK-STATUS--Detecting Intel Device - Attempt # 12

PMuld2
New Contributor II
97 Views

Now, after booting and rebooting the Laptop, flashall was not yet running successfully.

But I tried then the flash lite tool again, and now it seemed to have worked:

"/Users/pmu/Downloads/edison_fw/edison-image-edison.hddimg" "-t" "4096" "-d" "8087:0a99"` succeed

12/27/15 22:31:56.716 INFO : [Port 1/3] Running `"/Applications/Phone Flash Tool Lite.app/Contents/MacOS/dfu-util" "--alt" "rootfs" "-D" "/Users/pmu/Downloads/edison_fw/edison-image-edison.ext4" "-t" "4096" "-R" "-d" "8087:0a99"` command

12/27/15 22:35:48.568 INFO : [Port 1/3] Command `"/Applications/Phone Flash Tool Lite.app/Contents/MacOS/dfu-util" "--alt" "rootfs" "-D" "/Users/pmu/Downloads/edison_fw/edison-image-edison.ext4" "-t" "4096" "-R" "-d" "8087:0a99"` succeed

12/27/15 22:35:48.568 INFO : [Port 1/3] Running `Notify` command

12/27/15 22:35:48.634 INFO : Displaying notification during 60000 ms

12/27/15 22:35:48.634 INFO : [Port 1/3] Command `Notify` succeed

12/27/15 22:35:48.635 INFO : [Port 1/3] Flash success (duration=00:04:43.869)

 

And on the Edison serial debug port:

 

-Boot 2014.04 (Jun 19 2015 - 12:05:55)

Watchdog enabled

DRAM: 980.6 MiB

MMC: tangier_sdhci: 0

In: serial

Out: serial

Err: serial

Writing to redundant MMC(0)... done

Writing to MMC(0)... done

Hit any key to stop autoboot: 0

Target:blank

Partitioning using GPT

Writing GPT: success!

Saving Environment to MMC...

Writing to redundant MMC(0)... done

Flashing already done...

GADGET DRIVER: usb_dnl_dfu

#

DFU complete CRC32: 0xb98db2f8

DOWNLOAD ... OK

Ctrl+C to exit ...

#

Sergio_A_Intel
Employee
97 Views

Hi,

I'm glad you managed to flash your board. I noticed you were trying to flash image ww05-15. There is a newer version from ww25.5-15 that can be found here http://downloadmirror.intel.com/25028/eng/edison-image-ww25.5-15.zip http://downloadmirror.intel.com/25028/eng/edison-image-ww25.5-15.zip . About the reboot OTA method, this method is no longer used. You'll get an error if you try to flash the latest image using this method. You can see more information here

Sergio

Reply