Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

how to load g_webcam

FATA
New Contributor I
2,131 Views

Hi

Can anyone tell me how to load g_webcam on galeleio gen 2 board.

I am getting below logs when i am loading g_webcam

root@quark:~# modprobe g_webcam

[ 1273.212399] g_webcam gadget: uvc_function_bind

[ 1273.216940] g_webcam gadget: Unable to allocate streaming EP

[ 1273.228828] g_webcam 0000:00:14.2: failed to start g_webcam: -22

modprobe: ERROR: could not insert 'g_webcam': Invalid argument

Thanks

4 Replies
Pedro_M_Intel
Employee
216 Views

Hello farazata,

Could you let us know which modules did you add/modify? And which steps did you take to add this module?

I mean, could you explain us a little bit more about how you got this error?

Peter.

FATA
New Contributor I
216 Views

I jst enabled g_webcam through make menuconfig.

I when i deid modprobe g_webcam

I encountered the above error

Pedro_M_Intel
Employee
216 Views

Can you send us a screenshot of the menuconfig configuration? Also, did you check if g_webcam has any dependencies And if so did you make sure to install them?

Peter.

Carlos_M_Intel
Employee
216 Views

Hi farazata,

Do you have updates on this?

After the changes in the menuconfig, are you changing the defconfig file? Are you able to see in the defconfig file the changes?

Regards,

Charlie

Reply