Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ddor
Novice
953 Views

mcu api - "connection to 192.168.2.15 failed"

Jump to solution

hello,

i'm quite new to Edison, and the mcu api in particular.

i'm trying to create an mcu api project, and i've walked through the entire official tutorial, and yet, is still can't manage to "download"

my project to the board, as i get a "connection to 192.168.2.15 failed" error everytime..

what am i missing ?

thanks for the help,

Dor

1 Solution
Diego_V_Intel
Employee
90 Views

Hi dorlX,

That issue might be caused by the IP address used by your Edison. You need to access the Edison's console and run the following command: configure_edison --showWiFiIP. This command will show you what IP address your Edison has. That's the IP address you should use in the MCU SDK.

The IP address 192.168.2.15 is the default IP address, and it has be changed if your Edison has another one. Please check the following guide: https://software.intel.com/en-us/node/545144 Creating, building, and working with MCU projects | Intel® Developer Zone. In the section "Connecting Eclipse to a different board" you will find the instructions to change the IP address in the MCU SDK.

Regards,

Diego

View solution in original post

2 Replies
Diego_V_Intel
Employee
91 Views

Hi dorlX,

That issue might be caused by the IP address used by your Edison. You need to access the Edison's console and run the following command: configure_edison --showWiFiIP. This command will show you what IP address your Edison has. That's the IP address you should use in the MCU SDK.

The IP address 192.168.2.15 is the default IP address, and it has be changed if your Edison has another one. Please check the following guide: https://software.intel.com/en-us/node/545144 Creating, building, and working with MCU projects | Intel® Developer Zone. In the section "Connecting Eclipse to a different board" you will find the instructions to change the IP address in the MCU SDK.

Regards,

Diego

View solution in original post

ddor
Novice
90 Views

worked fine, thanks for the help.

Reply