Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
3,215 Views

miniupnpd-2.0 does not work with wlan0 interface

We are using the Ethernet and WIFI interface on Intel-galileo rev2 board.we are currently use miniupnpd-2.0 linux utility to discover board IP-address to remote server. upnp-inspector utility was installed in remote server.

miniupnpd is work fine with eth0 interface on galileo board and we can chek the board ip on remote server with the help of upnp inspector.check log of galileo board as below

log:

command:

miniupnpd -i eth0 -a eth0 -d

response:

miniupnpd[14400]: version 2.0 starting UPnP-IGD ext if eth0 BOOTID=1474286063 miniupnpd[14400]: HTTP listening on port 51453

miniupnpd[14400]: HTTP REQUEST from 192.168.60.1:57189 : GET /rootDesc.xml (HTTP/1.1) miniupnpd[14400]: Host: 192.168.60.141:51453

miniupnpd[14400]: HTTP REQUEST from 192.168.60.1:57189 : GET /rootDesc.xml (HTTP/1.1) miniupnpd[14400]: Host: 192.168.60.141:51453

miniupnpd[14400]: HTTP REQUEST from 192.168.60.1:57189 : GET /rootDesc.xml (HTTP/1.1) miniupnpd[14400]: Host: 192.168.60.141:51453

Now We change interface eth0 to wlan0 in miniupnpd. It stop to work and ip is not discover to remote server.it stop after "HTTP listening on port 43391" as per below log.

command:

miniupnpd -i wlan0 -a wlan0 -d

response:

miniupnpd[15292]: version 2.0 starting UPnP-IGD ext if wlan0 BOOTID=1474286261 miniupnpd[15292]: HTTP listening on port 43391

After only two line it will stuck up and not further process.

Please help us to solve the problem.

Thanks in advance.

0 Kudos
12 Replies
idata
Community Manager
134 Views

Hi Nikunj,

 

 

I've a few questions:
  • What image are you using, the uclibc or the eglibc?
  • Do you have connectivity to the server with both the eth0 and wlan0 interface, are you able to make ping requests?
  • Have you done any configuration to the server that might deny requests from the wlan0 interface?
  • Have you made any configurations to the miniupnpd.conf file? Attach the contents of this file to see the configuration settings.
We'll be waiting for your response.

 

 

-Sergio

 

idata
Community Manager
134 Views

Thank for quick support.

1) We are use our custom image based on the clanton-1.1.0 sdk.

2) Yes. We test ping with both the interface . Also We can access of ssh on both wlan0 and eth0 interface.

3) No. We have no any changes regarding wlan0.

4) Please check the configuration file data as below.

port=0

enable_upnp=yes

bitrate_up=1000000

bitrate_down=10000000

secure_mode=yes

system_uptime=yes

notify_interval=30

clean_ruleset_interval=600

serial=01

uuid=98:4F:EE:05:76:EC

ext_ifname=wlan0

listening_ip=wlan0

friendly_name=quark-98:4F:EE:05:76:EC

manufacturer_name=3.8.7-yocto-standard

manufacturer_url= http://www.3.8.7-yocto-standard.in

model_name=quark

model_description=quark_RAM=237052kB

model_url= http://www.quark.in

model_number=quark

idata
Community Manager
134 Views

Are those all the contents of the miniupnpd.conf? I looked at other miniupnpd.conf and they contained more options. Some of the options that could be relevant are enable_natpmp=yes and the deny/allow permission rules. These permission rules will allow a range of port numbers and IP addresses.

 

 

You can see more information on these permissions here:

 

http://wiki.ipfire.org/en/addons/miniupnpd/start http://wiki.ipfire.org/en/addons/miniupnpd/start

 

https://github.com/miniupnp/miniupnp/blob/master/miniupnpd/miniupnpd.conf https://github.com/miniupnp/miniupnp/blob/master/miniupnpd/miniupnpd.conf

 

 

I also found this link you might find useful https://forum.openwrt.org/viewtopic.php?id=51230 https://forum.openwrt.org/viewtopic.php?id=51230 . The user of this thread had a similar issue and there are several suggestions you might find helpful.

 

 

Let us know your results.

 

 

-Sergio

 

idata
Community Manager
134 Views

Thanks

Yes these all content are of miniupnpd.conf

I will check with the enable_natpmp=yes option and will know the result of that.

idata
Community Manager
134 Views

Keep us updated on your progress.

 

 

-Sergio

 

idata
Community Manager
134 Views

I check with enable_natpmp=yes option.

But still no progress.

Please help us to support .

Thanks in advance.

idata
Community Manager
134 Views

And what about the deny/allow permission rules. Have you added the ports and IP addresses of your network? What's the output of running the command route –n? Check that the IP routing table is configured properly. Also, how have you configured the remote server? Please name all the network-related configuration settings.

 

 

We'll be waiting for your response.

 

 

-Sergio

 

idata
Community Manager
134 Views

Hello;

I have also test with deny/allow permission rules. but still issue is not solve.

Please check the below log of route -n .

root@quark:/lib/systemd/system# route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

0.0.0.0 192.168.61.1 0.0.0.0 UG 0 0 0 wlan0

0.0.0.0 192.168.100.1 0.0.0.0 UG 0 0 0 eth0

192.168.0.203 192.168.100.1 255.255.255.255 UGH 0 0 0 eth0

192.168.61.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

192.168.100.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

192.168.100.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0

Thanks in advance.

Nikunj Patel

idata
Community Manager
134 Views

Thank you for providing the routing table we requested. From it you can see the behavior wlan0 is supposed to have with the lines

 

 

Destination Gateway Genmask Flags Metric Ref Use Iface

 

0.0.0.0 192.168.61.1 0.0.0.0 UG 0 0 0 wlan0

 

192.168.61.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

 

 

The first line means that any package from any destination will be sent through the gateway 192.168.61.1. The second line has a gateway 0.0.0.0. This means that there is no gateway specified so the packages sent through this interface won't be routed through the network. If you have your wlan0 interface in the 192.168.61.0/24 network, you won't be able to reach the server. This might be the cause of your error.
  • What's your wlan0 interface IP address?
  • Why specifically did you configure the routing table with these IPs?
  • What's the IP address of your server?

Let us know if you manage to use miniupnpd.

-Sergio

idata
Community Manager
134 Views

Hello;

Thanks for your quick reply.

Please check route command output when only wifi is connected.

root@quark:/mnt# route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

0.0.0.0 192.168.61.1 0.0.0.0 UG 0 0 0 wlan0

192.168.61.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

1) Board wlan0 IP is : 192.168.61.119

2) We don't configure the routing table.i just run the "udhcpc -i wlan0" command to get the dynamic ip.

3) We have two server 1) Server IP is : 192.168.100.195

2) Server IP is: 192.168.0.45

Best Regards;

Nikunj Patel

idata
Community Manager
134 Views

Thank you for providing the information we requested. We'll do some research and contact you back soon.

 

 

-Sergio

 

idata
Community Manager
134 Views

Hello Nikunj,

 

 

Thank you for your time waiting. I've been working on your issue, but unfortunately I could not find anything useful for you. Since you are using a custom image, it's hard to know what might be the root of the issue. My recommendation for you is to use the default image available on our website, but if you prefer using your custom image, I'm afraid I could not provide any other suggestions to try.

 

 

Anyhow, if you can find a solution for it, please share it with the community since other users might be benefit with your findings.

 

 

I apologize I couldn't provide a more useful response for you, but that's all I have.

 

 

Regards,

 

Sergio

 

Reply