Community
cancel
Showing results for 
Search instead for 
Did you mean: 
aselv1
Novice
901 Views

partition changing

Download the http://software.intel.com/en-us/iot/hardware/edison/downloads Edison Linux source files.

where is the source file ??

where i have to done this process

Decompress the source file: tar xvf .

in bsp guide i run the first command but its showing me an error like

root@Sparky:~# sudo apt-get install build-essential git diffstat gawk chrpath texinfo libtool gcc-multilib

Reading package lists... Done

Building dependency tree

Reading state information... Done

chrpath is already the newest version.

diffstat is already the newest version.

gawk is already the newest version.

libtool is already the newest version.

texinfo is already the newest version.

build-essential is already the newest version.

git is already the newest version.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

gcc-multilib : Depends: gcc-4.6-multilib (>= 4.6.3-1~) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

please provide me a step by step process

0 Kudos
6 Replies
idata
Community Manager
44 Views

Hello Ayyappan91,

 

 

Thanks for reaching out!

 

 

You can download the source from https://iotdk.intel.com/src/3.5/edison/.

 

 

The following steps have been tested by a couple of users and myself in https://communities.intel.com/thread/111630: https://communities.intel.com/thread/111630:

 

 

Make sure you are using Ubuntu 14.04 (I tested this steps on kernel version 4.4.0-38-generic) and have the following versions of Git, tar, and Python:

 

 

Git 1.7.8 or greater

 

tar 1.24 or greater

 

Python 2.7.3 or greater excluding Python 3.x, which is not supported.

 

 

Install all the dependencies with the command:

 

 

sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib \

 

build-essential chrpath socat libsdl1.2-dev xterm

 

 

Download and unzip iot-devkit-yp-poky-edison-20160606.zip ( http://iotdk.intel.com/src/3.5/edison/iot-devkit-yp-poky-edison-20160606.zip).

 

 

Go to iot-devkit-yp-poky-edison-20160606/poky/meta-intel-edison/meta-intel-edison-distro/recipes-core/images/edison-image.bb and comment or delete the following lines:

 

 

IMAGE_INSTALL += "iotkit-comm-js"

 

IMAGE_INSTALL += "iotkit-comm-c-dev"

 

 

Go to http://git.yoctoproject.org/cgit/cgit.cgi/meta-java/commit/recipes-core/icedtea/openjdk-7-03b147/sig...

 

 

Download the patch and unzip it.

 

 

Go to iot-devkit-yp-poky-edison-20160606/poky/meta-java/recipes-core/ant and delete the file called ant-native_1.8.1.bb, replace it with the file with the same name found in /meta-java-master/recipes-core/ant/.

 

 

Go to iot-devkit-yp-poky-edison-20160606/poky/meta-java/recipes-core/icedtea/ and delete the file called icedtea7-native_2.1.3.bb, replace it with the file with the same name found in /meta-java-master/recipes-core/icedtea/.

 

 

Go to iot-devkit-yp-poky-edison-20160606/poky/meta-java/recipes-core/icedtea/openjdk-7-03b147/ and delete the file fix-checksums.patch, replace it with the file with the same name found in /meta-java-master/recipes-core/icedtea/openjdk-7-03b147/.

 

 

Go to iot-devkit-yp-poky-edison-20160606/poky/meta-intel-iot-devkit/recipes-connectivity/bacnet-stack and open the file called bacnet-stack_0.8.2.bb. Look for the line:

 

 

SRC_URI = " http://sourceforge.net/projects/bacnet/files/bacnet-stack/bacnet-stack-${PV}/bacnet-stack-${PV}.tgz \

 

 

And change it for:

 

 

SRC_URI = " https://svwh.dl.sourceforge.net/project/bacnet/bacnet-stack/bacnet-stack-0.8.2/bacnet-stack-0.8.2.tg... \

 

 

Then follow the usual steps:

 

 

cd iot-devkit-yp-poky-edison-20160606/poky/

 

source oe-init-build-env ../build_edison/

 

bitbake edison-image u-boot

 

../poky/meta-intel-edison/utils/flash/postBuild.sh .

 

zip -r toFlash.zip toFlash

 

 

If you have issues building the image, you can also check https://communities.intel.com/thread/111630 https://communities.intel.com/thread/111630, on the latter pages, a user provided new ways to build the image with newer kernels and some other add-ons.

 

 

I hope this information helps you,

 

Pedro M.
aselv1
Novice
44 Views

Good day

I have finsihed the process that you have explained me but i have faced some error while

source oe-init-build-env ../build_edison/

its showing permission denied

please re type what i have to type in clearly

i have to type both source or-init-build-env../build_edison/

i cant build the image why its show trouble is their any steps for involving in building the parttions.

if i want to remove this please provide me the detailed informations

thanks in advance

idata
Community Manager
44 Views

Could you please share the error message with us? It is very strange that you got a permission denied message, I have never seen this personally. Are you the administrator or the PC that you're using? Or, is this PC perhaps owned by your school and limit your account in some way?

 

 

Anyway, please do share the error message, it will be of much help.

 

Pedro M.
idata
Community Manager
44 Views

Hello Ayyappan91,

 

 

Do you have any updates about this?

 

 

Pedro M.
aselv1
Novice
44 Views

Good day I have tried I can't done to increase the root size

If possible can you increase the root memory for 2.5 gb and give me the image

Kindly do me a favour I can't create or build my image

Please help me with this

idata
Community Manager
44 Views

Hi Ayyappan91,

 

 

I'm confused, you mentioned that you want to change the partition of the Edison but on the steps you shared, it seemed as if you were trying to build Edison's image, that's why I shared with you the steps I used to build the image.

 

 

Unfortunately, I'm not able to build the image for you. If you are interested in changing the partition sizes of the image you indeed need to build the image but you have to take into consideration this document:

 

 

https://www.intel.com/content/www/us/en/support/boards-and-kits/000005955.html

 

 

Nevertheless, please try building the image with the steps I shared plus the information in that document. Make sure you are using Ubuntu 14, the instructions do not work on Ubuntu 16. If you have any issues, please post the error message here and we'll try to help you.

 

 

Pedro M.
Reply