Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,066 Views

problem building on the D2000

good day

im folling the steps in showed in the "Intel® Quark™ Microcontroller Getting Started on Windows*: Video" but when i build the project hello world i get the following:

14:38:12 **** Build of configuration build_debug for project test ****

 

make

 

APP_NAME = test

 

SOC = quark_d2000

 

APP_DIR = .

 

BUILD = debug

 

make -C ./bsp/drivers SOC=quark_d2000

 

BUILD = debug

 

make[1]: Entering directory `C:/IntelSWTools/ISSM_2016.0.027/workspace/test/bsp/drivers'

 

0 [main] sh 4748 sync_with_child: child 2088(0x17C) died before initialization with status code 0xC0000142

 

21 [main] sh 4748 sync_with_child: *** child state waiting for longjmp

 

/usr/bin/sh: fork: Resource temporarily unavailable

 

make[1]: *** [../drivers/debug/quark_d2000/obj/qm_adc.o] Error 128

 

make[1]: Leaving directory `C:/IntelSWTools/ISSM_2016.0.027/workspace/test/bsp/drivers'

 

make: *** [libqmsi] Error 2

14:38:14 Build Finished (took 1s.907ms)

i tried with others templates and get the same. Im working on windows 8.

how can i fix it

0 Kudos
5 Replies
Highlighted
Employee
21 Views

Hello mauro30,

I did not have this issue when I originally installed ISSM. Are you using Windows 8 or 8.1? Please remember that only Windows 8.1 is supported.

As I mentioned I did not have issues the first time I installed ISSM on my PC (Windows 7) but I have gotten access to a Windows 8.1 PC. Let me download and install the software and update you.

-Peter.

0 Kudos
Highlighted
Community Manager
21 Views

hi Intel_peter

im using windows 8.1, is some out there using the 8? i wait for your update

thanks

Mauro30

0 Kudos
Highlighted
Employee
21 Views

Did you make sure to flash the D2000's ROM after installing ISSM? If so, did you have any issue? Or did everything worked as expected? In case you haven't flashed the board's ROM I'd suggest you to do it. You can flash the MCU's ROM in Intel ISSM > Update Target ROM...

Also, make sure the drivers of the board are installed. If you are having issues when trying to debug the board. Should re-install the driver's by running install.bat found in C:\IntelSWTools\ISSM_2016.0.027\debugger\driver.

Those were the steps I did to run the "hello, world" example and I did not have any issues on Windows 8.1.

Let me know if this information is of help for you.

-Peter.

0 Kudos
Highlighted
Community Manager
21 Views

hi intel_peter

i flashed the D2000's ROM without problem, the problem is building the projetc.

i looked in the foum and found a thread with the exact same problem even the problem iniciating the ISSM, but i get a via message with JON J K (Intel) that give me a new bat to start the ISSM ( https://software.intel.com/en-us/file/testtxt-14/download?token=Z6k1733e https://software.intel.com/en-us/file/testtxt-14/download?token=Z6k1733e ) so i dont know if is something with the SO or the ISSM

thanks

Mauro30

0 Kudos
Highlighted
Employee
21 Views

Did you make sure to install the latest version of the JRE? In case you didn't you can find it in https://java.com/en/download/ Download Free Java Software

If the issue persists after installing Java, I'd like to ask you if you have access to another PC to see if this behavior can be replicated.

-Peter.

0 Kudos