Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BGay
Beginner
1,168 Views

pygattlib and boost

Jump to solution

Hey everyone,

I'm trying to get pygattlib working so I can have an easy python interface for prototyping gatt servers on my Edison. I know there are a few different boost dependencies https://bitbucket.org/OscarAcena/pygattlib/src/a858e8626a93cb9b4ad56f3fb980a6517a0702c6/DEPENDS?at=d... https://bitbucket.org/OscarAcena/pygattlib/src/a858e8626a93cb9b4ad56f3fb980a6517a0702c6/DEPENDS?at=d..., and I cant quite figure out how to get them all resolved. I've got all the boost and boost-dev packages installed via opkg, but when i try to (pip install gattlib), it's telling me that the ld program can't find "lboost-python". Now, I've gone thru the packages on opkg the ones i have installed, and i can find any reference to the boost-python libs. Is this something I am going to need to build myself, or can we get it added to the package repo? It's weird, because i've googled edison gattlib and no one seems to have had problems like mine installing it, but then the libs i need are not in the repo so i don't know how other people got it installed. I also had to add the gcc quadmath header to the linker myself which seemed like an odd thing. I would also welcome a manual build process outside of pip if that's an option somehow. Sorry, my linux knowledge is small but growing.

0 Kudos
1 Solution
idata
Community Manager
141 Views

Hi,

 

 

In order to install pygattlib you need to install boost and gatttool. I found some threads related to this topic:

 

https://communities.intel.com/message/381268# 381268 https://communities.intel.com/message/381268# 381268

 

https://communities.intel.com/message/380798# 380798 https://communities.intel.com/message/380798# 380798

 

 

It seems that there are some problems if you install boost with opkg, and the solution for this (if boost has been installed with opkg) is to flash the board and then install boost from source.

 

The latest image (uname -a Linux edison 3.10.17-poky-edison+ # 2 SMP PREEMPT Mon Mar 14 15:26:16 PDT 2016 i686 GNU/Linux) already has pip so you don't need to install it. Please install boost with:

 

wget http://sourceforge.net/projects/boost/files/boost/1.58.0/boost_1_58_0.tar.gz tar -zxf boost_1_58_0.tar.gz cd boost_1_58_0/ ./bootstrap.sh ./b2 install

 

[from: https://communities.intel.com/message/381268# 381268 https://communities.intel.com/message/381268# 381268]

 

Then, install Gatttool by following the instructions from that, run the pip install gattlib and let me know your results, I am already running these steps too.

 

 

Regards,

 

Charlie

View solution in original post

3 Replies
idata
Community Manager
142 Views

Hi,

 

 

In order to install pygattlib you need to install boost and gatttool. I found some threads related to this topic:

 

https://communities.intel.com/message/381268# 381268 https://communities.intel.com/message/381268# 381268

 

https://communities.intel.com/message/380798# 380798 https://communities.intel.com/message/380798# 380798

 

 

It seems that there are some problems if you install boost with opkg, and the solution for this (if boost has been installed with opkg) is to flash the board and then install boost from source.

 

The latest image (uname -a Linux edison 3.10.17-poky-edison+ # 2 SMP PREEMPT Mon Mar 14 15:26:16 PDT 2016 i686 GNU/Linux) already has pip so you don't need to install it. Please install boost with:

 

wget http://sourceforge.net/projects/boost/files/boost/1.58.0/boost_1_58_0.tar.gz tar -zxf boost_1_58_0.tar.gz cd boost_1_58_0/ ./bootstrap.sh ./b2 install

 

[from: https://communities.intel.com/message/381268# 381268 https://communities.intel.com/message/381268# 381268]

 

Then, install Gatttool by following the instructions from that, run the pip install gattlib and let me know your results, I am already running these steps too.

 

 

Regards,

 

Charlie

View solution in original post

idata
Community Manager
141 Views

Hi,

 

 

While installing Gatttool, the correct command is: ./configure --disable-systemd --disable-udev

 

I ran the instructions above and it worked for me, let me know your outcome

 

 

Regards,

 

Charlie

 

BGay
Beginner
141 Views

Gattlib is installed! This is the post I was looking for, thanks!

Reply