Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sk23
New Contributor II
2,461 Views

unable to in install "npm install jsupm_lm35"

Hi ,

I was unable to install jsupm_lm35

Logs:

npm WARN optional Skipping failed optional dependency /noble/xpc-connection:

npm WARN notsup Not compatible with your operating system or architecture: xpc-connection@0.1.4

npm WARN enoent ENOENT, open '/home/root/package.json'

npm WARN root No description

npm WARN root No repository field.

npm WARN root No README data

npm WARN root No license field.

npm ERR! Linux 3.10.17-poky-edison+

npm ERR! argv "node" "/usr/bin/npm" "install" "jsupm_lm35"

npm ERR! node v0.10.35

npm ERR! npm v3.8.9

npm ERR! code ELIFECYCLE

npm ERR! mraa@1.0.0 install: `node-gyp rebuild`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the mraa@1.0.0 install script 'node-gyp rebuild'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the mraa package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! node-gyp rebuild

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs mraa

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls mraa

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

17 Replies
Sergio_A_Intel
Employee
181 Views

Hi,

Can you provide more details, like how are you installing jsupm_lm35, what commands have you used so far, what guides have you followed, what image you are using?

Are you using the command npm install jsupm_lm35?

Sergio

sk23
New Contributor II
181 Views

Hi ,

I am using command /message/396466# 396466 npm install jsupm_lm35

 

Please check the screen shoot for your reference.

Intel version is 146.(yocto linux version)

idata
Community Manager
181 Views

I ran the command npm install jsupm_lm35 successfully on the latest image. I'd suggest you to flash your Edison with the latest image. It can be found here https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads .

 

 

Sergio

 

sk23
New Contributor II
181 Views

Hi Sergio ,

I have an issue with latest build.

Please let me know this issue is fixed on latest release.

idata
Community Manager
181 Views

The latest built is not the one described in the link you posted, the latest built is release 3.0 and can be found in the link posted above. The issue is not yet fixed, however there's a workaround posted here /thread/77945 https://communities.intel.com/thread/77945 .

 

 

Let us know if you're able to run the command npm install jsupm_lm35 succesfully.

 

 

Sergio

 

sk23
New Contributor II
181 Views

Hi Sergio ,

Is there any solution on firmware 146 without updating latest firmware.

I have configured many things on firmware 146.

idata
Community Manager
181 Views

If you look at the error messages you received, it says to make sure to have the latest version of node.js and npm installed.

 

 

You can check the current version with node –version and npm –version. Update to the latest npm and node.js and try to install jsupm_lm35 again. You can get the latest node.js from http://alextgalileo.altervista.org/edison-package-repo-configuration-instructions.html http://alextgalileo.altervista.org/edison-package-repo-configuration-instructions.html

 

 

Sergio

 

sk23
New Contributor II
181 Views

,node –version

Hi ,

Please check the node and npm version. Is this Compatible or Not ?

idata
Community Manager
181 Views

If you're not able to run the command npm install jsupm_lm35 then those versions are not compatible. I'm using node 0.10.38, npm 3.9.3, mraa 0.9.5. If you need to update npm you can use npm install –g npm.

 

 

-Sergio

 

sk23
New Contributor II
181 Views

Hi ,

I was unable succeed.

Software version 146(yocto)

Node v0.10.35 (node --version)

npm 3.9.3 (npm --version )

mraa v1.0.0-4-gdb54645 (edison mraa-version)

I was unable to upload the file. Please share your email .i will share the debug log on google drive.

Log (Error)

npm WARN optional Skipping failed optional dependency /noble/xpc-connection:

npm WARN notsup Not compatible with your operating system or architecture: xpc-connection@0.1.4

npm WARN enoent ENOENT, open '/home/root/package.json'

npm WARN root No description

npm WARN root No repository field.

npm WARN root No README data

npm WARN root No license field.

npm ERR! Linux 3.10.17-poky-edison+

npm ERR! argv "node" "/usr/bin/npm" "install" "jsupm_lm35"

npm ERR! node v0.10.35

npm ERR! npm v3.9.3

npm ERR! code ELIFECYCLE

npm ERR! mraa@1.0.0 install: `node-gyp rebuild`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the mraa@1.0.0 install script 'node-gyp rebuild'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the mraa package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! node-gyp rebuild

Please do need full.

idata
Community Manager
181 Views

Please update node with opkg update node as suggested in the error message. Node –version should be v0.10.38.

 

 

-Sergio

 

sk23
New Contributor II
181 Views

Hi ,

I tried below sequence. still some issue and please do need full. 

npm install –g npm.

opkg update node

 

npm install jsupm_lm35

 

Log

npm WARN optional Skipping failed optional dependency /noble/xpc-connection: 

npm WARN notsup Not compatible with your operating system or architecture: xpc-connection@0.1.4

 

npm WARN enoent ENOENT, open '/home/root/package.json'

 

npm WARN root No description

 

npm WARN root No repository field.

 

npm WARN root No README data

 

npm WARN root No license field.

 

npm ERR! Linux 3.10.17-poky-edison+

 

npm ERR! argv "node" "/usr/bin/npm" "install" "jsupm_lm35"

 

npm ERR! node v0.10.35

 

npm ERR! npm v3.9.3

 

npm ERR! code ELIFECYCLE

 

 

npm ERR! mraa@1.0.0 install: `node-gyp rebuild`

 

npm ERR! Exit status 1

 

npm ERR!

 

npm ERR! Failed at the mraa@1.0.0 install script 'node-gyp rebuild'.

 

npm ERR! Make sure you have the latest version of node.js and npm installed.

 

npm ERR! If you do, this is most likely a problem with the mraa package,

 

npm ERR! not with npm itself.

 

npm ERR! Tell the author that this fails on your system:

 

npm ERR! node-gyp rebuild

 

npm ERR! You can get information on how to open an issue for this project with:

 

npm ERR! npm bugs mraa

 

npm ERR! Or if that isn't available, you can get their info via:

 

npm ERR! npm owner ls mraa

 

npm ERR! There is likely additional logging output above.

 

 

npm ERR! Please include the following file with any support request:

 

npm ERR! /home/root/npm-debug.log 
idata
Community Manager
181 Views

I just flashed image 146 and was able to run npm install jsupm_lm35 without errors using these versions:

I then upgraded npm and got similar results

In this case, we're using the same versions but was unable to reproduce your issue since I'm not seeing the error message you're receiving. This command works using a fresh install of both release 3.0 and firmware 146.

 

Try to flash your image to either of these versions and let us know your results. You can back up all your work before doing so. For steps on how to backup follow http://www.instructables.com/id/BackupRestore-Intel-Edison/?ALLSTEPS http://www.instructables.com/id/BackupRestore-Intel-Edison/?ALLSTEPS

-Sergio

idata
Community Manager
181 Views

Were you able to install jsupm_lm35 successfully, do you still need help with this thread?

 

 

-Sergio

 

sk23
New Contributor II
181 Views

Hi Sergio ,

I update latest image still i was unable to install

Linux version 3.10.17-poky-edison+ (neck@iotdk-ninja) (gcc version 4.9.1 (GCC) ) # 2 SMP PREEMPT Mon Mar 14 15:26:16 PDT 2016

npm install jsupm_lm35

npm WARN package.json mraa@1.0.0 No repository field.

npm WARN engine jsupm_lm35@0.7.0: wanted: {"node":">= 4.4.x"} (current: {"node":"0.12.2","npm":"2.7.4"})

jsupm_lm35@0.7.0 node_modules/jsupm_lm35

root@edison:~# .

I tried below steps to update node,Still unable to update.

opkg update

opkg upgrade nodejs

sk23
New Contributor II
181 Views

Hi Sergio ,

please provide solution for above post.

idata
Community Manager
181 Views

The latest image gives a different output for cat /proc/version. The output of the latest image is

 

 

root@EdisonEMC:~# cat /proc/version

 

Linux version 3.10.98-poky-edison+ (neck@flax) (gcc version 4.9.1 (GCC) ) # 1 SMP PREEMPT Mon Jun 6 14:32:08 PDT 2016

 

root@EdisonEMC:~# cat /etc/version

 

201606061707

 

root@EdisonEMC:~#

 

 

Your output is from the previous image Release 3.0. Flash the latest image, make sure you're on the latest with cat /etc/version and try again to run npm install jsupm_lm35.

 

 

-Sergio

 

Reply