Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AAmar2
New Contributor I
2,186 Views

wget: bad address 'iotdk.intel.com'. Unable to connect to internet after setting a static IP to galileo.

After having run the sketch to set the static ip of intel galileo gen2,I am unable to connect it to the internet. It is constantly showing the error-

 

wget: bad address 'iotdk.intel.com'

Here is the screenshot of the error that I am getting after running "opkg update"--

And here is the screenshot of /etc/resolve.conf file after i set the ip to 8.8.8.8. Yet i couldnt connect to internet.

FGTudayatejwani

0 Kudos
8 Replies
idata
Community Manager
120 Views

Hi mishra007,

 

 

Thank you for reaching out, while FGT gets in contact with you I would like to give you a hand.

 

Could you please provide the sketch you're using? Is it one from the Arduino examples?

 

Are you using a WiFi antenna to have access to the network or are you using an Ethernet cable? Any other information that you think can help us (like the image you're using, etc.) will be more than appreciated.

 

Also, for future use, I found this really good guide on how to set a static IP on the Galileo http://www.gregorykelleher.com/blog/galileo_ethernet http://www.gregorykelleher.com/blog/galileo_ethernet.

 

 

Regards,

 

-Pablo
AAmar2
New Contributor I
120 Views

Intel Corporation wrote:

Hi mishra007,

 

 

Thank you for reaching out, while FGT gets in contact with you I would like to give you a hand.

 

Could you please provide the sketch you're using? Is it one from the Arduino examples?

 

Are you using a WiFi antenna to have access to the network or are you using an Ethernet cable? Any other information that you think can help us (like the image you're using, etc.) will be more than appreciated.

 

Also, for future use, I found this really good guide on how to set a static IP on the Galileo http://www.gregorykelleher.com/blog/galileo_ethernet http://www.gregorykelleher.com/blog/galileo_ethernet.

 

 

Regards,

 

-Pablo

Hi I found a solution on my own with some luck got it working-

It had gateway issue,I mean my default gateway(IP of my router is 192.168.0.1) so I run this following code to get internet access in my intel galileo-

route add default gw 192.168.0.1 eth0.

But instead of running it everytime,I wrote this code in bashrc file and just source it everytime I boot my galileo. This works for now! If there is some other solution then kindly do let me know!

FTinetti
Honored Contributor I
120 Views

mishra007 wrote:

Intel Corporation wrote:

Hi mishra007,

 

 

Thank you for reaching out, while FGT gets in contact with you I would like to give you a hand.

 

Could you please provide the sketch you're using? Is it one from the Arduino examples?

 

Are you using a WiFi antenna to have access to the network or are you using an Ethernet cable? Any other information that you think can help us (like the image you're using, etc.) will be more than appreciated.

 

Also, for future use, I found this really good guide on how to set a static IP on the Galileo http://www.gregorykelleher.com/blog/galileo_ethernet http://www.gregorykelleher.com/blog/galileo_ethernet.

 

 

Regards,

 

-Pablo

Hi I found a solution on my own with some luck got it working-

It had gateway issue,I mean my default gateway(IP of my router is 192.168.0.1) so I run this following code to get internet access in my intel galileo-

route add default gw 192.168.0.1 eth0.

Great, that's why I asked you to send the output of the route command... in the now visible-"approved" (?)-delayed by the moderator post... great you were able to get it to work.

But instead of running it everytime,I wrote this code in bashrc file and just source it everytime I boot my galileo. This works for now! If there is some other solution then kindly do let me know!

Yes, add that line to the sketch that sets the IP address (after setting the IP address).

Fernando.

FTinetti
Honored Contributor I
120 Views

mishra007 wrote:

After having run the sketch to set the static ip of intel galileo gen2,I am unable to connect it to the internet. It is constantly showing the error-

 

wget: bad address 'iotdk.intel.com'

...

FGT udayatejwani

Unfortunately I'm not able to experiment with my Intel Galileo right now, however, there are somethings you can try. Let's focus our work on connecting to the internet.

Please send the output of the commands:

1) In the Windows computer (check you include all the output in your reply):

ipconfig

2) In the Intel Galileo (2 commands, check you include all the outputs in your reply)

ifconfig

route

Take into account you should start your Intel Galileo connected to the router with Internet access, do not start your Intel Galileo withuot your cable connected to the router.

Fernando.

FTinetti
Honored Contributor I
120 Views

Are you able to see my previous post? I look the warning

"Currently being moderated" so I don't know if you are able to see it...

Fernando.

AAmar2
New Contributor I
120 Views

FGT wrote:

Are you able to see my previous post? I look the warning

"Currently being moderated" so I don't know if you are able to see it...

Fernando.

I couldnt see it earlier,but i can view it now. I saw that same "moderated" warning. I dont know why.

AlHill
Super User
120 Views

There is nothing to be concerned about. Read this thread:

If you have a thread or post in the moderation queue, it will be reviewed by a moderator and either approved or rejected. Most often, approved. However, the forum software has to evaluate each post for potential issues. Bad links and spam have been greatly reduced by examining posts for such issues. The result is clean and safe content for legitimate members of the Intel community.

We appreciate your patience regarding these "moderation" issues. Also, if you see a thread or post with inappropriate content, please report the thread or post so a moderator can examine it.

Doc

FTinetti
Honored Contributor I
120 Views

I've replied, but my posts get moderated again and again. Send a PM in case you want some help from me (anyway, Intel people know much better).

Fernando.

Reply