Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DM7
Beginner
1,038 Views

/workspace/Hello_World/Debug: No such file or directory

I just installed Intel System Studio IoT (version 4.5.0.201612091715) on Windows 10 but I am unable to compile simple hello world application. The following error happens:

23:41:19 **** Incremental Build of configuration Debug for project Hello_World ****

 

Info: Internal Builder is used for build

 

docker exec -i 0557c0e81f2f591dd3f7815ba65c861501e487bb42e95b2aba2dc06c53bb1176 /bin/bash -c "cd /workspace/Hello_World/Debug && i586-poky-linux-g++ -I/usr/include/upm -I/usr/include/mraa -O0 -g3 -Wall -c -fmessage-length=0 --sysroot= -m32 -march=i586 -c -ffunction-sections -fdata-sections -o src/main.o ../src/main.cpp"

 

time="2017-02-09T23:41:21+03:00" level=warning msg="Unable to use system certificate pool: crypto/x509: system root pool is not available on Windows"

 

/bin/bash: line 0: cd: /workspace/Hello_World/Debug: No such file or directory

23:41:22 Build Finished (took 2s.397ms)

My Eclipse workspace is located in d:\workspace_iot directory. I expect it should be mapped into /workspace directory in the container but that is empty:

$ ls /d/workspace_iot/

Hello_World/ On_Board_LED_Blink/ RemoteSystemsTempFiles/

$ docker ps

time="2017-02-09T23:48:04+03:00" level=warning msg="Unable to use system certificate pool: crypto/x509: system root pool is not available on Windows"

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES

0557c0e81f2f inteliotdevkit/intel-iot-yocto:latest "/bin/bash" 20 hours ago Up 18 minutes 0.0.0.0:32768->22/tcp intel-iot-yocto-workspace-iot-787811000

$ docker exec 0557 ls -la /workspace

time="2017-02-09T23:48:33+03:00" level=warning msg="Unable to use system certificate pool: crypto/x509: system root pool is not available on Windows"

total 4

drwxr-xr-x 2 root root 40 Feb 9 20:29 .

drwxr-xr-x 71 root root 4096 Feb 8 23:53 ..

0 Kudos
3 Replies
idata
Community Manager
59 Views

Hi Dmikh,

 

 

Thanks for your interest in the Intel® Edison Platform.

 

 

I appreciate all the information provided, I have found another thread with an issue similar to this one, and the user dcbrian has solved it, there is mentioned that Docker has a list of directories (Docker Prefs | File Sharing) on the host machine to which it permits itself to write, and an alternative workspace path cannot fall into that list, so it would be necessary to add your workspace path to that list. Please take a look at the thread: /message/429360# 429360 Failure to Generate ISS IoT Example Project for more details.

 

 

Hope this information helps.

 

 

Regards,

 

-Yermi A.

 

DM7
Beginner
59 Views

Where can I find "Docker Prefs | File Sharing" ? Docker Quickstart terminal is a CLI tool and do not have menu.

I tried to reinstall studio selecting default workspace directory in user home but another error happens:

DM7
Beginner
59 Views

I found a way how to share workspace on non-default location. In my case I used d:\workspace_iot

1. Stop default docker machine

docker-machine stop default

2. Run VirtualBox, open 'default' VM settings and add D:\ path to Shared Folders list:

3. Start default docker machine

docker-machine start default

4. Run studio and select d:\workspace_iot as workspace path.

It seems that Intel System Studio IoT has limitation on home directory path. It cannot include:

- spaces

- dots

- non latin, localized characters

It should be noted in installation instructions as well as description how to use workspace in different location. It would save a week of time for me and probably other new users just to run hello-world on recently bought Edison board.