Intel® NUC Elements
Support for Intel® NUC Compute Element, Board Element and Chassis Element
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

60 Discussions

Thunderbolt 3 port doesn't work

ken6
Beginner
322 Views

Hi,
I bought the NUC last month. But now my NUC has a problem with Thunderbolt 3.
I remember that it worked fine at first, but someday it became unusable. BIOS update or Windows update?
---
NUC platform: Intel NUC 9 Pro NUC9VXQNX
Storage: Samsung 970 EVO Plus 1TB NVMe
Memory: Crucial DDR4-2400 16GBx2
BIOS: 0059 Latest
OS: Windows10 Pro 20H2
Thunderbolt3 Driver: DCH 1.41.1054.0 Latest
All other drivers are up to date.
---
I tried the following:
- Disable or Enable Thunderbolt 3 devices in the BIOS.
- Older versions of device drivers and legacy drivers that are not DCH.
- Switched Thunderbolt security to Legacy or Unique ID.
If the Thunderbolt device disappears from Device Manager, remove the battery and perform a CMOS reset, it will appear in Device Manager, but it will not work even if the device is connected.

There is also a problem with USB3.1 Gen2 or DP instead of Thunderbolt3.
- Even if I connect a Sandisk Extreme SSD, the connection speed is USB 2.0.
- Even if I connect to the monitor with DP, there is no image on the monitor.

I am in great trouble. Help me.

0 Kudos
4 Replies
n_scott_pearson
Super User Retired Employee
303 Views

I'd like to see what else happens from the USB side. Do you have a USB 3 flash disk? If so, does it connect at USB 3.0 speeds?

I just checked my QNX. I too could not see a USB 3.0 flash disk. In fact, I checked the front panel USB 3.0 ports as well and they too will not work. This has to be a driver issue; I used these ports just the other day.

...S

ken6
Beginner
298 Views

Hi Scott, 

Thank you for your quick reply. And, thank you for taking the time to consult me.

Yes, I have a USB3.0 flash disk dongle. But this is a USB Type A connector.
I connected to the front and rear Type-A connectors and confirmed the connection at USB 3.0 speed.
And, I connected to the Type-C port (Thunderbolt3) via a USB hub that connects Type-C to Quad Type-A, but I can only connect at USB 2.0 speeds. This USB hub is working fine with other devices.
Also, I converted Type-C of the above SanDisk Extreame SSD to Type-A, connected it to the Type-A port, and confirmed the connection at USB 3.0 speed as well.

The problem is only with the Type-C port.

n_scott_pearson
Super User Retired Employee
296 Views

Hhmmm, well, I seem to have the sicker puppy. I am not connecting at USB 2.0 speeds either.

...S

ken6
Beginner
280 Views

@n_scott_pearson 
Oh...
Your cute puppy may be more serious than my Mameshiba.
Can Thunderbolt be connected even if the USB device cannot be connected?

so contacted Intel Support in Japan about the situation.
I will write it here when the situation changes.

Reply