Intel® NUC Elements
Support for Intel® NUC Compute Element, Board Element and Chassis Element
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

59 Discussions

Thunderbolt port may be fried

ScottyO
Beginner
231 Views

Looks like my Thunderbolt port might not be working. When I plug my eGPU into the Thunderbolt port, the graphics card does not light up, and my computer does not notice a new device has connected.

This is after roughly a month of my setup working just fine, after considerable effort in setting it up. My specific combo of gear has been flagged by Intel as having problems, it turns out. I have a NUC10i7FNH1, a Razor Core X, and a Radeon 5700XT. You will find a lot of people complaining about the NUC not working with the Core X and the 5700XT, and there are all sorts of claims of how to fix these problems. So I spent about a day troubleshooting various problems I might have to no avail. (Btw, for those who stumbled upon my post looking for an answer to the Error 12 problem, google "Razer GPU Switcher" and download the 2016-2017 version for the Core v2 that is available on Razer's support site, this is how I solved the problem a month ago).

I finally just plugged my eGPU into the USB-C port and the graphics card lit up, and I got a notification on the computer that a thunderbolt device tried to connect. Of course, that port can't support the GPU sadly.

I decided to plug my phone into the Thunderbolt port, and noticed that it would not hold a charge. It would keep attempting to charge, but fail. The computer also did not recognize my phone. The USB-C port on the other hand, works as intended.

I did notice that the Thunderbolt bus does not show up in device manager now either.

What should I do? Halp :<

0 Kudos
3 Replies
Sebastian_M_Intel
Moderator
213 Views

Hello ScottyO, 

 

Thank you for posting on the Intel® communities.   

 

Please provide the following: 

 

1. Run the Intel® System Support Utility (Intel® SSU) and attach the report generated:   

  • Open the application, check the "Everything" box, and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".    
  • Click on the menu where it says "Summary" to change to "Detailed View".    
  • To save your scan, click on "Next", then "Save".    
  • Use the option under the reply window to attach the report to the thread (Drag and drop here or browse files to attach).   

 

2. Install the latest Thunderbolt™ Bus driver for your NUC and let us know about the outcome https://downloadcenter.intel.com/download/28735/Thunderbolt-3-DCH-Driver-for-Windows-10-for-Intel-NU...  

3. Update to the latest BIOS version on the Intel® NUC. 

Steps: https://www.intel.com/content/www/us/en/support/articles/000033291/intel-nuc.html  

Download: https://downloadcenter.intel.com/download/30073/BIOS-Update-FNCML357-  

 

4. Check the Thunderbolt option in BIOS: 

  1. Press F2 during boot to enter BIOS Setup. 
  2. Go to Advanced > Devices > Onboard Devices
  3. Check that the Thunderbolt Controller is enabled. 
  4. Press F10 to save and exit BIOS Setup. 

 

5. Change the Windows power management setting for the Thunderbolt controller: 

  1. Press the Windows key and X
  2. Select Device Manager
  3. Expand the System devices section. 
  4. Right-click the Thunderbolt(TM) Controller and select Properties
  5. On the Power Management tab, uncheck the box for Allow the computer to turn off this device to save power. 
  6. Click OK
  7. Close Device Manager. 

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician


ScottyO
Beginner
209 Views
I just did the good ol' screwdriver in the AC socket trick and it works now

I had heard about it in various forums, and finally stumbled upon this article:

https://gtrusted.com/how-we-reset-the-thunderbolt-3-port-on-the-intel-skull-canyon-nuc6i7kyk-nuc-kit

I removed the RAM and SSDs, then stuck a smol flathead screwdriver in the AC socket (this is supposed to short something out to reset the port). Very anti-climactic, of course, no fireworks. Kinda just feel like an idiot aimlessly probing a power socket with a screwdriver, until you turn the thing on and it works.

Afterwards, the second time I booted up my computer, the eGPU did not connect initially. I unplugged it from the thunderbolt port, plugged it into the USB-C, the GPU lit up, unplugged it, GPU lights go off, plugged it back into the Thunderbolt port like a 5 year old trying to make the thingie work, and it did. The GPU lit back up, and it has worked ever since.

After over a day of troubleshooting drivers, I fix it with a toddler technique. Epic.
Sebastian_M_Intel
Moderator
204 Views

Hello ScottyO,  

 

Thank you for your reply. 

 

I am glad to hear that your system is now working as intended, thank you for sharing the fix as well. 

 

Based on that, we will proceed to close this inquiry. If you have any additional questions, please post a new thread and we will gladly assist you. 

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician


Reply