Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
893 Views

7i7BN(H) DCH graphic drivers video dropout.

Way way way back years ago many of us had problems with the video graphic drivers for the NUC 7i7X series with video dropout. It was fixed with a registry edit for DisableEDramForDisplay=1 that was added into every release driver going forward with great success. I'm still running the same old 7i7BNH and have tried all of the new DCH intel released graphic drivers and have been sent back to the beginning with constant video dropouts. This NUC is unusable with any of the DCH driver releases.

 

25.20.100.6373 of the classic is the last one that works for me. Any of the intel experts still around who can provide some feedback? It's been a long time, hope someone can help

Thanks!

TX

0 Kudos
4 Replies
Highlighted
New Contributor III
20 Views

Now that you mention it, you are absolutely correct

I'm on a 7i5BNH and have always upgraded to the latest Graphics driver and also posted that I've had no problems with DCH driver. I actually thought that the flicker had to do with my internet connection. Downloaded and installed 25.20.100.6373 and after

streaming for I dont know exactly how long I can say the any flicker I've had is no more there. So I guess it's 6373 until a new DCH driver comes out and then I'll test again.

0 Kudos
Highlighted
Employee
20 Views

Hello TTX, Thank you for posting on the Intel® Communities. The DCH drivers are generic and have not been validated for the Intel® NUCs (yet). If you are having issues with these drivers, we recommend using validated drivers here: https://downloadcenter.intel.com/product/95065/Intel-NUC-Kit-NUC7i7BNH Amy C Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
New Contributor III
20 Views

Amy they must have been validates for every manufacturer out there since there are no cautions on the download page. So why not on the NUC's?

0 Kudos
Highlighted
Novice
20 Views

I should add to my original post that I'm using the USB-C to HDMI @ 4K 2160p HDR.

 

Years ago this was my original problem with the NUC that was fixed with the driver registry edit and a firmware upgrade.

 

That's worked great with every intel driver up until the start of the DCH line of drivers for me.

 

The original problem had to do with some conversion chip that intel chose, I had to go back to my old posts to find it from 2017. "LSPcon DP to HDMI" was the conversion chip that intel picked. They never quite got the HDMI working right out of these at 4K 2160p, but the USB-C to HDMI was the work around, along with the firmware update and registry to DisableEDRamForRTDisplay=1

 

 

Dpers1, you pose a good question, if the DCH is a generic, or otherwise, common driver across all platforms - then how could it not be validated for the NUC?

 

I've always been able to just grab the latest Iris plus 650 driver and be fine once intel worked that fix into the drivers a year or maybe two ago.

 

Not a huge deal I'll just stick with the latest driver that works.

 

I just wanted to bring it to attention that the DCH drivers do not work properly in the hopes someone at intel can sort it out like they did with the old driver problem years ago for these NUCs.

 

 

Cheers,

TX.

 

 

 

 

 

 

 

0 Kudos