Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11305 Discussions

A RAID SOLUTION for 4gen NUCs!

speak
Beginner
365 Views

I just wanted to add that I have discovered why the RAID config kept failing, for those who are using 4gen NUCs as servers! Basically the https://ark.intel.com/content/www/us/en/ark/products/81164/intel-nuc-kit-d54250wykh.html model at this link.

 

It seems that the Secondary slot for a SATA 2.5" SSD or HDD would "fall out" of the RAID array on reboot. And other times reappear! Very annoying! Since my 4 NUCs were in warranty at the time I opened a case with Intel. They came to the conclusion that the SATA edge connector board was defective and they sent me new version ones to swap in. This seemed to work for awhile....

 

Now, we flash forward to 2020. I am redoing one of those servers and lo and behold, RAID problems re-surfaced! I was like "WTH!" I swapped back each of the old SATA boards for sh*ts and grins, but no change! Im like, this is one bad Greek Tragedy!

 

THEN!

 

I tried swapping the power and SATA cabling from another NUC Im using as a bedroom media server, AHCI mode, non-RAID. And BOOM! RAID issues vanished! It seems that I have finally found the true cause of the intermittent RAID issue, with the 2.5" drive disappearing and reappearing again! POOR QUALITY CABLING! At least with my tests. And fortunately the 5gen and on seem to have addressed this with better quality cabling from 3rd party vendors.

 

So my advice for those who are seeing this weird malady on 4gen NUCs, try swapping the cabling between NUCs, using any cabling from NUCs you will not make a RAID. And see! It worked for me and I am basking in gloatatious sunlight lol.

 

5 years on and my NUCs are running like tops, all forms of MS technology, rock-solid.

 

 

-Speak-

 

0 Kudos
4 Replies
LeonWaksman
Super User
327 Views

Thank you for this valuable information.

 

Leon

 

Esteban_D_Intel
Moderator
327 Views

Hello RSpea2,

 

Thank you for posting on the Intel® communities.  

 

We would like to thank you for the information provided.

Hopefully, other community peers will find these steps helpful.

 

Esteban D.  

Intel Technical Support Technician 

speak
Beginner
327 Views

Hello Esteban! In this day and age of technology where Emails and Forum posts often get ignored, it is incredibly gratifying to receive a response not merely a day later! :)) My hat is off to you, sir!

 

Most likely most techies are running the newer tech so this will not be relevant to them. Im a few years too late to post it, haha. But there may still be some loyalists still running 4gen and my hope is to help others struggling with this weird obscure issue and save them some headache.

speak
Beginner
249 Views

UPDATE:  Revisiting my faulty SATA cables, after closer inspection I have narrowed down the trouble to a faulty SATA data cable.  The stock cable is actually a very poor design and not robust enough to withstand a lot of twisting and bending!  Such is the case what happened in my situation.  The shielding had pulled out of the plug at one end, unbeknownst to me.  Leaving the 4 ground wires exposed.  Having no protection, 3 out of four wires broke off flush at the foot of the connector.  Thus not enough ground points for the interface to detect a drive.  I took a chance to pull back the wrap and shielding and drop a blob of solder on the 4 wires after I brought them all together against the one intact ground wire and then re-wrapped the cabling.  Seems to have done the trick!  My 2.5" SSD is recognized again! Yayyyyyy!  (See photos)

Notes: The plug is made of plastic!  So if you attempt this repair for a similar fault, don't loiter with the soldering iron.  Just enough to get a nice shiny ball encompassing all the broken wiring and unbroken wire while not melting the connector.  The 4 signal wires are individually wrapped in a thick plastic jacket so the chance of the solder melting through and shorting those is very slim.  I tested each pin and no shorts so good to go.  Goodluck!

Reply