Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KBopp
Novice
1,040 Views

All devices work in USB 2.0 but not in USB 3.0

Jump to solution

I have the D34010WYKH1 and I am unable to get any USB 3.0 peripherals to connect. This includes USB3-to-SATA HDDs, USB3 hub, and a USB Blu-ray Burner. I am using USB 3.0 cables and attaching them to any of the 4 external USB 3.0 ports. I have the latest BIOS and drivers from Intel. The weird thing is that all of those devices work perfectly if I replace the USB 3.0 cables with USB 2.0 cables (they just work at USB 2.0 speeds). I'm not changing the ports, just the cables. In fact, I can use the USB 3.0 cable as long as I put a USB 2.0 M/F extension in-line. Help!

Tags (1)
0 Kudos

Accepted Solutions
KBopp
Novice
88 Views

Turn off Legacy USB mode in the BIOS. This allowed my devices to connect at USB3 speeds using my USB3 cables.

View solution in original post

3 Replies
DHoga2
Valued Contributor II
88 Views

I am not from Intel and don't know whether it is this situation, but I'll mention just in case. It was mentioned in another thread that the USB driver installer asked user to reboot before it had fully finished installing, so that if you rebooted too quickly the driver ended up in some sort of limbo state. If so maybe you can try removing and re-installing the driver but wait longer this time before rebooting?

Also are you using Windows 7 or something else? I use Windows 8.1 and never even noticed until your question that there was a USB 3.0 driver for download - I'm fairly certain that I've used devices at USB3 speeds without ever having installed Intel's USB3 driver.

Update: you may also want to let us known your BIOS version and what is your setting for xHCI mode in the Visual BIOS. Release notes for BIOS version 40 say they fixed a bug that was in version 38 regarding not defaulting to the Smart Auto setting for xHCI (I'm not sure what it was set to instead or whether that would matter for your particular situation).

KBopp
Novice
88 Views

Thanks for the thoughts. I had read about the delay in installing the USB3 driver. I don't believe this is the case anymore, but I waited an extra long time just in case. The pop-up window said that the USB3 Hub was ready before the Reboot option was available.

I talked to a friend at work who also indicated that this might be a BIOS issue.

I dug around and turned off Legacy USB mode. That seems to have fixed everything.

I appreciate you taking the time to help me with this problem.

KBopp
Novice
89 Views

Turn off Legacy USB mode in the BIOS. This allowed my devices to connect at USB3 speeds using my USB3 cables.

View solution in original post