Intel® NUCs
Support for Intel® NUC products
11784 Discussions

BIOS Not Properly Communicating with OS?


NUC Model: NUC8i7HVK

Issue Occurrence: Always

CPU: Intel i7-8809G


OS: Windows 10 Pro (10.0.16299.492)

BIOS: HNKBLi70.86A.0047.2018.0718.1706

Ethernet: Intel Ethernet Connection I219-LM & Intel Ethernet Connection I210-AT

Chipset: Intel 100 Series/C230 Series Chipset Family

Problems: I feel like the following issues are somehow related, but don't know enough to say for sure.

(1) There is no working Ethernet showing anywhere on my PC. (Task Manager, Device Manager, or in Control Panel's Network Devices)

(2) Physical Ethernet ports don't function despite being enabled in UEFI. Center LED on front panel also indicates ethernet is active.

(3) Task Manager displaying incorrect RAM speed (2400 vs 2800). BIOS & IXTU both correctly show 2800.

(4) Task Manager shows 2 of 4 RAM slots used, but to my understanding, there are only 2 slots total.

Things that may be noteworthy:

- I recently upgraded from a NUC6i7KYK to this NUC8i7HVK. I migrated all storage drives and RAM from one NUC to the other. Maybe that's causing a communication issue?

- After my first couple of boots, I disabled both ethernet ports in BIOS under the assumption I wouldn't be needing them. Not sure if the adapters were recognized in Windows OS before that since I hadn't checked.

- One day I Hibernated/Shut Down (can't recall which) the NUC, and went to bed. When I woke up the next morning, BitLocker had locked my PC. Had to

enter the Recovery Key because "changes may have been made to the hardware". I'd made no changes whatsoever. I entered Recovery Key, and didn't think twice about it

until the ethernet issues were later noticed.

- When I scan the NUC with Driver & Support Assistant, there is no indicator that BIOS is up to date (which it is). As I recall, the scan would display whether

or not the 6i7KYK's BIOS version was current.

Failed Attempts to Fix:

- Reset CMOS by disconnecting battery.

- Tried installing the Ethernet drivers (version 23.2). I received error message "Cannot install drivers. No Intel adapters are present in this computer."

- In Device Manager I selected the "show hidden devices" view and both adapters (I219-LM and I210-AT) became visible, but were unusable.

Tried to manual update them; received the same error.

- Uninstalled both adapters to do a fresh reinstall. Rebooted, and they've never returned since. Now, they are no longer even visible with "show hidden devices".

Tried to manually add adapters back into Device Manager, could only find the I219-LM in the list of available legacy adapters. Still unusable.

0 Kudos
11 Replies
Valued Contributor I

Hi CoBu,

The issue, it seems is that Windows is not recognizing the Ethernet.

To confirm

  • Ethernet enabled in BIOS
  • Moved the storage and RAM across from your old NUC to the new NUC
  • BIOS is up-to-date

Have you attempted to connect your HVK to your cable/modem router via Ethernet. On the back of the unit, confirm that you have a blinking green on the left and a solid yellow on the right Ethernet port when connected.

There may be other intermediate steps that other's may recommend.

It seems to me this is a Windows issue and I recommend reinstalling windows completely, after backing up your essentials.


Hi MikeLevine,

- Your summary of the situation is correct.

- Yes, my attempt to connect the HVK to my router via Ethernet is what led to the discovery that it wasn't working.

- On the back of the unit, there are no lights of any kind (green or yellow) shining from either Ethernet port.

Super User

You can't just move drives from NUV6i7KYK to NUC8i7HVK. This is complete different hardware with different drivers. That is probably the reason that Bitlocker had locked your machine. Also the Windows activation will be not valid.

1. My suggestion is to use other SSD and perform clean Windows installation. Here you will find a tutorial for this procedure: Windows 10 Help Forums . Install with UEFI boot option (i.e. skip on step 12).

2. If you don't have free SSD, backup the current one and use it for the new installation.

3. After finishing the installation, install all drivers, downloaded from Intel site: Downloads for Intel® NUC Kit NUC8i7HVK

4. If you're running Windows 10, version 1607 or later and you added your Microsoft account to the new device, the digital license will be linked to your device, you will be able later to transfer this license to the new NUC:




I won't completely deny that the migration could be behind the BitLocker lockup, but wouldn't that type of thing occur immediately if it were to happen? I'd been using the HVK just fine for a week when it suddenly happened overnight. And for the Windows activation, fortunately my version already allows activation on multiple PCs.

- I'll probably be following similar steps to what you've suggested if no one recommends any alternatives. Was trying to save that for last since I really didn't feel like going

through the headache of starting over with BitLocker and all.

Super User Retired Employee

Sorry to do it, but you've hit upon a pet peeve of mine. UEFI is a set of firmware components from which a BIOS can be implemented. By itself, it is not a complete BIOS nor is it an entity in and of itself. It is incorrect to say "enabled in UEFI". You enabled something in the BIOS configuration. People do this because a slimy marketer at one of the motherboard vendors tried to use this as a way to say that they were the first to deliver UEFI support because they delivered the first BIOS with a GUI interface. Both of these claims were completely false; Intel had been shipping BIOS based upon UEFI for 5 years at that point (although without a GUI) and BIOSs with GUI interfaces (a) didn't need UEFI in order to be implemented and (b) had been shipping for years. Regardless, a lot of people fell for this crap and suddenly UEFI and BIOS configuration GUIs were being considered synonymous. They aren't. Again, sorry for hopping up on a soapbox here, but this curdles my milk everytime I hear it.

Ok, to your issues. Let me paraphrase so I can make sure that I understand the issues...

  1. You migrated a Windows installation from a 6th generation Core processor to a 8th generation Core processor (and associated chipsets). [Aside: In and of itself, you should *never* do this. In the past, I have seen this cause many unexpected problems. You should always do a fresh install of the O/S on a new platform. Still, let us go on and see...]
  2. You disabled ethernet support in the BIOS configuration.
  3. At a later point, you had to do a BitLocker recovery because the hardware seemed to have changed. You discovered that the ethernet ports, while still disabled, were now visible (i.e. weren't being hidden by the BIOS as they should be) and this was considered a hardware change and thus the BitLocker recovery had to be done.
  4. In the course of trying to fix this issue (all attempts failing), you discovered that the ethernet ports were being properly hidden in subsequent boots. [Aside: I am presuming that the things you tried were actually done in a different order than you have listed them here.]

So, in conclusion, you are seeing an anomaly wherein, during a certain power-on (or set of power-ons), the BIOS did not properly hide the ethernet ports. Is this correct?

Ok, my comments/questions on your other "problems":

  • You say ethernet ports do not function despite being enabled? When did you enable them? You said they were disabled???
  • Task Manager? Um, no, it doesn't display any of this information. Where are you seeing it?
  • In my check, the BIOS has exposed SMBIOS records indicating that there are four DIMM sockets and has populated Memory Device records for all four sockets. This is obviously a BIOS bug.
  • In my check, the BIOS has exposed a current speed of 2133MHz in the SMBIOS Memory Device records that are indicated as populated. This is correct for my DIMMs. Are you sure that your DIMMs are actually being run at 2800MHz? They may be running at only 2400MHz.




Yeah I always assumed that BIOS/UEFI were different, but still similar enough to be interchangeable. I'll try to keep your comments in mind moving forward.

- Your paraphrasing of the issues is partially correct.

1. True

2. True

3. Not exactly. The day I awoke and needed a BitLocker Recovery preceded me realizing there was any issue with the Ethernet. It was days later that I enabled the ports in the BIOS and

found out they weren't functioning properly. Even though Ethernet was now enabled in BIOS, the ports don't show anywhere in Windows.

- Enabled a few days ago.

- I currently have 3 different Windows 10 PCs. HVK is the only one that doesn't display "Ethernet" in Task Manager's Performance Tab. It is on the left side between "Disk" and "Wi-Fi", below "CPU" and "Memory".

- How would I verify that the DIMMs are actually being run @ 2800? The only ways I know to check (BIOS/IXTU) other than Task Manager both show 2800. I tried systeminfo cmd, but I only see memory quantity not speed.

Super User Retired Employee

Ah, I understand now. So it's actually the complete opposite case. Ok, that's actually an easier thing to test for. I will give it a shot (disable both ethernet interfaces and then see if the devices are not exposed properly when I re-enable them).

Checking is a sticky subject, since most software dumbly regurgitates what the SMBIOS table is exposing - and we have already seen one set of bugs in what it is exposing for memory. One way to find out is to run a tool like RWEverything (it's freeware) and look at the actual data being reported out of the DIMM SPDs themselves.



Had a spare blank SSD laying around that I installed a fresh copy of Windows 10 on. Results were all of the exact same issues. I believe this newfound info removes the possibility of a Windows error. Do anyintel_admin have other suggestions for this issue?

Super User Retired Employee

I disabled the two ethernet ports in Visual BIOS and booted. The BIOS properly disabled the hardware, but the devices are indeed there when I show hidden devices. Windows properly removed the ethernet connection and connected to the network using wireless. I then shutdown and powered back on. Things stayed as they were (i.e. nothing changed as a result of complete power off). Next, I restarted, went back into Visual BIOS, reenabled the two ethernet interfaces and booted. Windows properly enumerated the devices and connected to the network using ethernet (as well as wireless; [aside] I wish I had a capability for saying do not connect via wireless if can connect via ethernet).

So, let's go through the issues...

  1. I reported this 4-DIMM issue, as well as a couple of other issues that I found while looking through the SMBIOS Structure Table. The engineering team is already looking into this.
  2. Insofar as the DIMM speed values in the SMBIOs table go, it is being displayed properly on my HV. I asked engineering to verify that this is working properly after they remove the spurious structures.
  3. I would have presumed that, if the BIOS hides a device, Windows does not see it at all - and thus it shouldn't be displayed by Device Manager (even with Show Hidden Devices enabled). I asked them to look at this as well.
  4. Regarding the ethernet hardware, I am presuming that you enabled both interfaces in the BIOS and thus whichever one you plugged the ethernet cable into should be working. If this is the case and the driver is not having problems installing, then you may have suffered a hardware failure.

Hope this helps,


Community Manager

Hello CoBu


Thank you for contacting us.


Based on the description of your post, the troubleshooting done, and the recommended steps from N.Scott.Pearson, lw1948 and MikeLevine, it all points to be a hardware issue.


If that's the case we strongly suggest you to check the warranty of you unit and start a warranty claim through the following link:


As a last recommendation we suggest you to recover the BIOS following these steps:


Here is the link for the latest BIOS for your unit:


I hope to hear from you soon, please let us know if you need further assistance.




Diego S.



BIOS version now updated to HNKBLi70.86A.0049.2018.0801.1601 with all of the same issues. Some things that may be noteworthy:

  • Could not successfully update/recover BIOS using Jumper or Power Button method after many attempts at each.
  • Could only update BIOS using Home screen of Visual BIOS. Updated fine on first try.
  • When attempting Jumper/Button methods, NUC powered on and off multiple times (2-4) before list of Function commands ever became available. (Maybe this is normal?)
  • F4/F7 only worked sporadically. When the Function keys were accepted, NUC would not go through update procedure. Would simply reboot and return to same Function screen.
  • USB's LED (physically located on my flash drive) would continually blink before and during failed Jumper/Button attempts. The LED usually behaves like this when drive is plugged into a PC in Sleep mode. LED light remained solid preceding successful update using Visual BIOS.

Not sure if any of this information is relevant, just documenting what I saw.

Beginning Warranty Claim process now.