Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12729 Discussions

BOXNUC7CJYH1 Fails to boot to any drive


I have a Nuc that I bought in 2019 but never used that I am planning to finally put to use. The Nuc did not come with a hard disk and I have tried to throw two different ssd drives into the thing, one with Ubuntu(PNY) and one with Win10(Intel). 

I have an ubuntu boot drive as well that the Nuc fails to recognize at all most of the time. 

I updated to the latest bios firmware. 

Behavior on boot is that the Nuc reaches the "Intel NUC" splash screen and never goes any further. The devices and peripherals bios screen recognizes that a SSD Drive is connected to the SATA Port, but the boot menu doesn't list anything. 

Once, I was able to get the boot drive to be recognized by the BIOS, and tried to use the boot menu to boot to it, but when I selected it I just got an endless black screen. 

I've been looking into the issue for about a week now and I cannot find anything that has produced any results. 

Labels (1)
0 Kudos
2 Replies
Super User

What type of partition has the Windows 10 drive? GPT or MBR? 




New Contributor I

To confirm the NUC works, download the Windows 11 media creation tool (, get a USB stick then create a Windows 11 boot (its all done from the above tool), connect that USB to your NUC then power on, it should boot to WIndows 11 install, if it does then its likely how the drive is set up, likely not GPT formatted disk.