Community
cancel
Showing results for 
Search instead for 
Did you mean: 
schmosef
Novice
693 Views

BOXNUC8i7BEH1 random Windows 10 hangs and fails the Intel Processor Diagnostic Tool Test

I bought a NUC8i7BEH1 a few weeks ago. It was running fine for about two weeks.

 

About a week ago, it started to randomly hang in Windows. The only way to get it working again was to hold down the power button and force a restart.

 

No errors were reported in the Windows Error logs, just that the computer was restarted unsafely.

 

I ran a full test with MemTest86. No memory errors were found.

 

When I ran the Intel Processor Diagnostic Tool test, it would sometimes get as far as the CPU Load test, then freeze Windows. Usually, it would just fail at the IMC test stage.

 

Assuming that it was a defective CPU, I exchanged it for a new unit of the same model, at the store where I bought it.

 

This, brand new, replacement NUC is also failing the Intel Processor Diagnostic Tool test at the IMC stage and Windows is randomly freezing.

 

How should I proceed with this?

 

Is it possible that both of these NUCs are from a bad batch? Should I ask to exchange it again?

 

Is it possibly that the RAM is bad, even though it passed a full MemTest86 scan?

 

Is this something that can be fixed with a BIOS update?

 

Also, I tried to file a support request with the Intel Online Service Center page. It can find my device for warranty confirmation, but when I try to complete the support request form, it says my device cannot be found.

 

I'm at a loss for how to proceed, please advise.

0 Kudos
9 Replies
n_scott_pearson
Super User Retired Employee
253 Views

Forget that bad batch drivel. It's not the NUC. By having it replaced, you've proven that​. It is either your memory or your storage. Look at those.

...S

schmosef
Novice
253 Views

I'd like to think that you are right about the NUC not being at fault, but the CPU is failing the Intel Processor Diagnostic Tool test.

 

Do you have one of these NUC8s? Does it pass the test?

 

I've run full tests of the RAM with MemTest86 and the Windows Memory Diagnostic. Both tests found no errors.

 

Windows Event Viewer is not showing any errors in the timeline leading up to the hang. It just logs the fact that the computer was restarted unsafely.

 

The failed processor diagnostic test might be a red herring but there are no other problems being reported by the system.

 

If you have any suggestions for diagnosing this further, I'm all ears.

 

The only other thing I can think to try is to take out one of the memory sticks and see if the problem persists.

n_scott_pearson
Super User Retired Employee
253 Views

My BE NUC runs the iPDT without issue. I have 256GB Toshiba/OCZ RD400 NVMe SSD as system drive and 1TB Seagate Barracuda HDD as data drive. I have 16GB (2x8GB) Crucial (always Crucial) DRAM.

 

When testing DRAM, start with only one SODIMM installed. Test it twice, once in each socket. Do the same with the other SODIMM. Finally, if everything has succeeded, test with both SODIMMs installed. Test using MemTest86 (or MemTest86+) and with iPDT and for your Windows hang. Additional comments:

 

  1. The test tool doesn't catch all memory issues. I have, on a number of occasions, seen bad/incompatible memory test just fine but fail in practice.
  2. Did you reinstall Windows after getting the replacement unit? If not, the problem could be something in your Windows image. A reinstall might be appropriate.
  3. They will hate me for saying so, but I don't trust iDSA as far as I can throw it. I download the packages (including BIOS updates) from the Intel Download Center and install them manually.
  4. Never install BIOS Updates from within Windows. Always download the .BIO files and install them via the F7 method.

 

If you are using an NVMe SSD, it too can cause issues. In fact, there were a bunch of reports of Samsung 970 drives causing issues out of the box. Replacing them fixed the problem.

 

As for contacting Intel, don't be shy, pick up the phone and call them.

 

Hope this helps,

...S

 

schmosef
Novice
253 Views

Thanks for the advice.

 

I found something online about changing the Windows compatibly setting for IMC.exe to Windows 7. I did that and now the NUC passes the IPDT test.

 

I'm testing the RAM in isolation now. I really hope it turns out to be a problem with the RAM, because that's an easy fix.

 

I'm using Corsair RAM. That's what the store had in stock, when I bought the NUC. 2x16GB.

 

I am using a Samsung 970 evo plus NVMe SSD. I hadn't heard that there were problems. I'll look into that, too. The Samsung software says it's got the latest firmware installed.

 

I didn't perform a clean Windows install because it took a long time to get all the software I use installed and configured. But you make a good point. I'll run the Windows SFC tool to see if it detects any corrupted system files.

 

Interesting thing about the BIOS: The first time I booted the replacement NUC, it started to boot Windows, paused for a moment and performed a BIOS update, all without prompting. Then it booted Windows normally. I just had to reactivate the Windows license after login.

 

 

R_Kede
New Contributor I
253 Views

I'm having the same issue with my NUC kit ( my cpu is core i3 ).

INTEL support team have replaced my NUC but the same issue persists with my new NUC.

my memory module is Intel validated.

I'm glad to hear I'm not the only one with the issue.

Everyday I must unplug my NUC from the power outlet & restart it all over again.

I can prove it with my SSU report.

Read about it here

https://forums.intel.com/s/question/0D50P00004PmbXVSAZ/nuc8i3beh-sleep-awakening-problems-again?lang...

schmosef
Novice
253 Views

I just read through your thread. It must be very frustrating.

 

I have sleep disabled on my NUC, so I haven't run into your issue.

 

After taking out one of the RAM modules, my NUC has been stable, so far. I'm going to follow the advice above and test the RAM module in the other socket, then test the RAM module that I removed.

 

I hope I can isolate my problem to a specific RAM module, which is easy to replace.

n_scott_pearson
Super User Retired Employee
253 Views

@R.Kede​,

 

Let's be very clear: Your memory module IS NOT Intel validated !!! Samples of your memory module type may have been put through compatibility testing by Intel, but your particular memory modules have never been validated (not unless you did it yourself).

 

...S

 

n_scott_pearson
Super User Retired Employee
253 Views

@schmosef​,

 

So, just to be sure, your hangs were NOT as a result of going to sleep and not properly waking up, right?

 

[Aside: Actually, in almost all of the reported cases, the NUCs *are* waking up, they just do so without waking up the monitor interfaces as well 😴 (regardless, the result is same; a reboot is necessary to get the monitor(s) working).]

 

Let me know how the DRAM testing goes. It takes a considerable time, I know. It was way worse back in days of the Intel Desktop Boards business; we had to ripple test single DIMMs across four sockets and then test the various two-DIMM combinations as well.

 

...S

schmosef
Novice
253 Views

My hangs were NOT related to the NUC failing to properly wake from sleep. I have sleep disabled.

 

The hangs always happened while I was actively using the NUC: surfing the web, watching a YouTube video, browsing with File Explorer, running 3DMark or PerformanceTest, etc.

 

There was no consistent way to cause it to hang. It would just happen randomly.

 

Come to think of it, it does seem like a RAM issue. But I've never had bad RAM pass a full MemTest86 test before.

 

It's been about 24 hours since I took out one of the RAM modules and the NUC has been stable. I've been throwing a lot of multitasking at it and it's been fine.

 

I'm going to cycle the RAM slot and then swap out the installed RAM module for the one I removed.

 

Thanks for your advice on this. Fingers crossed, I'm on the verge of permanently resolving my issue.

Reply