Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LJoha4
Beginner
1,048 Views

Bios update problem

I have an old NUC that start to feeze after lastest Windows 10 upgrde (1809).

So as a start of troubleshooting i was planning to upgrade Bios first.

It felt like it did go like a charm, it found that bios file och it start to flashing and said DONE

and then restart. But after restart the machine will not now boot any more. I have blue flashing on the NUC and then it restart.

 

I have a movieclip of this behaviour, see here.

https://1drv.ms/v/s!AoYBVswIgL-IkRbb7bPKpmFtw5JL

 

And the model of my NUC is here:

https://1drv.ms/u/s!AoYBVswIgL-IkRdp3B2SCA17Soia

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
111 Views

What you are seeing (i.e. the three flashes) is the NUC indicating that it failed to initialize memory.

 

First thing to try is resetting the SODIMMs:

 

  1. Unplug the NUC's PSU from A/C power.
  2. Without unplugging anything, flip the NUC upside down.
  3. Remove the bottom cover.
  4. Remove your SODIMM(s) and then reinstall them.
  5. Leave the bottom of the NUC open.
  6. Reconnect PSU.
  7. Flip the NUC up onto its side and power it on.
  8. If this fixed it, great, close up the NUC and you are done.

 

Next, try clearing CMOS:

 

  1. Unplug the NUC's PSU again.
  2. Remove the screws I circled in red in the picture below:IYE.jpg
  3. Carefully, pry up the board along the edge that I marked with a red line in the picture above. I use a small slot screwdriver against the edge of the board and press it outwards just a tiny bit to free up the USB connector and allow the board to be lifted. Note: you don't need to remove the board completely, just lift it enough to access the battery.
  4. There is a yellow battery pack attached to the board with a small cable (see picture below). Unplug this cable.NUC-battery.jpg
  5. Wait 15 minutes.
  6. Plug the cable back in.
  7. Push the board back down into position.
  8. Put the two screws back in.
  9. Put the NUC's bottom cover back on.
  10. Power up and see if the problem is cleared.
  11. If the problem is cleared, at the BIOS Splash Screen, press F2 to enter BIOS Setup (Visual BIOS), set the date and time and then exit. System should boot up.

 

Let us know how it goes...

...S

 

 

n_scott_pearson
Super User Retired Employee
111 Views

I forgot to mention, there is the possibility that the issue is as a result of the memory is failing (either the processor (its memory controllers), the board or the SODIMMs themselves are failing). If this was the case, it would explain the freezing that you were seeing (though seeing the freezing is not an absolute indicator that memory is failing). If this is the case, only through trying different SODIMMs could you determine that they were responsible and replacing them fixes the issue.

 

...S

LJoha4
Beginner
111 Views

Thanks so much for the reply and very good troubleshooting. I will try these things asap.

 

I have another NUC så i can easilly swap the DIMMs and do the aother things you mention here.

 

An update will come soon. :-)

LJoha4
Beginner
111 Views

No luck att all, i have now done the things you suggested.

 

  1. Remove the DIMMs
  2. Removed the cable to the battery and waited 1 hour

 

Any more tips? :-)

n_scott_pearson
Super User Retired Employee
111 Views

Only thing left to try is a BIOS Recovery.

 

  1. On another PC, place copy of latest .BIO file (GK0066.BIO) into the root folder of a USB flash disk.
  2. Properly eject this disk.
  3. Flip NUC upside down and remove bottom plate.
  4. Remove yellow BIOS Configuration jumper (remember the header and pins that it was on!).
  5. Insert USB flash disk into USB port on NUC.
  6. Turn NUC onto its side and press power button.
  7. The NUC should proceed on its own to do BIOS Recovery. A progress display, like what you see when doing normal BIOS update, should appear onscreen.
  8. If no display is presented, leave it sitting there for at least 10 minutes.
  9. If display is presented, wait for it to complete (it will tell you).
  10. Power off.
  11. Restore jumper to pins 1-2 of the header.
  12. Put the bottom plate back on.
  13. Remove USB flash drive.

 

Either it worked or it didn't. If it worked, great. If it didn't, well, I am out of ideas.

...S

LJoha4
Beginner
111 Views

Excellent, i will try this tonight.

 

It was this bios file i used when i flashed bios for the first time that i mentioned in my first time.

 

Thanks again

Reply