Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
214 Views

Boot freeze (solved)

My story is a little long but bear with me as it may be of interest to some users.

 

 

I purchased a NUX8i7BEH which I equipped with a 16 Gb DDR4 2400Mhz Corsair RAM and a 970 EVO Plus MVMe 500 Gb V-NAND Samsung SSD.

 

I then installed on it Windows 10 Pro and Ubuntu 18.04 LTS in dual boot.

 

Once done, I switched my system on, and lo and behold, everything worked fine.

 

I switched my system off. Then switched it back on and this time, the on/off switch lit blue but nothing happened with the exception of the SSD LED blinking on once or twice.

 

I switched it off, then back on again and this time… it booted uneventfully.

 

And so on and so forth. My system would sometimes boot, and sometimes would not.

 

I checked my install, went as far as erasing everything and re-installing Windows only as I thought that perhaps GRUB2 was not behaving as Intel expected a decent boot loader to behave in the boot sequence.

 

Same problem. My NUC would sometimes not boot.

 

I upgraded the BIOS to version 75 (the latest).

 

No change.

 

I erased the CMOS memory of my BIOS (F9).

 

No change.

 

I changed various settings in the BIOS.

 

No change.

 

I did a BIOS recovery.

 

No change.

 

At Intel’s suggestion, I upgraded both the HDMI firmware and the graphic driver

 

No change.

 

Please note that both my RAM and my SSD are approved by Intel

 

Intel very kindly offered to change my NUC8i7BEH. The exchange was swift and uneventful (thank you Intel!)

 

There I am, with my new NUC.

 

I switch it on and … same problem!

 

It boots when it is in the mood.

Please note that I had set a user password in the BIOS and that when attempting to boot, the boot sequence did not even reach the stage where I was supposed to enter my password. It froze before.

 

I started suspecting that some incompatibility existed with my display monitor.

 

I was using a nondescript display that I had salvaged from an old ASUS laptop that died on me a few years ago. The display was very clear and crisp and I could not resolve to dispose of it.

 

As a consequence, I made a stand for it and bought the following monitor kit which I installed on my ASUS laptop display to turn it into a monitor:

 

NT68676 (HDMI+DVI+VGA+Audio) LCD Controller Driver Board with an inverter converter monitor kit for a 1920X1200 LCD Panel LP171WU3-TLB3.

 

The new monitor worked fine. I am using it with all sorts of computers e.g. an Acer desk computer, a Raspberry Pi, etc.

 

Suspecting some sort of incompatibility with my NUC, I plugged in an LG Flatron M2262D and guess what? Everything now works without a hitch.

 

I can’t believe that I went through all this because of an incompatibility with a monitor. After all, a computer can boot without ANY display, can’t it?

 

So my problem is solved, but I feel a little frustrated that I can’t understand why I had it in the first place.

 

Thanks for bearing with my long story but if you took the trouble to read that far, and you happen to have an idea why this happened, please let me know!

 

(Many thanks to Intel Support which was very responsive!)

 

0 Kudos
3 Replies
Highlighted
Super User
15 Views

Glad you have it working.

 

"Please note that both my RAM and my SSD are approved by Intel" . Although not the problem, you can easily get bad memory/SSD that are on the tested/approved list.

 

Doc

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Super User Retired Employee
15 Views

Does this LCD panel support 1024x768? This is necessary for BIOS Setup (Visual BIOS) display. Should not have affected booting to Windows/Linux, however - unless it (also) connects to USB?

...S

0 Kudos
Highlighted
15 Views

Yes it does. The visual BIOS displayed well and the BIOS set up could be done without any problem. Connection to the NUC was HDMI.

0 Kudos